WIP (5.9.2017) :s-----l-----o-----w-----e------s-------t display ever ;)

Today I see no problems anymore with the graphics in Rhino 6 Beta and 5 64-bit. I don’t know, what’s going on here. Hm?!? So, no need to contact you neighbours at the moment.

Thank you

Hi @stevebaer,

I’ve got this behavior again, and found that this is related to my external monitor Eizo CS270. Switching the external monitor off and on again, it works. Not good. Hm?



Hi @stevebaer,

it was not the external monitor. I’ve played with the driver settings, and found that switching off antialising fixes the problem.




Hi @stevebaer,

I still have problems with this hardware. I have found this note to set the Intel video driver memory:

Rhino says “Video memory total: 2 GB”. This sounds a little bit much for a machine with 4 GB RAM in total.

Can I reduced this memory size in Rhino?



I’m not familiar with how Intel driver allocate memory. Rhino simply asks the driver how much memory is available and displays the results. It does not actually do anything like tell a driver how much memory to use.

What problems are you having? If you are looking to reduce video memory, I would assume the current problems are not video related.

Hi Steve,

it’s still the same problem. From time to time Rhino 6 freezes OpenGL views in Rhino 6. (Latest Rhino 6.7, Windows 10, 4 GB RAM, Intel HD 4000, driver date: Dec. 2017)

I don’t know why, and still guessing.



Is Rhino 5 64 bit also freezing? If that is so, then the 64bit display drivers are still being difficult. @jeff, do you have advice on reinstalling drivers?

Yes, Rhino 5 64-bit freezes too, Rhino 5 32-bit not.

Then this really looks like the 64 bit display driver is at fault. Rhino 5 and Rhino 6 are basically two 64 bit applications that use OpenGL in completely different ways.

I had this same problem on my 4-year old Asus laptop that used the Intel 4000 video drivers. The problem disappeared when I manually updated the video driver from the Intel website.

The only thing I can recommend trying here is to completely uninstall and delete the current video drivers using the Device Manager…and then re-install them…

Follow these steps…

  1. Start the Device Manager

  2. Expand the device tree (Note: My images show 2 display adapters, yours will probably only show one, the Intel)…so just work with that one.

  3. Right-click on the Intel display device and select “Uninstall”

  4. CHECK the option “Delete the driver software for this device” and then click “Uninstall” button

When it finishes, at this point you may need to reboot your computer… once rebooted, follow these steps:

  1. Go back into the Device Manager again (first image I posted above)
  2. Right-click the display adapter again (It probably will now say something like “Microsoft Basic Display Adapter”, and select “Update Driver”

  1. A Windows dialog will display…select the “Search automatically…” option:

You should then see the following series of screens:

Note: Your screen will probably flash and pop, and turn black…but should eventually return back to you…

Also, even if Windows doesn’t suggest you reboot, I would reboot again anyways, once the process completes.

If that still doesn’t solve the problem, you might try what Birk said, and install the drivers manually from Intel’s site.


Hi @Birk_Binnard and @jeff,

thank you for all your details. I now have deinstalled the driver completely, installed it again with the windows device-manager, and at the end installed the latest driver build (12-11-2017) again.

Now Rhino 6 works again, I hope this will stay.

Thank you as always and a happy sunday


ahhhhhh, 5 minutes later, after a Windows restart, Rhino 6 hangs again. I go nuts. :frowning:

10 minutes later, after 3 restarts, Rhino 6 runs again. I hate driver gambling. Now I pray for a stable system and set


for a good feeling, oh man.

nothing helps, Rhino 6 hangs again. Deleted the HKEY… thing, completely reinstalled Rhino 6, nothing helps. Now I spell my “Apple Macbook” curse, and throw this machine out of the window. I wish you a good flight. :wink:

That sucks. I wouldn’t typically make this recommendation, but you may have better luck with Windows 7. This definitely sounds like a driver problem and if both V5 and V6 are misbehaving, then there is little we can do to improve the situation.

As a parallel Win and Mac user I can confirm that Macs are good for Outlook only. Forget Apple products if you need computing power.

I’m not bending down.
But the same problem comes up with the current tablet PCs…

I’m not sure this is the same problem. Michael is seeing both Rhino 5 and Rhino 6 misbehaving on this laptop.

Hi @stevebaer and @jeff,

I just want to say thank you very much for the improved OpenGL settings/internals in the current Rhino 7.24.

I was able to resuscitate my Intel HD Graphics 4000 laptop, by setting OpenGL to 3.3.