Performance on Battery vs. Plugged in?

Hi there,
I just recently got a Lenovo Thinkpad P1 at work (I think that’s the model?) and am running Rhino 6 and VRay 3.6. My question is pretty simple - I’m noticing a dramatic change in performance when my machine is plugged in versus unplugged - I already tried changing battery modes so that it replicates the same performance as when the machine is plugged in, but I’m still having the same issues. The performance I’m talking about is just laggy navigation, nearly impossible to rotate models, pan views, etc.
I just don’t know exactly where or what I’m supposed to tweak to get the same performance on battery. I’ve tried looking it up but I’ve had no luck. If there’s a quick list of settings I can tweak to get the performance or if someone knows where I’m supposed to go to make those changes, if you could let me know - thanks in advance!

Why not post your Rhino System Info command results?

Well, the Windows power settings are the place to set those options, it may just be throttling heavily under battery regardless because it is an ultra-thin, too much heat off the battery.

Sorry for the late reply. Here it is:

Rhino 6 SR17 2019-8-6 (Rhino 6, 6.17.19218.13231, Git hash:master @ 62456cca9a849f28b1a160168ce8c7a1bc26010f)
License type: Commercial, build 2019-08-06
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DET-00028

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 4-9-2019 (M-D-Y). OpenGL Ver: 4.5.0 - Build

Secondary graphics devices.
NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 10-16-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build
Driver Date: 4-9-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19218.13231
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19218.13231
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19218.13231
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19218.13231
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The main Vray engine is CPU based. Your Power settings set to Balanced in Windows will drop the CPU power usage and speed when unplugged. Changing the power settings to use High Performance on both plugged in and battery.

This is probably in advanced power settings.

Hi - the SystemInfo that you posted shows that Rhino is using the Intel GPU - I suppose you ran the command when the PC was not plugged in?

Have you played with the settings in the NVIDIA Control Panel?
Manage 3D settings > Global Settings > Preferred graphics processor
There is a setting for Power management mode that you can change to Prefer maximum performance.

You could add a program-specific profile for Rhino so that you only switch to maximum performance when using Rhino.

1 Like

You might also look into updating the Nvidia driver if you haven’t already. Since it’s a laptop, Lenovo (Dell?) would be the first place to check. If they don’t have a newer driver you could consider trying the driver from the Nvidia download site.

wim, looks like I’m getting an error message when I try to open NVIDIA control panel - says “Application is not compatible with installed NVIDIA Driver.” I currently have a NVIDIA Quadro P2000 with Max-Q Design. Strangely enough it’s got a little
yellow problem icon under Device Manager saying Windows stopped the device because it has reported problems. Updating the drivers doesn’t do anything as I have the latest one, nor does disabling/enabling either.

I think my solution is under that control panel, I just can’t get into it!

Hi - it sounds like there is something very wrong with the installation of that GPU.

Please try a “clean install” of the drivers following the recipe posted here:

Make sure to include step 4 of the uninstalling process!

1 Like

Wim, you’re a lifesaver! Our IT is off for the weekend and I was just able to get my P2000 working using these steps.

Our department has a Quadro P5000 in a Thunderbolt 3 External GPU, and it looks like whenever I plug that in, the P5000 takes over and the P2000 in my laptop stop working entirely (and strangely enough stops any external displays from working either). So even after unplugging this external GPU, the P2000 didn’t come back online; I had to reinstall it and it’s going again. IT has been scratching their heads trying to figure out why the GPUs cancel each other, if they can work in tandem, etc.

You saved my workflow this weekend, thank you so much!