Rhino doesn't pick NVIDIA as primary display

Hi, I’m using a new laptop with hybrid graphics.
The rhino 7 doesn’t pick NVDIA as the primary display
i have tried the solutioin of


However, it doesn’t work, my OpenGL still appears as intel display.

Any helps will be greatly appreciated!

What’s the laptop? What’s the complete information in systeminfo in Rhino?

It looks like there’s no driver installed at all for the integrated Intel video. That doesn’t seem right even if you’re trying to not use it.

It’s Razer Blade 15, it is a company’s laptop.
Really dont know how to deal with this…
Here is the full systeminfo.
Thanks a lot!

Rhino 7 SR11 2021-10-20 (Rhino 7, 7.11.21293.09001, Git hash:master @ 972ac562128b307e99f15e56dd11586c73e91ecb)
License type: Commercial, build 2021-10-20
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [60% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: Microsoft Basic Display Adapter (Intel) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 1 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 10-13-2021 (M-D-Y).
> Integrated accelerated graphics device with 4 adapter port(s)
- This device is not being used

No graphics device is being used. Either an error occurred on startup, or certain devices have been disabled.
See below for any possible configuration changes that may help resolve this issue.

  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 2.1

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins that do not ship with Rhino
C:\Users\kwu\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21250.810

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

See if this helps:

Hi John.
Thanks for your reply.
I have tried this solution but it doesn’t work for me…

Well IT is going to have to look at it if that stuff is locked down…'cause it says right there that there is no device being used, there’s no driver for the Intel graphics and nothing is working.

Hi Jim,

I have checked the device manager
it appears normal

is it a rhino problem that it actually blocked the graphics…

No, a “Microsoft Basic Display Adapter” is a big problem. There’s no driver for the Intel graphics.

Hi -

That’s not how it works. Hardware resources are completely managed by the Windows OS and Rhino is only on the receiving end.

That does not appear normal.
The first display adapter that is listed is a “Microsoft Basic Display Adapter”. That should be some Intel of some kind. That looks like the result of uninstalling the drivers for that GPU and then not installing new ones.
Please make sure that you have rebooted the machine and read the following post - then try what Jeff suggested about finding the drivers for that device.


Thanks a lot Wim!
The problem already fixed.