Rhino WIP 8-Nov-2016 Display


#1

Much better graphics performance, thanks!


Rhino WIP 8-Nov-2016 Available
WIP Display issue on Intel GPU
(Brian Gillespie) #2

Oh yeah, I forgot that part. Shaded, Wireframe, XRay, and Ghosted modes all use a much more modern way of doing OpenGL drawing - they should look about the same, and may be a lot faster in some cases.


#3

Update: not sure if this is related, but there’s a bug where the camera and/or target distances get huge and then I can’t get back to the geometry until after restarting rhino. I can select the objecta with ctrl-a, but when I try to zoom to the selected objects it says Unable to zoom - no objects are visible.

There are also some glitches (improved over the previous version), where when switching between display modes, it looks like it brings up a frame from the past. So there’s a bit of flashing back and forth.


(Brian Gillespie) #4

@hanscad thanks for those details. Can you please post a video that shows the problem and a 3DM file that you use to reproduce it?


#5

Well, here i get a wireframe display in wireframe, in shaded, and in ghosted …
I get the same non working mess in rendered that has been the same for months and months…
I see a new display called arctic, that does indeed look like a white-out in a snowstorm…

so all in all, I cant use this wip at all, because the display is a mess…

I’m not complaining, just giving feedback…V5 is fine and rock solid.

cheers
rabbit

Rhino 6 SR0 2016-11-9 (Public Build, 6.0.16314.1241, Git hash:6.0.16314.01241 in branch n/a)

Windows 7 SP1 (Physical RAM: 7.9Gb)

ATI Mobility Radeon HD 4650 (OpenGL ver:3.3.11672 Compatibility Profile Context)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: ATI Technologies Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 11-16-2012
Driver Version: 8.970.100.7000
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Brian Gillespie) #6

@rabbit what about the current WIP (2016-Nov-15)?


#7

Pretty much the same Brian…
I include a zip file with screenshots of the same geometry in every display mode…

cheers
rabbit
rabbit_display_shots.zip (3.4 MB)


(Steve Baer) #8

Could you try the following?

  • Start Rhino
  • Run TestGLCoreProfile
  • Restart Rhino

Does shaded and ghosted mode look better? Please do no go into other display modes than wireframe, shaded, and ghosted when testing. We don’t have all of the kinks worked out in rendered, pen, … yet and I don’t want those modes to affect this test.

Once done, it is probably best to run TestGLCoreProfile again and restart Rhino.

Thanks


#9

Sorry - no change at all - all those modes are just wireframe…

Cheers
rabbit

—Sent from mobile device & email—


(Steve Baer) #10

@jeff any ideas of what to try? I would really like to NOT force a driver update while working on the WIP in the hope that we can work around driver issues.

My current thought is to tweak the CHECK_GL_ERROR function in Rhino so it compiles in release builds and is only run when enabled through a test command. Wire drawing is pretty darn complicated in the WIP and that appears to be working on Tony’s computer. I bet we would get an error report when attempting to draw the shaded meshes.


(Steve Baer) #11

Tony, are your display modes the default modes or have you tweaked with them? I noticed there is no grid in your screenshot and that got me wondering if the modes have been modified.


#12

Yeah - they are all default (I just hate the grid!)

cheers


(Jeff Lasor) #14

@stevebaer Interesting… No ideas here at the moment… It is curious though that his drivers are 4 years old and that they only support 3.3 compatibility mode.

@rabbit When you run the TestGLCoreProfile command, can you grab a screenshot of Rhino’s OpenGL settings page?

Thanks,
-Jeff


#15

Here you go…


(Jeff Lasor) #16

Ok Thanks… I have an HD 6950 here…so I guess I’ll throw together a W7 machine and see what happens…The problem is that I will be using the latest drivers…but hopefully it will fail.

-J


(Jeff Lasor) #17

@rabbit @stevebaer

Ok, well I setup a Windows 7 Ultimate machine and installed a Radeon HD 6950 and the latest Rhino BOTD. The earliest drivers I could get my hands on was July 2015… So far everything is working as expected here… I’ve maxed out all my settings too.

So I’m not sure where to go from here… other than see if the July 2015 drivers work for you. However, I believe Steve is working on some more diagnostic capabilities…so we would like you to hold off on any driver updates until we can gather more information…


#18

Thanks Jeff
This is a Toshiba satellite laptop - I can’t update the drivers beyond what I’ve got anyway…(unless there is some complicated hack which I don’t know about…)

Cheers
rabbit

—Sent from mobile device & email—


(Steve Baer) #19

Hi Tony,
I the latest WIP I added a test command called “TestGlWarnings”. Please run this command and restart Rhino. I would be interested to see if you get an error message and if so what the message is. This will help me find the general location in the display code where things are going wrong on your computer.

Thanks,
-Steve


#20

OK Steve -

The first screen shot is what happened immediately I ran the command.
The second is what happened after restarting…

cheers
rabbit


(Steve Baer) #21

Thanks! It may take a few WIPs to figure out the exact location of the bug, but this helps a lot.