WIP (5.9.2017) :s-----l-----o-----w-----e------s-------t display ever ;)

The intent is to make Rhino responsive. In your case this is not happening and dynamic downgrading is kicking in. I’ll keep investigating this line of GPUs.

On the 10 10 WIP I’ve used it in bootcamp of macbook pro i5 8GB with Intel hd 5100
comes to a complete halt…
need to hard reboot.
Turning tessellation off makes it going though it’s a bit slow on view other than wireframe.

1 Like

That is a sure sign of a driver crash. These are really hard to work around.

Is Rhino slow with all models/display modes on this computer?

Maybe doing a full Rhino 6 removal and reinstall can help too. I did that on one occasion to get rid of some old settings and also had to do so a few times during the v5 wip cylcle. (By the way I wish there was a McNeel tool to remove all Rhino WIP related settings in the regestry and all files related to the program)

1 Like

There are almost no settings saved in the registry anymore. Open file explorer and go to

Deleting the settings directory and the Plug-Ins directory will delete all of the saved settings and force Rhino to use defaults.


And if you feel like it, maybe even just rename the settings folder, so that the XML files can be compared once you have configured Rhino to work again as you normally do.

Wireframe seemed ok. But I haven’t done much like just drawing a curve and making one extrusion.
I need to open some files to check.
Maybe I’ll try installing different version of the driver.
Any report from anyone using bootcamp?

Sounds good.
I also have a Surface Pro 4, i5, Intel Graphics as well.
V5 runs super, V6 not.

Sounds good, but did this change during the WIP stage, because I have lots of settings under each “plugin” folder of “Rhinoceroc - 6 - Plug-Ins” in HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE and also some in HKEY_USERS

(Click image to see full length, and still that is about half)

Those values are still stored in the registry. That is a list of where plug-ins are located and what their commands are.

1 Like

Hi @jeff, and @stevebaer,

with the latest Windows 10 updates Rhino 6 Beta and now also Rhino 5 64-bit (SR14) are still runing in slowness mode. One click in the viewport every 10 seconds is possible. Remark: Rhino 5 32-Bit is running normally without this slowness.

Here again my system info:

Rhino 6 SR0 2017-12-5 (Rhino WIP, 6.0.17339.11131, Git hash:master @ 01128be76fcfa21764b3cd10786b227fe05fc7bb)

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)

Intel(R) HD Graphics 4000 (OpenGL ver:4.0.0 - Build

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  Vendor Name: Intel
  Render version: 4.0
  Shading Language: 4.00 - Build
  Driver Date: 4-4-2016
  Driver Version:
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 2114912 KB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp	"Commands"	
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp	"WebBrowser"	
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp	"Rhino Render"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp	"Displacement"	



Hi all

I had a similar issue with WIP versions on my DELL Precision with Quadro K1100M graphics. Wireframe mode was ok, comparable to v5, but any shaded mode suffered a lot of lag when trying to move around the viewport.

Since updating to BETA, the problem has altogether disappeared!


If Rhino 5 (64 bit) is now running slow, I would assume there is a problem related to the Intel 64 bit OpenGL drivers in Windows 10. Sometimes Windows doesn’t do a great job of updating graphics drivers when the operating system updates. I would see if there are new Intel drivers available for the Intell HD 4000 as a first shot.

I hate telling people that they need to update their drivers, but in this case if things suddenly became slow after updating Windows this is the first thing to point fingers at.

Hi Steve,

I’ve followed this instruction, and ended up in the result “Windows has the latest drivers, there is nothing to update”

Then I have downloaded the latest driver from Intels homepage:

The installation fails with the warning “this system doesn’t have the minimum requirenments”:

What to try next?



I wish I knew. Am I correct in that the performance drop happened in all versions of Rhino after you performed a recent update of Windows? If that is the case, I could try to contact someone at Microsoft to see if there is anything they can do.

Hi Steve,

it seams that the driver was not updated, when I compare the current Driver Version: (now), to the Driver Version: from 4 months ago (5. Sept 2017).

Rhino 5 32-Bit and Rhino 4.0 (hardware acceleration on) work without problems.

So, perhaps it is another Windows 10 problem. Yes, Microsoft should contact me about it. (I can’t use Rhino 5 64-Bit and Rhino 6 Beta anymore on my main PC).



Is there something you want me to do? I want to help, just not sure what the best next step is.

What do you suggest, is there an official support way? (Microsoft is your neighbour :wink: )

Ha! I chat with my neighbors less than people from other parts of the world.

I have one contact at Microsoft that I can try. I’ve never had much luck with finding the right person to talk to, but it doesn’t hurt to try again.

Don’t you have some chrismas-markets to go outside in the cold? :wink: We love these x-mas market meetings.

Yeah, better a try, than nothing.