Latest Rhino 8 runs at 0.01 FPS - unusably slow! Rhino 7 runs fine

I’ve been struggling with all Rhino 8 WIP releases in terms of performance being noticeably slower than Rhino 7, but yesterday’s release brought it completely to a halt. It runs at around 0.1 FPS making it completely unusable.

I urgently need to diagnose it and I don’t know where to start given that Procmon takes ages to start as well. Any suggestions would be greately appreciated. Any way to trace graphics call it makes?

If that’s of any help, whenever it “lags” it also “swallows” the cursor and the keyboard preventing the system from inputting any global windows shortcuts.

Latest Graphics Driver for an Nvidia’s P2000 5GB card.

Hi Daniel,

no idea, I would start with these downgraded OpenGL-settings:

Good luck


1 Like

Thanks, I’ll need that.

Tried that, same results.

I’ve tried copying all the settings from Rhino 7 to Rhino 8 and it didn’t change anything. It does have something to do with settings on this particular computer, because running the same model on another copmuter runs only as slower as in the previous Rhino 8 releases - but still nowhere near normal Rhino 7 performance.

Any way to diagnose running Rhino instance will be very much appreciated.

Right now, it’s completely stuck, unable to even rotate the viewport.

Type SystemInformation in the commandline and post your specs here. I think then the McNeel support can help you.

1 Like

Please see below. If anyone could please check what major changes could have happened since version 8.0.22305.12305 it would be amazing.

Rhino 8 SR0 2022-11-22 (Rhino WIP, 8.0.22326.12305, Git hash:master @ d91c600ecef5c4d78353fa4054849e18d690c58d)
License type: Commercial, build 2022-11-22
License details: Cloud Zoo
Expires on: 2023-01-06

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 9-12-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.40
    > Accelerated graphics device with 4 adapter port(s)
        - Secondary monitor attached to adapter port #0
        - Windows Main Display attached to adapter port #1

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 2.1
  Anti-alias mode: None
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 9-12-2022
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp	"Commands"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\RPC.rhp	"RPC"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoBonusTools.rhp	"Rhino Bonus Tools"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRender.rhp	"Legacy Rhino Render"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\Constraints.rhp	"Constraints"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp	"RhinoRoslyn"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp	"RhinoCPython"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp	"Constraints UI"	8.0.22326.12305
  C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp	"SectionTools"	

Worth noting that none of that would be necessary if Nvidia’s support for Linux drivers wasn’t suboptimal and I could just use my own laptop at work.

I don’t understand your Linux statement. FYI Rhino doesn’t support virtual systems like VMWare, etc., see here: Rhino - System Requirements

Sorry, please ignore it, it’s irrelevant to the problem at hand.

However, if you knew if there’s any way to reinstall previous version of Rhino that would be really helpful:

Is the only way uninstalling the current version? I’d rather not lose all the settings…

Also a possible culprit, but as mentioned above Rhino 7 works fine despite:

McNeel support recommends often first to repair the installation, and not to reinstall:

Old installation files are only available from on request.

Sorry, I’ve missed that icon and reinstalled it before seeing your message. Fingers crossed though this will be still fine.

EDIT: good news is that reinstalling didn’t change any of the customizations.
bad news is that after reinstalling the same problem persists.

Just a short remark, are your viewports set to Shaded or Rendered, and not to Raytracing?

They are set to “Wireframe” - yep, this bad :frowning:


I’ve reinstalled 8.0.22305.12305 - it’s working okayish again…

If I won’t solve it, it’s either getting Nvidia Optimus to work, or I’ll be stuck on 8.0.22305.12305 for a while…

That NVIDIA Quadro P2000 is getting somewhat old but it should be fine to run that with OpenGL 4.6.

You could try a clean install of the GPU drivers or creating a Rhino scheme that doesn’t have any customizations to check if those have an impact.

1 Like

Thanks, I will give it a try.