Rhino 6 Freezing Without Warning-Computer Becomes Unusable

Run the Rhino command SystemInfo and post the results here.

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Educational, build 2019-12-17
License details: Cloud Zoo. In use by: Preston Baird ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-PRESTON

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 12-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-24-2019
Driver Version: 26.21.14.4187
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Did you add any plug-ins such as V-Ray after purchasing the educational license?

Rhino 6 SR22 was released on Tuesday. It may or may not help. Normally updates will automatically install if automatic updating is selected but it sometimes takes a day or so.

Click on Help. If it says an update is ready to install close Help and then Rhino.The update should install. If it says “This Rhino is up-to-date” then if you have SR21 that means that it has not checked for updates recently. To manually check for updates first make sure in Update frequency that Service release is selected. Then click on the blue “Check Now…” on the right side of the panel.

Hi Preston,

Some questions:

  1. When you bought your Rhino licence, did you just apply the licence or did you reinstall the software as well?
  2. Did your problems start immediately you applied the licence or was there a period of days before they started?
  3. Between your trial working ok and the problems starting did you make any changes to your hardware (such as installing more memory)?
  4. Between your trial working ok and the problems starting did any Windows updates get installed?
  5. Are you working on the same model as you were during the trial?
  6. Have you tried creating a new model to find out if the problems are model-specific?
  7. Is your PC a stock machine from a manufacturer or a home-build?
  8. Are there error messages in the Windows logs that tie in to your problem episodes?

The symptoms you describe (particularly as Rhino is not the only program to have been affected) suggest that you could have a memory or disk issue, or you may be suffering from side effects from a Windows update (lots of reports of problems with recent ones). But that’s not for sure, so the more info you can provide the better.

Regards
Jeremy

Hi Jeremy,

I did a fresh install of Rhino with the license I bought. Also, I just updated to SR22 per David’s suggestion.
It was a period of days before the issues started, and yes around that time I recall installing a Windows update, and since then I have continued to get the newest Windows update hoping the problem will go away.
I tried making a new model yesterday, nothing complex, and had the same crash behaviors.
No new hardware was ever added, changed or removed since this machine was built. I built it myself last August and from then all through the fall I used Rhino for class and never had any issues until purchasing the education version in late December. I think we can rule out hardware because of that.
I am not working on the same model as I was during the trial, and have tried that model with the paid version but I was not able to get it to crash.
As for the Windows logs, where would I locate those?

I doubt the crashes are due to the change from the evaluation license to the educational license.

When did you install V-Ray?

There have been reports of problems related to Windows updates.

This may be significant. How large is the current model? Does it have any textures or other bitmaps?

Added: Does the current model cause any problems on your laptop?

Right click the Windows icon in the task bar and select Event Viewer. Don’t be overwhelmed by the number of entries you see! Choose Windows Logs - System and filter to limit the display to Errors. Look particularly for memory or disk-related messages.

Have you, since the problems started, been able to make any new models that did not exhibit problems? Have you tried starting from different templates?

I would run the file rescue utility in Rhino to analyse one of the files that repeatably exhibits problems (Create a new, empty model and run _Rescue3dmFile. Select your problem file and then take the Analyse option. Copy and paste the results into a text editor and search for Error.) to see if it is damaged.

I would also run the Windows command chkdsk to eliminate the possibility of disk corruption.

As a final resort, I would uninstall Rhino, download the latest release from McNeel, and do a clean install.

And try first without reinstalling the V-Ray plug-in as well if you go on the path of reinstalling. Or alternatively disable the plug-in in Tools > Options > Plug-ins and restart Rhino.

I got rid of V-Ray entirely. I have not seen Rhino crash recently but I have mainly been doing renders, not making new shapes.
I have not tried from new templates but no file has ever run on this computer without the crashes. They have all been on the normal template with Feet as the units.
As for the event logs, I am not sure how to interpret them. Nothing is labeled as memory or disk though.
chkdsk was normal and said there were no problems.
I used Illustrator again today and it was behaving the same as the Rhino crashes but I could not even ctrl+s so it essentially damaged my file to the point where I could not open it. Rhino is at least letting me ctrl+s when it crashes.

I will try to reinstall Rhino from McNeel. Maybe it is also worth noting that last night I took the file I have been working with which like all the others since the issues started, has exhibited crash behaviors, and I tried it on my laptop. Never had a single crash, but did realize the entire time my laptop was running SR20, so I updated it to SR22 at the end of the night and didn’t work anymore on that file. I am wondering if it is a Rhino issue because an older version of Rhino with the same file never crashed the entire time I used it.

Hi - please keep using Rhino without V-Ray to check if that stops it from crashing.
The fact that Illustrator also crashes your PC, though, points to other causes.
One thing could be hardware - have you monitored the temperature of your system?
The other usual suspects are the GPU drivers. You could try a “clean install” of the drivers following the recipe posted here:

Make sure to include step 4 of the uninstalling process!
-wim

Are you able to post the file here? Helpful to try it on a “known good” setup.

Jeremy

Here is the one I have been working with for several weeks. It has exhibited both types of crashes.
Problem File.3dm (15.6 MB)

Here is another file I made recently with the same crash behavior, to show that even fairly small files are experiencing the issues.
Dumpster 3D Model.3dm (592.0 KB)

Even with the driver steps I got the same exact freeze/crash behavior as before on that dumpster file. I would expect the same on the large one too. I am really at a loss, this is very frustrating.

I’ve been messing about with your dumpster file and everything has worked normally so far. How many operations can you do before you start to experience problems? What type of operations are you doing just prior to their appearance?

It seems to depend…Sometimes I can work for quite awhile before it screws up. Other times it is within 10-20 minutes of opening it and starting work. I notice the problems always occur when making 3D objects, moving objects, and especially when aligning my snaps to corners, midpoints, etc. it seems to struggle with those tasks for some reason. The guidelines that they create also like to freeze up in conjunction with all of those things. I have also noticed occasional stuttering and recently I was changing the walls on that large file to a different layer and after changing the layers they would stay selected until I clicked on them again and hit esc. Normally you can just click somewhere/hit esc. to deselect. Not sure what is up with that or if it is related to the issue…

Just as a means of ruling out: could you monitor the temperatures in your machine? Motherboard, CPU, GPU, etc. See if these climb a lot just prior to your machine freezing. If they do you may want to blow out the dust from all moving parts and heatsinks.

You may have more than one problem. Having issues with Illustrator as well as Rhino suggests a fault outside of Rhino, while the problem appearing on your laptop after updating Rhino suggests a fault within it.

As well as monitoring your PC temperature, I would suggest you ensure your motherboard bios and drivers are up to date. Also check that your specific memory is on the mobo manufacturer’s approved list. Check that the memory is properly seated. If you have overclocked CPU and/or memory try more relaxed settings. Try temporarily removing half the memory.

As far as Rhino goes, I haven’t reproduced your experience, but I’m afraid I don’t have the free time to keep at it for hours. That said, I am running a 6.23 service release candidate, not 6.22. So you could try changing your Rhino update settings to SRC and download 6.23.

Jeremy

UPDATE

After continuing to have problems despite the wealth of suggestions on this topic, I decided to bite the bullet and do a “fresh start.”

I need to emphasize that this will give the option to keep your personal files, but Windows will uninstall most of your applications, including Rhino along with Autodesk and Adobe products, which you will need to manually install. However, a cool feature I noticed is it will (at least for me) generate a list of all of the applications it uninstalled and even has links to some of the places where you can reinstall them.

Anyways, the conclusion of this, after reinstalling Rhino, was that I have been able to complete the same tasks that were causing my system to freeze prior to this Windows “fresh start,” and I can now use Rhino and even the same files as before and experience none of the problems.
Windows Settings > Windows Security > Device Performance & Health > Fresh Start > Additional Info
At this point it will ask if you want to get started, and then you have the choice of wiping everything, or wiping programs but keeping your personal files. Definitely still do a backup of anything you may worry about losing prior to doing this. As I said, once it is finished, edits to the registry

I hope this helps if anyone else runs into this really niche-seeming problem.

1 Like