WIP (5.9.2017) :s-----l-----o-----w-----e------s-------t display ever ;)


#1

Hi…,

with the latest WIP the display is soooooooo sloooooooow, that it took me 1 minute to draw a box.

Even when I switch all OpenGL stuff off, nothing changes.

Cheers

Michael
www.flexiCAD.com


(David Eränen) #2

Hi @Michael_Meyer,

Could you post the information Rhino displays in Help -> System Information…?

Also, what display mode are you in when you create the box? Wireframe, Shaded, Rendered or something else?

-David


(Steve Baer) #4

That is an older Intel GPU which we automatically don’t use tessellation shaders for drawing wires so changing the checkbox value on the OpenGL page won’t make any difference. I believe I have one of these in my pile of test computers. I’ll pull it out and see if I can repeat the problems you are seeing.

Did you restart Rhino after setting UserHardwareDriver to False? That is probably necessary for testing. Setting that value to false is really a last ditch effort to try and keep Rhino running as it switches display over to a legacy software based OpenGL that will not support much more than basic wireframe and shaded drawing.


#6

Hi @DavidEranen and @stevebaer,

bellow my system info from my MacBook Air 2012 running with BootCamp. I draw a box in wireframe mode. Even rotating the viewport in wireframe mode brings Rhino to sleep. After 5 seconds its back.

Yes, after several restarts nothing changes. There is no difference if OpenGL.UseHardwareDriver is on or off.

Rhino 6 SR0 2017-9-5 (Rhino WIP, 6.0.17248.9001, Git hash:master @ 7e347fcf24857788f05ec55ceedd96f3405c685f)

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)

Intel(R) HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4425)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: Off
  Redraw scene when viewports are exposed: Off
  
  Anti-alias mode: None
  Mip Map Filtering: None
  Anisotropic Filtering Mode: None
  
  Vendor Name: Intel
  Render version: 4.0
  Shading Language: 4.00 - Build 10.18.10.4425
  Driver Date: 4-4-2016
  Driver Version: 10.18.10.4425
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 2114912 KB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp	"Commands"	
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp	"WebBrowser"	
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp	"Rhino Render"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp	"Cycles for Rhino"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp	"Displacement"	

Thank you

Michael
www.flexiCAD.com


(Steve Baer) #7

Did this just start with the latest WIP or have you not been using WIPs on this computer for a while?


#8

Hi @stevebaer,

I update the WIP all 3-4 weeks on this PC. In the past wireframe mode was fine. Shaded and Rendered viewports were often much slower than in Rhino 5.0 from my feeling.

Thanks

Michael
www.flexiCAD.com


(Steve Baer) #9

Ok, I’ll see if I can repeat this with an Intel 4000 GPU here. @jeff anything you can think of that may have caused this recent change?


(Jeff Lasor) #10

I would like to see a screenshot of the TaskManager CPU page when this “slowness” occurs. It sounds like something is sucking up CPU… Drawing a box on even the worst hardware should be pretty instantaneous, so something is obviously getting in the way.

I just looked at the UseHardwareDriver setting, and it looks like it’s broken… checking or unchecking it doesn’t seem to do anything…I’m always in a hardware usage mode. So we need to fix that if it’s ever going to be used as a diagnostic tool.

@Michael_Meyer Start the TaskManager,

Then…

  1. on the top Menu, select “Options” and make sure “Always on top” is CHECKed
  2. Go to the Performance tab and click the CPU icon…
  3. Then make sure ALL CPUs are being displayed (right click on the graph and select “Change graph to->Logical processors”.
  4. Start Rhino and draw your box…
  5. Try to get a screenshot of the TaskManager (i.e. push the PrntScr keyboard key and then paste it here).

It should look something like this…

… I just want to rule out anything that might be bogging down your CPU.

Thanks,
-Jeff


#11

Hi @jeff,

bad news, cpu is doing nearly nothing, while drawing the cube (took about 80 seconds ). Even rotating an empty viewport is nearly impossible (all 5 seconds a new frame, and a CPU usage at around 2%).

All the best

Michael
www.flexiCAD.com


(Jeff Lasor) #12

@Michael_Meyer
Actually, it’s good news… it means that it’s definitely something in Rhino…which theoretically, means we can fix it… At the moment, I’m at a loss…but give me the weekend to think about it and hopefully we’ll having some things you can try on Monday.

Thanks,
-Jeff


(Jeff Lasor) #13

Also @Michael_Meyer, as a side note… It looks like you haven’t hard booted your computer in over 5 days… So just to eliminate some kind of accumulating corruption thing…please fully shutdown and reboot your system.

Thanks,
-Jeff


#14

Dear @jeff,

OK, I have rebooted. Rhino WIP behaves the same.

Thank you

Michael
www.flexiCAD.com


#15

Hi @jeff,

I’ve tested the latest WIP (Sept., 12), no change in the display behavior.

Thanks

Michael
www.flexiCAD.com


(Jeff Lasor) #16

Thanks @Michael_Meyer… we’re still thinking about this one.

-J


#17

Steve/David,
I have installed the most current WIP update and my system crashed once again while rotating very simple geometries, which Rhino 5 instead manages without problems.

Once again, I have tested the performance difference with Rhino 5, using TestMaxSpeed, with no whatsoever geometry in the new file. Here are the results on my system (still a Macbook Pro 17" with Windows 7 Pro installed on Bootcamp).

Rhino 5.0
Time to regen viewport 100 times = 0.25 seconds.

Rhino 6 WIP
Time to regen viewport 100 times = 0.38 seconds.

Regards,
Luca


#18

Hi @jeff,

FYI with the latest WIP (10.10.2017), the graphics is great and normal again with OpenGL on or off. No problems anymore here.

Thank you very much and have a nice weekend

Michael
www.flexiCAD.com


(Jeff Lasor) #19

@Michael_Meyer
Great news! Thanks for the the update.

When was the last WIP you used where it still did not work? If you can remember.

Thanks,
-J


(Steve Baer) #20

@Charles, Michael has a similar GPU. How is the latest WIP on your Surface Pro 3?


#21

Hi @jeff and @stevebaer,

the WIPs from last week and before didn’t work. The WIP from this week is the first one without these graphic problems.

Thank you again

Michael
www.flexiCAD.com


#22

@stevebaer,

with WIP 10-10, it feels a bit better.
But only because when manipulating a shaded view, Rhino switches to Wireframe and back to shaded when done.
Nice trick, but not very amusing.
Is this really intended?

I still wish V5’s responsiveness back.


BTW, it is a Surface 3, not a Pro.