Black screen

Can you run _SystemInfo in Rhino and copy/paste the results here?

Try a '_4View command. This step has helped me many times.

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Licenza lab educational, build 2023-02-27
License details: Cloud Zoo
Expires on: 2023-11-01

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 8-25-2021 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Laptop GPU (NVidia) Memory: 4GB, Driver date: 11-13-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.98
> Integrated accelerated graphics device with 1 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-13-2022
Driver Version: 31.0.15.2698
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I tried but nothing change

If you right click on the desktop and choose Display Settings, and scroll down to “Graphics” -

Click on that, and see if you have an entry in there for Rhino. If not, add one.

Then, hit Options

and make sure it is set to use your NVidia card (High Performance).

Does that help?

no i tried also that but it continues to do the same thing
I also tried to unistall and reinstall it but nothing changes

Your video drivers are a bit out of date, not sure if they’re enough to cause a black screen.

If you go into Options > View > OpenGL and uncheck GPU Tessellation, does that help any?

im not finding them sorry… i go in options but then im not seeing “view”

no i done it, i found it but nothing changes

nothing change :c

What if you start Rhino in Safe Mode?

that works wtf

Well it disables all the OpenGL stuff. You can reduce the OpenGl support in regular Rhino in the same area Mitch was pointing you to.

The drivers for both of your cards are a bit out of date, have you updated them yet?

yes i done what Mitch said and i uptated the drivers

but however if i uncheck GPU tasselation, nothing changes, all is black

Go to that same panel below the “tesselation” box and move the slider over to the left until it starts working. Mind you something seems fairly screwy that it’s not ‘working’ with a relatively modern Nvidia GPU.

Yes, it has all the symptoms of not actually using the NVidia card at all, the black screen stuff seems relatively common with the AMD cards at the moment.

Hi Edoardo -
I’d try a reboot and then checking that all Windows updates are installed.
After that, try a clean install of the drivers using the following recipe:

-wim