R6 - very slow viewport performance on laptop

Installed the latest Rhino 6 (6.2.18038.04101) on my Laptop (a Wacom Cintiq Companion) yesterday, and the viewport is unusably slow, even with an empty scene. There’s a 5 second delay after every redraw.
Latest driver for the on-chip graphics (intel HD 4000) is installed.
CPU: intel Core i7-3517U
Rhino 5 works perfectly well, and 3d-performance is basically fine for my needs.


There were viewport problems with the R6 WIP already, but then some versions worked fine again.

Thanks for looking into this!
Best regards

Any change if you use GPU tessellation? If not, how about if you change this advanced option to False?

I’m also curious if your v5 Options>View>OpenGL has hardware acceleration off.

FYI @stevebaer

The GPU tessellation checkbox shouldn’t make any difference for this specific card. Intel GPUs that support OpenGL levels less than 4.4 won’t use the GPU tessellation drawing routines at all since they are known to not really work.

1 Like

Thanks, but, well, it suddenly works! Didn’t change any settings, just started R6 somewhat later, and the viewports ain’t stuck anymore. No idea why.
So, sorry for the noise, but I wasn’t kidding…
Is it possible that the graphics card throttles itself down due to heat or something?
Best regards

On a HD520 with the latest Intel drivers, it does.
GPU tesselation has to be off.
Ok, a HD520 is not a HD4000.

What OpenGL levels do these drivers report? If the value is 4.4 or above then Rhino assumes they are new enough to try and use GPU tessellation


But GPU tesselation doesn’t work.

I guess we found yet another Intel driver that doesn’t work with GPU tessellation. All drivers that state that they support OpenGL 4.1 or above “should” support this feature. Unfortunately, some drivers just don’t do a good job of it at all. This is really the reason that a GPU Tessellation checkbox even exists on the OpenGL settings page. If it worked for all drivers that stated they support the feature, we wouldn’t need the checkbox.

I was able to install the newest drivers for the HD520 now.
GPU tesselation works OK now.

1 Like

That’s great news. Hopefully Intel will get this feature working in more of their drivers over time.

And hopefully they make more reliable drivers one day.
I have an app that shows all curves in front of the surfaces when MSAA is off; 2x AA (or more) heals it. The price is the lower performance.

The hardware itself is not so bad as some say.

I’m having the same issue that the original post was about. *I did find that if I have only 1 viewport open, everything seems to work ok. Once the four viewports are open, it’s impossible to work.

I have a desktop that this isn’t an issue. But my laptop it is. And the variable that it seems to be worse when I have my 4K monitor attached to my laptop. Which makes me think it’s a GPU problem?

I fear that even though I sent in my laptop for GPU repair/replacement, it could still be the culprit, but maybe not?

Here’s the info from My System Info:
Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)
Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
GeForce GTX 1080/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)
OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height
Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Does it still happen with load-protecting (disabling) all plug-ins that don’t ship with Rhino (Tools \Rightarrow Options \Rightarrow Plug-ins, use the filter combobox)? Do restart Rhino after disabling them.

The only plugin I have is Vray (although I would think Section Tools would be listed, but maybe that’s not a plugin?)

And I tried disabling, but same thing.

Do you have any of the GeForce Experience, Shadowplay etc software running? See if turning them off (I actually always opt to never install them) helps any.

Funny, I just watched that pop up on my screen. I’ll make sure it’s off and let you know if anything changes.

Thanks for helping at this late hour. I will have to check this out for real in the morning when I’m at work with my 4K monitor.

It is 07:24 in the morning here in Finland, rainy and cloudy, but I’m fully awake!

1 Like

Lately I had this ‘laggy performance’ problem even in Rhino 5 on the intel HD graphics. It disappeared after turning off “Use accelerated hardware modes” in the OpenGL setting.
I just tested this again, and now it’s fine even with that mode ON again. Yeah, not particularly logical.
Rhino 6 works fine now.
Just telling, for what it’s worth…
Best regards


Seems like turning off Geforce, etc maaaaay be making a difference. Will post again with updated thoughts