Rhino crashing on startup

Hi -

No, you won’t. In Safe Mode, plug-ins are not loaded. This includes certain plug-ins that ship with Rhino by default. Among other things, this means that you won’t be able to work in any shaded display mode.

At any rate, we’re seeing a lot of these issues in the past week or so and have now found that it is caused by a combination of an update to the latest Windows 10 version and drivers for the on-board Intel UHD Graphics 630 chip.

We are working on finding a way around this Microsoft bug and should be having a new build out within the next week if all goes fine. Until then, you can either roll back your Microsoft Windows update from 10.0.19042 to, e.g., 10.0.18363 or disable your Intel GPU in the Windows device manager. If you have an external monitor (i.e. not a laptop’s own display), make sure that is not connected to the HDMI port of your machine but directly to the NVIDIA card in your machine.
-wim

1 Like

Awesome, thank you! I disabled the Intel GPU and it’s back to working.

2 Likes

Hi again -

I’m happy that got you on the road again.
Would you mind describing your system a bit more? Is it a desktop or a laptop machine? Are you connected to external screens? If so, did you also connect the screen (or one of the screens) to a different port on your machine when you disabled the Intel GPU?
Thanks!
-wim

It is a desktop, connected to a monitor. I didn’t connect the screen to a different port when disabling intel GPU. I just disabled it and was able to access rhino.

Yup. Sounds like the bug the latest Windows 10 update added that janked OpenGL applications like Rhino.

Hi. I am having the same problem here. Rhino opens in safe mode, but crashes on normal mode. I already updated the graphics card driver and the problem continues. When opening a window pops up saying: Rhino encountered a problem and needs to close.

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Commercial, build 2022-01-10
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: (null)
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL (null) (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 1-28-2022
Driver Version: 30.0.15.1165
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001

system_info.txt (1.4 KB)

I don’t see a good reason why Rhino would not start.

Try this:

  1. Rhino 7 in Safe mode, Options > View > OpenGL
  2. Move the slider down to OpenGL 3.3
  3. Close Rhino and start normally.

Any luck?

Hi John

Thanks but the problem persists.

Jorge

I also uninstalled and reinstalled Rhino. No progress

It looks like Rhino is crashing when trying to initialize that Nvidia driver.

Here’s a link to the current driver.
Please install it and see if Rhino runs better.

Any luck?

Here’s what your existing driver is reporting to Rhino:

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 1-28-2022
Driver Version: 30.0.15.1165
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Hi John.

I downloaded and installed the driver from the link you sent me but no luck.
I’ve been working for years with no problem. I have updated the PC drivers, rhino etc, when the system let’s me know. That is the only change I have done to the PC. Actually disconnected all peripherals. No luck.

Thanks

Jorge

Here’s a screenshot of my convo with the developer:

My guess is if you keep sliding the OpenGL slider to the left, you will eventually find a setting that works for now.

I’m at a loss to understand the problem.

Hi John, I tried with all OpenGL slider values. No solution.

As far as I know, you are the only one reporting this problem.
My guess is the Windows side of the OpenGL display tools are damaged.
I’ll assume Windows Check for Updates is fully up to date and there are no failures in the update log.

The only option might be a wipe and reinstall Windows.

Thanks John. Yes.
I will wipe and reinstall Windows.
I’ll let you know any advance.

Hi Jorge -
I suppose you might have already reinstalled Windows at this point…
If not, I’d try a clean install of the GPU drivers first.
You can find the recipe for doing so here:

Make sure to include step 4 of the uninstalling process!
-wim

Problem solved. I changed SSD drive and clean installed all the software. Everything working fine. Thanks

1 Like

Good to hear. I’m sorry you had hardware problems.