All of my viewports are black, I tried everything I could, nothing works

I’d hit the NVIDIA web site and look for an updated video driver for your system.

Like this:

— Dale

Okay I have tried downloading that driver but it still does not work.

Hi @user1940,

have you made the Nvidia processor the primary graphics adapter for Rhino using the Nvidia Control Panel in Windows?

For your laptop, see: How to make the nVidia graphics processor the default graphics adapter using the NVIDIA Control Panel | Dell UK.


I tried setting openGL to both Quadro processor and the Auto_select, none worked.

Did it make any difference at all? That it didn’t is hard to believe.

Hi -
I would start with a clean install of the drivers with the instructions found here:

Make sure to include step 4 of the uninstalling process!

okay I will try this thank you.

No difference.

call us 206-545-6877

Hello. My entire middle section of the viewports is black. No divisions dividing all four sections are even present. I cannot even go into the options in rhino as nothing happens when I click it. My graphic drivers seem to be up to date. Please help.

What else are you using? What is your laptop? How high resolution is your monitor? You seem to be having unique troubles.

I am using a Dell Precision 5540, I am not using a monitor right now.

Is it a 4k screen?


Please type _SystemInfo at the command line and copy/paste the info here…

Rhino 7 SR17 2022-4-12 (Rhino 7, 7.17.22102.05001, Git hash:master @ 13b57035af8fb22da005ef72c56e4555d9dbcfe3)
License type: Educational, build 2022-04-12
License details: Cloud Zoo

Windows 10.0.22000 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-18-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro T1000 (NVidia) Memory: 4GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\yamil\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22102.1509

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello- the first thing to try, if you have not, is to disable this plug-in in Options > PLug-ins page, then close and re-open Rhino. Any better?


I just downloaded enscape today, a few hours ago, the problem was there prior.

Here’s a link to the current drivers for your Quadro T1000:

The drivers were released 2 days ago.
When you run them, choose the Advanced option and check the box for a “Clean” installation.

Between that and disabling Enscape you should be okay.

Okay I will try this, thanks!