Rhino Navigation Painfully Slow


I recently installed both Rhinoceros 5 and Rhino 6 Evaluation for Windows, and when I open either one of the softwares, the navigation is painfully slow. I can´t seem to do anything, pan and orbit take several seconds. There’s also problems changing views, the first time I try to maximize a view, nothing happens; then, when I try to maximize a to a second view, it shows/maximizes the first view I tried.

I’m attaching a video.

I already tried disabling all plugins, I already updated my graphics card drivers and also tried turning off the grid.

I have the following laptop:
Acer Aspire VX5-591G
Intel Core i7-7700HQ CPU @2.80 GHz
16.0 GB RAM
64-Bit Windows 10, x64-based processor
NVIDIA GeForce GTX 1050 Ti - 4 GB

Any suggestions?

Please start Rhino 6 and run the SystemInfo command. Paste the results here. I’m going to guess that a display driver update is needed, but it’s best to get the data first.

Hi Steve,

Thanks for the quick reply. I ran the SystemInfo command and this is what i got:

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Evaluation, build 2020-03-19
License details: Stand-Alone
Expires on: 2020-07-01

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MAYTORENA-ACER

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-2-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 3-17-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 445.75

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341

If it were me, I’d update your old display drivers.


If your computer fusses about the driver not being validated for your computer, here’s how to sort that nonsense:

This driver is slightly newer but probably isn’t worth updating:

Any better?

You might want to read this discourse post as well

Thank you very much @stevebaer and @John_Brock. It was indeed the display driver. I have a dual Nvidia and Intel display driver, and I had only updated the Nvidia driver. I had tried before to update the Intel driver too, but, as John mentioned, I ran into that error message about not being able to install the driver due to it not being validated by my computer’s manufacturer. Now, with the help of the second link I was able to install it manually and it solved all the problems. Rhino is now working properly and very fast.

Thank you both.

Best regards,

Fernando Maytorena

1 Like