Slow Display

unhandled

#1

I’m experiencing the same thing with a model I’ve imported from Rhino 5. When I rotate the model in perspective view, it slows my computer to a halt. When I open the file it says… Creating Meshes in the console.


V6 Goal: Display Performance
(Steve Baer) #2

Can you share the model?


#3

2-24_001.3dm (6.0 MB)
It’s a fairly simple study model for an arch class.


(Steve Baer) #4

Rhino creates meshes for objects as they enter the scene to be displayed and eventually as all of the objects have been shown the “creating meshes” message will go away.

Does “creating meshes” eventually go away with this model or does it continue on forever? I am experiencing the “creating meshes” going away, but it may be different for some reason on your system.


#5

The “Creating Meshes” command passes but then if I try to rotate the view
it grinds to a halt and becomes unresponsive as if it is a heavily detailed
model in rendered mode.


#6

I created a file and made an array of 100 boxes of 10 units (feet) by 10 by 10. Even that file does the lagging thing. UGH! I want to use it so badly too.Rhino 6 Test.3dm (226.6 KB)


#7

EDIT:
I turned off the Hardware Acceleration and it helps.

Just in case this helps:

Rhino 6 SR0 2017-2-28 (Rhino WIP, 6.0.17059.2211, Git hash:master @ 6250fb6755aa8168fe586a6e95a61d5b5c6ede12)

Windows 10.0 SR0.0 or greater (Physical RAM: 28Gb)

Quadro FX 380/PCIe/SSE2 (OpenGL ver:3.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 3.3
Shading Language: 3.30 NVIDIA via Cg compiler
Driver Date: 11-14-2016
Driver Version: 21.21.13.4201
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 256 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(David Eränen) #8

@Brennan_Aitken-Gantz What happens if you disable Skylight (Rendering -> Lighting -> Skylight)


(Wim Dekeyser) #9

I’m seeing some weird things with that file.

I opened it without any warnings popping up. Zoomed extends. Hid the area of houses that is away from the origin and zoomed extends again. That didn’t change the view and so something else must be out there. (still looking into this).

With the view like that, the area of houses at the origin that is visible is rather small but something there keeps blinking on and off and never stops doing so. Zoomed into that region in the top view shows this (Discourse does not like wmv so zipped file): 2-24–display-top view.7z (94.2 KB)

Then I tried to find out more about what is out in space that I don’t see and decide to load the file again: File > 1. > Save Changes? No.. Now I get a Missing image files warning for “block from portland maps.PNG”. Why did this not pop up when I first opened that file? The blinking of geometry is still there.

I exit Rhino. Start Rhino again and drag’n’drop that file and pick “Open”. No warning about missing image files.
Now the blinking is gone and I am also unable to recreate an issue that I had trying to select an object out in space but only getting a hold of two invisible curve points… Oh well…


#10

Not sure if this is supposed to be like this but when it opens you have the Study model shown and if you zoom extents again 2300 feet away.

Perhaps this is what is slowing it down. It runs fine on my computer but Ive seen this before when my models get to be large and the distance between parts grows as well

Looks like this was already noted by @wim.


#11

Thanks for the input. I’ve built a second file in Rhino 5 and taken it into Rhino 6 for the AMAZING Make2D command improvement. Big thanks to that!

The problem persists though. I can barely rotate the model. I’ve even changed my video card out in hopes that was the issue.

No dice. I’ve turned off skylight in the rendering section as suggested. Nothing helps except turning of the OpenGL use hardware switch in the advanced portion of Document Properties. And then I start getting strange results like the model redrawing partially in ghosted or not at all after rotating.

Rhino 6 SR0 2017-2-28 (Rhino WIP, 6.0.17059.2211, Git hash:master @ 6250fb6755aa8168fe586a6e95a61d5b5c6ede12)

Windows 10.0 SR0.0 or greater (Physical RAM: 28Gb)

Quadro 400/PCIe/SSE2 (OpenGL ver:3.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 3.3
Shading Language: 3.30 NVIDIA via Cg compiler
Driver Date: 1-9-2015
Driver Version: 9.18.13.4135
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 512 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Steve Baer) #12

Please update to the latest WIP that we released today. The latest WIP includes major changes in the display code.


#13

Steve,

I’ve updated and the behavior persists. Is there a best practices to reset completely to make sure I’m isolating the WIP install to it’s function and it’s not some part of my adjusted Rhino 5 settings that is causing the issue?

It’s a pretty serious bug though. It renders it unusable. I’m happy to help however I can.

Brennan


(Steve Baer) #14

Thanks for trying; I wasn’t sure if this release would make a difference for what you are seeing but I there were so many changes this week I wanted to make sure we were at least discussing the same version of the WIP.

I know you are experiencing the slowdown in rendered mode, but…
Does the dramatic slowdown occur in wireframe mode?
Does the dramatic slowdown occur in shaded mode?


#15

It occurs in all modes. I’m watching the CPU and Memory consumption while it happens on my computer and it isn’t really spiking so much. It’s almost like it enters some sort of loop that isn’t really taxing on the computation but stalls everything out.

I can make a fresh file with an array of cubes and it happens there too in all view modes so I don’t think it is related to the geometry that much.


(Steve Baer) #16

if you draw a line in wireframe mode, is it unusably slow?


#17

No, it works great when I make one line, or many lines.

It works pretty good right now when I make a 3d array of cubes too.

You know what I just found in the DocumentProperties->General section is the Memory was set to 256. I set it to 20,000 and it seems much better but my Rhino 5 install is set to 256 and flies.

UPDATE: It’s definitely still laggy


(Steve Baer) #18

Can you elaborate? It sounds like things were working and then not…


#19

They weren’t working. I didn’t realize I had it set to no OpenGL still. That helps somewhat, but the shaded mode is non-functional without OpenGL. Some closed polysurfaces show up, some don’t, some faces do, some don’t.

The issue is with any mode besides wireframe.

I’m using wireframe because I want the new functionality for Make2D and rendered clipping plane views but I have to reopen the model in Rhino 5 to work on the model in shaded view.


(Steve Baer) #20

That is not an option that we even want to expose in Rhino. Not much is going to work without OpenGL being used.

So wire frame IS working fine? I know this sounds like you are being asked to repeat yourself, but I want to get accurate information on exactly what is going on.

I also noticed that your drivers are from 2015. Have you tried updating these?