Rhino 6 keep freezing, windows 10, first time user

Update: worked a charm :slight_smile: thanks

If you could run the _SystemInfo command and paste the result now that Rhino works again - good info to have what driver is good for that model GPU

Rhino 6 SR12 2019-1-29 (Rhino 6, 6.12.19029.6381, Git hash:master @ ae9d7fba5fda0b43002dc44a34e059a9a382db04)
License type: Evaluation, build 2019-01-29
License details: Stand-Alone
Expires on: 2019-05-26

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon HD 7800 Series (AMD) Memory: 2GB, Driver date: 2-20-2019 (M-D-Y). OpenGL Ver: 4.6.13547 Compatibility Profile Context 25.20.15025.1002

Secondary graphics devices.
AMD Radeon HD 7800 Series (AMD) Memory: 2GB, Driver date: 2-20-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-20-2019
Driver Version: 25.20.15025.1002
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for that information! I’ll get it on the list.

Having the same issue here, just tried installing Rhino 6.0 on windows 10 and was stuck on loading and then shows its not responding…

Anyone figured out or suggest how to resolve this issue ? thank you, would very much appricated.

Hi - the current version is Rhino 6.16.
At any rate, does it start up when you run it in safe mode?

It works fine on the safe mode but not on the normal mode …
Ive tried updating my graphic card Gefore RTX and installed the latest already… and restart my laptop and reopened it and still stuck " not respoding " .

Windows 10 here… sigh…

Yes latest Rhino 6.16, because I just downloaded the installer today and run the installing today

Hi - in that case, please start in safe mode, run the SystemInfo command and post the result here.

Thank you so much for replying

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Educational, build 2019-07-09
License details: Cloud Zoo. In use by: Johnason Lin ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: ROG-JOE

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2080 (NVidia) Memory: 8GB, Driver date: 7-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.60

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 3-8-2019
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001

PS interestingly the very fist few times was normal, but once I used Rhino 6 to open Rhino 4 files it started this problem, perhaps its got nothing to do with it just matter of time it starts this problem.

Hi - this section here tells me that something is wrong with the installation of the GPU drivers. Please try a “clean install” of both Intel and NVIDIA drivers following the recipe posted here:

Make sure to include step 4 of the uninstalling process!

Ive tried updating all my Graphic card drivers and still no luck,

I even formatted my new laptop last night and everything went back to factory setting and the first thing I did was install Rhino 6 again… no luck

Same issue opened the first time was ok, second time just says no response.
Thank you for you for replying, let me know what you think .
Regards Joe.

Hi Joe factory settings are not likely to be right - if you are at factory settings you’ll want to get all available Windows updates and the latest video drivers for both GPUs - these will likely not be up to date at the defaults settings.
You might also try forcing Rhino to use the NVidia by setting the control panel to use ‘High performance’.



Yes, I tried that too and no luck

Thank you

I tried uninstalling the Intel graphics card, and it worked for few times I was so happy for 5mins …
And then i restart and reopened Rhino to check again, it was same not responding…

I then tried running this on Rhino icon and at the moment it works, compatitiblity test and saved it and it auto detects to windows 8 settings for Rhino.

2019 August 01
No luck still , as soon as I imported Rhino 4 file onto Rhino 6, the same problem occurs, not responding… sigh… I will try the uninstalling and updating the graphic cards again …

Everytime I uninstall the intel graphic card, Rhino 6 works and if i reinstall it and update it, Rhino 6 will go non reposonsive…

Hello - if Rhino is stalling but not crashing, please force a crash dump as outlined here

and send it to tech@mcneel.com . Please include a link back to this thread in your note.


Hi Pasacal Golay,

I use a VGA to HDMI to link the laptop to the monitor, at the moment if i disable my intel graphics card UHDgraohics 630 and I am using NVIDIA GeForce RTX2080, Rhino 6 is working fine on both laptop screen and my Asus VX229 monitor. But I have no sleep mode and for some reason if I close my laptop screen down normally will automatically go into sleep mode but my windows 10 will crash or complete frozen.

I will try to send the dump file to you developers, thank you very much.

I’m going to contribute even though I think this is a mystery problem. I’ve been using Rhino 4+ for a couple of years, upgraded to 6 in January- about 6 months ago. Here I am on Intel i5 3570 8GB. In my shop when I can be there is i7 8700 16Gb. This has never happened yet on the i7.
Periodically Rhino will not start. The workspace should load as the white grids but it just stays black and then one…by…one they will show. Rhino will say unresponsive and never will actually function. I have had some degree of luck by running Windows Update, for some reason. But not this morning.
So on these threads there is a clue about graphics card drivers. My system is onboard Intel HD graphics and it kept saying that drivers are up to date.
So this morning I went to Intel and installed the Intel update utility. Ran it and it said there is another graphics driver. I said OK, install it and then it said, “This is older than the existing drivers, do you want to overwrite?” I said yes, and I guess I went back to the native drivers because all of a sudden Rhino runs just fine. This is only one day and the problem has been sporadic, so we shall see.
So yes, my solution wasn’t to update the drivers, it was to backdate them.
In any case yes, maybe this problem lies in graphics compatiabilites in general…

Cool to be here, John

Since I can’t edit the post, I will update. This problem was a real annoyance because Rhino 6 was essentially useless. I have had no issues since I did this, have run Rhino 15 times at least. In a nutshell:
My system was bought to use Rhino at home. It is I5, refurbished, which includes installing Win10 on it. I believe the system was Win7 when new. That means that the Win10 graphics drivers were installed for the Intel HD onboard graphics.
I went to Intel and got their driver utility. Using that it found the original Intel driver and suggested installing it. Then a box pops up saying “the existing driver is newer than this, continue anyway?” and I say yes and install the original driver. Problem solved, it seems…