"Text" is extremely slow

Hi all,

Rhino slows down when I click on any text to edit it, even crashes sometimes.

It has nothing to do with the file, file size, plugins, etc…I found that closing the properties panel helps, as it prevents the text to preview on the panel textbox, but that is quite inconvenient. Any ideas on how to fix this?

Thanks Rhino community!
SS

Hi SS,

Can you copy the resulting report text from the command _SystemInfo in a post here.
It’s often gives a good first hint to what might be the cause
-Willem

1 Like

Hi Willem,

Thanks for your quick answer. There you go:

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Commercial, build 2019-08-23
License details: Stand-Alone

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: SERGI-PC

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 10-7-2016 (M-D-Y). OpenGL Ver: 4.4.0 - Build 21.20.16.4534

Secondary graphics devices.
NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 10-27-2017 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build 21.20.16.4534
Driver Date: 10-7-2016
Driver Version: 21.20.16.4534
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi SS,

The first thing to do would be updating your GPU drivers, they are from 2016 and 2017.
for Intel I think you start here:

and for the GeForce start here:
https://www.geforce.com/drivers

Please report back if the issues persist!

-Willem

Thank you Willem. I updated the drivers, hoping that would fix the Text issue, but it still performs the same.
Extremely slow and buggy when double-clicking a text box, or when clicking a text with Properties panel open.
So…issues persist!
Do you have any other ideas? Thanks a lot for your time.

Hello - is this new behavior or has it always done this? If new, did you update Rhino to 6.17 and have it start? Can you please try updating to the latest, 6.18,

https://www.rhino3d.com/download/rhino-for-windows/6/latest

Does that make any difference?

-Pascal

Hello Pascal - thanks for your reply.
It still doesn’t perform well.
I also noticed it happens when selecting dimensions too. Anything that has the option to input text on the properties tab causes this issue.

My workaround is not-to-have the properties tab on when clicking a text or dimension, then edit it by double-click.
If properties are on, the whole program freezes…a friend said it happened to him in Rhino 5 and doesn’t remember how he fixed it (not with an update, but tweaking an option…).

_S

Hello - try disabling VRay in Options > Plug-ins page, and then restart Rhino. Does that behave any differently?

-Pascal

I this is just how things work at the moment when a lot of text is on the screen and you have some selected for editing in the properties panel.

Hi all,
Pascal - I tried that, it still doesn’t improve.
Steve - if I start an empty file and create a single text box with a single word, it still slows down when selecting it.

Still no solution…
Thank you all for your input.

I found this discussion:

Where an user posts a video where the text performance is similar to mine:

and he is doing the same workaround as me:

Hi - Please try to focre the GeForce card to be the primary OpenGL device - you should be able to find an “High Performance” setting in the NVIDIA Control Panel. Also, make sure to plug the monitor into the GTX card.

Any difference?
-wim

Thanks Wim.

I updated the OpenGL device and plugged the monitor into the GTX card (system info copied below)…no improvement.
I am using DisplayPort, I will try with HDMI tomorrow and let you know if that works. Could that be the solution?

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 9-26-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.48

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Anti-alias mode: 4x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: Height*
  • Vendor Name: NVIDIA Corporation*
  • Render version: 4.6*
  • Shading Language: 4.60 NVIDIA*
  • Driver Date: 9-26-2019*
  • Driver Version: 26.21.14.3648*
  • Maximum Texture size: 32768 x 32768*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 32768 x 32768*
  • Total Video Memory: 6 GB*

I want to check in on this issue please - I have exactly the same behaviour and have had it for months now. Makes using layouts an absolute pain.

Hi Nico - please try with the Properties panel closed - it may be faster for now, until this

https://mcneel.myjetbrains.com/youtrack/issue/RH-57326

is fixed.

-Pascal

Hi Pascal

Yes, that works, but it’s not a sustainable way to use Rhino unfortunately, as I always need Properties handy. Hope this can get sorted out soon!

Hi, I found out that the actual problem (At least for me) is the spell checker, it works poorly on rhino and its over using resources incredibly. My native language is spanish but I use my computer on english, I was writing text on spanish and of course every word was highlighted. I realized that the text box is slow when its loading the spell check and when having words highlighted.

Searched for options to actually turn it off and there are none. The spell check should be removed until there are improvements made on the code to use the Windows 10 spell checker. So I can not turn the spell checker in rhino and windows and my only workaround was to change my system language to spanish for writing and everything is working incredibly smooth, cause I dont even have a single misspell.

I hope this helps you, it really helped.

Have a nice day,

Matías Correa Díaz

2 Likes

wow! that solved my problem here too. I disabled the spell autocorrect from the control panel and it works smoothly again. thanks!

There’s a test command: TestToggleSpellCheckOnAnnotationText in SR 6.30 RC.
Let us know if that helps.

1 Like