Very slow layout

Hi all, I know this has been discussed before, but it’s driving me up the wall. Layouts are so incredibly slow and have been for years, I have to know if there is something I’m doing wrong or some workaround I can enable to make this workable. This is not a complex model - it’s a very simple 4MB pure 2D line drawing. There are no fancy display modes, no clipping planes, no polysrfs or anything like that.

Despite that, even doing something as simple as aligning text has an almost 2 second lag, each time I click on a text box. Just clicking and waiting for the text editing window to appear on the right takes a few seconds.

What can I do here? It’s turned drafting into an absolute chore.

2 Likes

1 Like

Does this happen with all fonts? As a test if you change the text fonts to Arial, does it help any?

It might be fractionally faster, but there’s still a distinct lag between clicking on any text object and being allowed to edit it.

Hi Nico - I can’t reproduce that here with a simple file. Can you post an example that behaves like that on your system? Also, please provide your SystemInfo data.
-wim

For what it worth, it seems very similar to this thread:

Thanks - that does look similar.
RH-62653 is still open - I gave it a nudge…
-wim

1 Like

This is exactly what I have, down to the bump in CPU usage - I can hear the fans spinning up aggressively every time I attempt to edit text. It is absolutely a result of having the Properties toolbar open. Was fixed at some point in V6, and has returned - with a vengeance.

My model can be found here: 2021 - NJH - Final 2D Signed Off.3dm (7.2 MB)

System Info dump:

Rhino 7 SR3 2021-2-22 (Rhino 7, 7.3.21053.23031, Git hash:master @ f8a40388712d9cf7edc68910e0415427bdefc64a)
License type: Educational, build 2021-02-22
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 24Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1660 Ti with Max-Q Design (NVidia) Memory: 6GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-11-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\nicov\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.0.0.0
C:\Users\nicov\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Users\nicov\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\nicov\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2020.12.7.446\SectionTools.rhp “SectionTools”

Thanks, Nico - that is very easily reproduced with that model.
-wim

Please McNeel Team, fix this! Switching to Rh7 has become extremely frustrating for this reason only! :frowning:

Same issue here. Annotation/dimension/hatch/text all get similar issues. Have to turn properties panel off to make it the same speed as rhino 6. Hope it can be fixed soon.

Is there any new information on this error? I am surprised that it’s still hanging around. Makes working in Rhino for layouts unfortunately an absolute pain.

Hi Nico -

RH-62653 was fixed and closed. When I tested that with your 2021 - NJH - Final 2D Signed Off.3dm file, I found that 7.6 behaved much better than previous versions. I opened that file again now and only notice a shorter-than-1-second lag when selecting some text and immediately panning the view. Everything else seems fine here. Shifting between selected blocks of text immediately shows the editable text in the Properties: Text panel. On your system, is that equally slow as what you showed in the video in post #2 in this thread?

I also see from that YT item that having larger amounts of fonts installed might be an issue. When you navigate to Control Panel\Appearance and Personalization\Fonts on Windows, how many fonts does it show? (I’ve got 304 items here).
-wim

Definitely still there. About 4 seconds on average in this file. I have around 800 fonts installed.