Rhino 6 SR22 and rhino 7 wip Lag bug

Hello - in my quick test, I see no difference yet between text in Fira Sans Condensed and Arial - so there must be some other factor - if the file large, for example, are there many text objects?

-Pascal

Hi @pascal,

Please see sample file here with only 4 text objects (same Annotation Styles, but font override for ‘Fira Sans Condensed’ text: TestFontLag.3dm (65.4 KB)

And the behaviour/lags on my side:

The behaviour is erratic, and there is also some panel refreshing issue with ‘Arial’ font as well.
However, I kinda have the feeling that the lag period is proportional to the size of the text object.

I also tried that particular file in Safe Mode: same story.

System Info (and yes, I know, I have to update my graphic card drivers :slight_smile: )

Rhino 6 SR27 2020-6-11 (Rhino 6, 6.27.20163.15081, Git hash:master @ 8c9f18774d0fe24946068d123d78712d7a17f847)
License type: Commercial, build 2020-06-11
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 1-29-2020
Driver Version: 26.21.14.4219
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20163.15081
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20163.15081

So far this behaves just fine, here… I don’t have a good idea what to check - is that system info complete, right to the bottom, with all plug-ins showing?

-Pascal

Hi @pascal,

The system info are taken from safe mode, not all plugins are also displayed. But I assume that if the problem occurs in safe mode, it is not related to plugins as they’re not loaded anyway, or am I wrong?

Do you think a fresh new Rhino install could fix these issues?

EDIT: probably not, I just tried on another machine, both normal and safe-mode and I get the exact same issues…

Were you able to figure this out?
Is it still happening?

Hi @John_Brock, Hi @pascal,

I just tried again with this version in safe mode:

Rhino 6 SR28 2020-6-23 (Rhino 6, 6.28.20175.14591, Git hash:master @ 9ddbd1399e001a3eae701470332b5379477fa7d6)
License type: Commercial, build 2020-06-23

The lag still occurring with some fonts:

  • ‘Arial’, ‘Fira Sans’: no lag
  • ‘Fira Sans Condensed’: lag when selecting/deselecting the text object

I also performed a few more test (always in safe mode) and I observed the following:

  • the lag duration is correlated with the quantity of text (I selected each text 3 times):

    • with one line text object: maybe 1 second lag (4, 5, 6)
    • with 10+ lines of text:several seconds of non-responding application (1, 2, 3). I also can hear the fan of my computer starting a few moments after I select the text. The CPU usage clearly shows some peaks as well: some heavy computation is definitely taking place in the back scenes…
  • I tried a bunch of different fonts families:

    • ‘Monserrat’:

      • standard ‘Monserrat’: no lag
      • ‘Monserrat Black’, ‘Monserrat ExtraBold’, ‘Monserrat Medium’, etc… : lag occurs
    • ‘Source Sans Pro’:

      • standard ‘Source Sans Pro’: no lag
      • ‘Source Sans Pro Black’, ‘Source Sans Pro Light’ etc… : lag occurs
    • ‘Zilla Slab’:

      • standard ‘Zilla Slab’: no lag
      • ‘Zilla Slab Medium’, ‘Zilla Slab Light’ etc… : lag occurs

    Conclusion: it appears that the lag only occurs on sub-styles of the fonts.

To be honest, I really would like to get this thing fixed. Please let me know if there is anything I can do to help you to spot that bug. Is there a way for me to profile the application via a plugin debug on my side and send you back the result logs or whatever?

Please stop using Safe Mode.

It is intended only as a troubleshooting tool when display drivers or plug-ins are causing startup crashes.
It is not a “working mode”.

If you can’t run Rhino normally (not Safe Mode), solve that problem first.

I hope you’re kidding…
I use plenty of my ‘free’ time to expose the matter here and help you to reproduce that lag. The condescending response I get in return is to be taken for a moron… Is that a new McNeel policy?

Please tell me where I mentioned that I use SafeMode as a working mode?
Please tell me where I mentioned that I can’t run Rhino normally?

I use SafeMode to demonstrate you that the issue isn’t plug-in related. I have similar lags in standard mode as well. Did you read the posts above?

But OK, I won’t waste my time here any more, I don’t have the feeling that someone’s really listening.

You have completely misunderstood my comment.
They way you worded your message, gave no indication as to why you were running in Safe Mode and what you thought it would show.
I have no way of gauging anyone’s understanding of these tools outside what they post.
I’m sorry that I guessed incorrectly. No slight was intended.

The vast majority of Rhino users have never heard of Safe Mode.
Those that do, generally have no idea what it’s for.
When we give instructions for using it, most will not read the message and jump to the conclusion that it’s some special mode that makes it so they don’t need to fix anything.
A very small number, like yourself it seems, do know what it’s for. That is a very tiny percentage of Rhino users that blast questions at tech support like a fire hose.

In this case, it is still not a good measure of the issue as it blocks the OpenGL graphics which are key to performance.
Instead, if you suspect a specific plug-in might be involved, disable it in Options > Plug-ins and restart without it, not running in Safe mode.

This particular thread was revived as it had been ignored for a couple weeks with no activity. We are trying to slog through a backlog of old messages and yours came up.

Sorry, I probably overreacted, but hey, the Text Property Panel is clumsy since the release of v6. This not a scoop.
We are now by SR27, and this is still not working 100% fine.

I fully understand you’re probably more focused on adding nice features on the V7 right now, but Jesus, if some simple tasks like editing annotation objects without having to wait 5 seconds between each action still won’t work, please put a bit more effort and willingness, and fix that damn Annotation Object / Text Panel once and for all.

Just telling the clients to ‘…solve that problem first’ as they are trying to help to identify the problem is IMHO rude and no proof of cooperation on your side. If you’ve bothered reading my previous post, you would have find out why I’m using the safe mode. But anyway…

So here again, I disabled a few fancy plugins, ran Rhino in standard mode and here is the result:

Rhino 6 SR28 2020-6-23 (Rhino 6, 6.28.20175.14591, Git hash:master @ 9ddbd1399e001a3eae701470332b5379477fa7d6)
License type: Commercial, build 2020-06-23
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 6-21-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.48

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2020
Driver Version: 27.21.14.5148
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

And the behavior observed:

  • left font: ‘Arial’
  • right font: ‘DejaVu Sans Condensed’

The file is here: __LagTextObject.3dm (52.7 KB)

The simple action of selecting the TextObject drains 50% of my CPU during several seconds.

If this is suppose to be the expected behavior, ok then, but do not expect me to encourage my company to switch to v7 if such basic stuff isn’t handled properly until then (because BTW, the similar bug currently occurs in Rhino WIP).

I can see the lag here with the file above, but that may be because I do not have the font for the text block on the right installed (DejaVu Sans Condensed). Actually, the lag occurs here when deselecting the text, not selecting it - maybe 5 seconds or so. Obviously, if I change it to something else, the lag disappears. Otherwise, the lag may be due to Rhino looking for the missing font every time you select the text block and not finding it (here at least).

Hi,

Any improvements on this topic?

I tested to disable spell check as adviced here (Rhino 6, 6.30.20266.14531):

Moreover, on file start, the text panel is also not display properly:

Is there any hope this issue will be fixed one day?

Hi jeff, in the past I had another problem about delay on the text panel… it was like the dimension of the panel was putting Rhino interface in a resize loop.
I solved changing the column size so the text panel was fully visible… after that it seemed fixed…

Hi everyone,

I have the same problem as @jeffoulet , when selecting a text or dimension I have a lag of 1-2 seconds and it’s hard to work whit this handicap. It happens when properties are open, and do not happen if you select or move text without properties on. I’ve tried to modify the text/dim double clicking and don’t happens, so it’s seems to be something about properties.
In rhino 6 the lag was about 1 sec or less but on rhino 7 it’s worse…
I’ve changed the style and font to check but it’s still happening.

Thanks

Same problem here as well. Happens when properties are open and do not happen if you select or move text without properties on. And after I updated my windows 10 to the latest version, it causes me to have to lag on my windows UI when I drag them. This only happened when I open the rhino, everything goes back to normal when I closed the rhino. So it’s definitely the rhino’s fault.

Pretty sure it’s not my performance issue, since I am using 5900x + 3080 with 32GB GDDR4 memory

Exactly the same here. Brand new install of Rhino 7 (latest). No plugins. Massive lag when trying to edit annotation with the properties dialogue open. It is really problematic when I am doing lots of 2D documentation etc. Is there anyone working on this?
Cheers. All drivers updates as well. Please help!

Same exact text / annotation lag problem as rupertenberg above. Latest install of Rhino 7 with no plugins (in fact, it’s the Evaluation version). Every time I click on an annotation or text to work with it, there’s a 1-to-3 second delay. Doesn’t matter which font, or whether it’s a text or annotation, or what I’m trying to do with it. I’m working on a set of blueprints right now and I’m just cursing up a storm…this is taking me like 3x as long, and it’s so. much. effort. In fact, it’s so unworkable, I am seriously thinking I probably won’t be able to upgrade from Rhino 5 to Rhino 7, which is crazy. I’ve been using Rhino since 1.0, and I’m usually psyched to upgrade. I guess I’ll wait til Rhino 8?

1 Like

Hello - for now, please make sure Properties is not open or not on top in the pile of panels on the right.

-Pascal

Thanks Pascal, keeping the Properties tab in back is working and is a reasonable workaround for now :slight_smile:

Hi Pascal,
I hope something can be done because I use a lot text, dimensions and named objects. Having Properties Panel closed it’s not an option and make my workflow veeeeery slow.
I´v tried with some possible solutions:

But nothing has changed.

Thanks for reading and hope something can be done.

PD: In the last version of rhino (Version 7 SR5 (7.5.21100.3001, 2021-04-10)Comercial ) changing layer colors has also lag, that’s something new.