Text Editor Awfully Slow - Lags behind when typing

Please make sure to update to the latest service release (6.28). I remember doing some work in this area in the last couple months

HI Steve, I just did and tested: no change.
I made a video to better convey what I am experiencing.

You can clearly see how the view lags behind when panning immediately after selecting a text object.
Typing also lags behind: for a moment no typing appears and the word appear instantly. Cursor also lags behind.

Any ideas guys? Is this only happening to me?

Hi @ShynnSup,

I can reproduce both of your issues and I created the following YouTrack items:

Thanks for reporting!



Hello, I’ve been having this problem on and off for a few months too, and again this morning when editing a lot of text. I have the latest Rhino 6 build, latest GPU drivers, Win 10, etc.



Anyone got any news or workarounds on this please (other than closing the Properties panel)?

Sorry don’t know if this is an option but when I was doing layout for engraving pages I had to do it all in a text editor then copy/paste into rhino, was impossible otherwise due lags.
Open word pad or any other text editor and do your text in there then copy and paste into Rhino.

Hi @DavidEranen ,
I see problems when using text in Rhino. Maybe you can just bring up word pad or something that works and then just copy paste into rhino? I see huge problems in lagging and formatting but text has been problematic since V5 so I gave up. But recently I did a small amount of text in V7 and noticed problems with lagging right off the bat.

Thanks for the suggestion, it might end up being quicker even though I’m just editing a word or two (annotating 2D drawings).

Hi, is there a solution for this problem. I also have this Problem when working with annotaions in the Layout-Sheets.


  • How many monitors are you running and at what resolution?
    You only have enough VRAM for a single standard resolution monitor.
  • In Windows Conrtol Panel > Power options, are you set for High performance?
  • Are you using a docking station?

I’m working on an Asus ROG G751JY so:

One (1): 17.3" 16:9 IPS FHD (1920x1080) anti-glare.

No. But I tried it, no difference.


I am not sure why these answers are relevant though as many users seem to experience the same with different hardware and software configurations.

I don’t think this is driver related. Have you tried this in the V7 WIP?

Yup, same thing. :frowning:

@ShynnSup, @barrento, @tgraph, @DavidEranen

Can you please try TestToggleSpellCheckOnAnnotationText and let me know if this improves the text editing issues you are seeing? Thanks

1 Like

Hello Steve,

Thanks for this, I will try later today and report back,


Hello Steve,

I’ve tried editing text in SR 30 latest RC just now without running the test command, but the problem hasn’t occurred yet, but then it doesn’t always happen straight away.

I’ll keep using SR 30 RC rather than SR 29 for now and report back if the problem recurs.

Thanks again,


@stevebaer The test command fixes both problems for me (RH-60133 and RH-60134).


1 Like

@stevebaer I tried with Annotation text spell checking turned off in Rhino WIP and it definitely improved the smoothness of typing and manipulating text objects :grin:

I can still experience some lag when moving a text object by dragging it to a new position and immediately panning the view. (But it has to be done really fast for it to lag so it’s not a big deal).

Hi Steve, this worked for me. Thanks!