Text editing is really slow

Hello,
I’ve seen older posts about this, but nothing recently so wanted to ask again about editing Text. We have large models that are seeing significant slowdowns when editing text. We can go into the textbox in paperspace and start typing and sometimes can get a whole sentence typed in before the text editor catches up and starts displaying the characters. It is really a slog to edit our text annotations because it takes so long to have the text update. Is there a way to make sure the text editing is smooth? General geometry editing is smooth and fast but text editing is almost impossible.

Thanks
Ian

Hi Ian -are you running any non-default plug-ins? Is this file-specific? Large files? Any file?

thanks,

-Pascal

Pascal,
Nothing abnormal that I can think of. We see this issue in multiple models. They are on the larger side. All the annotative text is in paperspace and we are creating 10+ page drawings. I don’t know if this makes a difference, but the models do have lots of usertext on objects. We are mainly hardcoding in the text instead of referencing the usertext for the annotations, so I can’t see off hand how that would slow things down.

Would View styles have anything to do with the slow refresh of the text? we have been messing around with a number of the view styles.

Thanks
Ian

Hi Ian - I would certainly test in default wireframe, default shaded and whatever custom modes you may be testing… I don’t know but I would not be surprised if the display modes have some effect - worth a quick test anyway. Meantime, @lowell - do you have an idea about this slow text editing?

-Pascal

My guess is the text in the layout is the issue. I think most of the speed enhancements have happened in the model.

We would need a model but you can test this yourself.
Move the Layout text to the model and make a Detail to display it in the Layout where you want it.
Does that speed things up any?

I think @stevebaer is the guy that would know.

I haven’t seen anything like that, but I don’t work with big models much either
It would be good to have a 3dm file to see what you’re really up against.
Otherwise, we’re just guessing and making stuff up

OK,
So I think I’ve narrowed down the issue. I think it has to do with how Rhino is redrawing the layouts. As you type in the text box, the layout is updated to show the new text. If I zoom way in so that I only see that one text object then I can type in text smoothly. But if I am zoomed out then the text input is a slog.

I was able to recreate the issue but the file was a bit to big to upload. Hopefully I can describe how to recreate it:

  1. open a blank file and make a 10x10x10 box.
  2. Array the box 20x20x20 with a spacing of 20 in all directions.
  3. Explode the boxes so that you have a bunch of surfaces
  4. Create 2 layouts. the first with one viewport. the second with four viewports. Make sure all the surfaces are visible in all the layouts.
  5. Add a couple text objects to both layouts.

  6. Compare the response time to modify the text on the layout with one viewport to the response time to modify the text on the layout with four viewports. The text should be really laggy in the layout with four viewports.

You should see the response time in the four viewport layout speed up if you zoom into one of the text objects and edit it.

It seems like editing text requires the entire screen to be redrawn. So with lots of objects to redraw in each viewport the redraw time goes way up and slows down the text. It woulds seem like editing the text shouldn’t require the entire screen to redraw.

Hope this helps track down the issue.

Thanks
Ian

Thanks, that makes it clear.

This is a bug report about it
https://mcneel.myjetbrains.com/youtrack/issue/RH-48967

I just added https://mcneel.myjetbrains.com/youtrack/issue/RH-48968
With the details from this last post.

I have the same issue with Rhino 5 at the moment. I realized that when I double click the text so that I can write in the text box (where you can choose “wrap”) then the layout doesnt refresh until after you have exited the text box. Thus you don’t have to wait for it to refresh for every single letter.

I don’t know whether the issue I have been experiencing is related to what is described above, technically, but I did find this thread searching for “Rhino 6 very slow text.” I am using Rhino 6 SR13.

I am working on the beginning of a plumbing schematic, which currently has 1 point, 117 curves, and 21 text objects. Most of the text objects are 2-3 character abbreviations. I am working in model space. When I select a text object the entire Rhino interface freezes (the computer, generally, remains responsive) for 2-3 seconds, though anything I click/type during the “freeze” eventually happens. If I double-click on a text object and start typing, rapidly, whatever I type does eventually get entered into the text editing box.

However, this behavior has been intermittent. What I realized just now is that when the Properties Panel is displayed on my screen, this lag occurs. When The properties panel is not displayed, everything related to selecting/editing/manipulating text happens at a normal speed. I further noticed that when the properties panel is displayed, and I select text, the text editing box first displays whatever text had been previously selected, then goes blank for ~1 second, then shows the currently selected text. During this transition time, I also observed that the boundary of the text box actually shifts up and down rapidly by ~1 pixel or so. during the “freeze”.

To illustrate this happening, here’s a video rendered in slow-motion: https://www.dropbox.com/s/19omfrzqrvhvetj/rhino_slomo.mov?dl=0

And here it is in real time: https://www.dropbox.com/s/a4hbgf14rdxas35/Rhino_full_speed.mov?dl=0

The interface becomes responsive again once the wiggling stops, but after the new text has been drawn into the Properties Panel edit box.

My solution for now is to keep the Properties Panel off of the screen for this activity, since it isn’t part of my workflow. However, I do use the Properties Panel frequently when I am drawing, so a fix or suggestions on settings to change to avoid this lag when I select text would be great. Thank you.

In the Panels pull-down menu, turn on the Notifications panel.
Does it say anything about updating display drivers?
If it does, please chase that down and see if it fixes the problem.
Please report back.

I have an nvidia quadro P4000 and was running driver version 419.17, which is the latest driver certified for the version of Solidworks that I am running, and was released on 2/20/2019. I have updated to the current ODE branch release, 419.67, released on 3/20/2019, and observe the same issue.

I’m having the same issues.

Please don’t double post!
We’ll keep the discussion going in that other thread…
-w

Hi, I found out that the actual problem (At least for me) is the spell checker, it works poorly on rhino and its over using resources incredibly. My native language is spanish but I use my computer on english, I was writing text on spanish and of course every word was highlighted. I realized that the text box is slow when its loading the spell check and when having words highlighted.

Searched for options to actually turn it off and there are none. The spell check should be removed until there are improvements made on the code to use the Windows 10 spell checker. So I can not turn the spell checker in rhino and windows and my only workaround was to change my system language to spanish for writing and everything is working incredibly smooth, cause I dont even have a single misspell.

I hope this helps you, it really helped.

Have a nice day,

Matías Correa Díaz

1 Like