Rhino 6 SR22 and rhino 7 wip Lag bug

Hello. we have find a “lag bug” with the leader on rhino 6 and 7 wip

with the big file (>200 Mo) if I select a leader, then rhino wait afew second befor print the valu of leader.
Do yo see this problem?
it’s verry embarrassing beacause we waiting waiting and waiting again :S
for information, the bug didn’t exist with annotation text :slight_smile:

after a few seconds


1 Like


I also experience lags on leader/text/dimensions annotations. Sorry to say, but it is really a pain in the a*s.
Currently doing a lot of 2d drawings, and every time an annotation object is selected, it take 1 to 2 seconds until Rhino refresh.

For instance, by selecting an annotation text or a leader, and trying to moving it with the gumball, the object is ‘sticky’ and move only after a few moment:

And here the file:leaderSoSloooooww.3dm (70.8 KB)

It also lags in Safe Mode as well:

I presume it has something to do with the Object’s Properties Panel, because if I the Layer panel is displayed, it does not seem to lag (see above).

Please, fix this, really, please… It just impossible to work with this.

Also maybe related to these:

System info:

Rhino 6 SR23 2020-2-18 (Rhino 6, 6.23.20049.14121, Git hash:master @ 22177e6af29b3de25aa2187085ece6d80938b281)
License type: Commercial, build 2020-02-18
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 11-12-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.28

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-12-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

1 Like

Hi, I have find the problem

the problem is the number of block instance,not the bigger file
I have created the bug with a litle file.
In the detail view, try to select a leader object and see the lag :S but if you select a text object the rhino don’t lag

Lag leader.3dm (2.5 MB)


Hi @SMC2,

Interesting, I also noticed a lag in your file. After doing a ‘Purge’ and deleted all blocks, the lag seems to be gone.

Did you try my sample file above?
It is weird, because in this one, it seems to be a lag issue even if there are no blocks at all in it.

Maybe there is one problematic behavior (laggy annotation object), but with more than one cause?

Hi Jeffoulet.

Yes I have testing your sample file and i have see the lag bug if i use the gumball one time so it is strange and very annoying beaucause your file have not block in memory and is very light.
For information the bug is too on rhino 7Wip.

I think that the problem have multiple cause.


Hello - it looks (here) like a selection of text (in your example file) lags after selection of another text; leaders lag after a selection of a leader. Select text then leader, everything is quick (here) and the first selection after activating the detail is also quick.

Still poking…
And yes, clearly the number of blocks in the file has an impact in your test file.
@jeffoulet - I see a lag in your file if I select the leader first … then the text. I still see this if I make a new annotation style and delete yours…

I’ll put these examples on the pile - thanks.



Hello. great

thanks very much

@jeffoulet, @SMC2 - the delay appears to be in the Properties dialog - close or hide that and see if things improve - still a bug, but it might help for now.


Yes I have closed the dialog box and the lag as desapear. But working whithout the dialogbox is not powerfull :S

Hi @pascal,
Thanks for adding it on the pile. Indeed, hiding the Properties panel, seems to disable the lag, but well… as @SMC2 said, it’s not really convenient to constantly switch that panel on/off during editing of multiples annotations objects… but anyway, hope you find a fix to this :slight_smile:

Hi @pascal,

Any news on that topic?
Rhino v6 SR26 and still experiencing massive lags (Rhino hangs during at least many seconds) with text objects.

I suspect it to be font related: with text in ‘Arial’ font, everything seems OK and fluid. If I change to ‘Fira Sans Condensed’ the lag occurs. By reverting back to ‘Arial’, the lag disappear:

It is very strange, with font ‘Fira Sans’ (also not condensed) it seems to be no lags.

Hello - in my quick test, I see no difference yet between text in Fira Sans Condensed and Arial - so there must be some other factor - if the file large, for example, are there many text objects?


Hi @pascal,

Please see sample file here with only 4 text objects (same Annotation Styles, but font override for ‘Fira Sans Condensed’ text: TestFontLag.3dm (65.4 KB)

And the behaviour/lags on my side:

The behaviour is erratic, and there is also some panel refreshing issue with ‘Arial’ font as well.
However, I kinda have the feeling that the lag period is proportional to the size of the text object.

I also tried that particular file in Safe Mode: same story.

System Info (and yes, I know, I have to update my graphic card drivers :slight_smile: )

Rhino 6 SR27 2020-6-11 (Rhino 6, 6.27.20163.15081, Git hash:master @ 8c9f18774d0fe24946068d123d78712d7a17f847)
License type: Commercial, build 2020-06-11
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 1-29-2020
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20163.15081
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20163.15081

So far this behaves just fine, here… I don’t have a good idea what to check - is that system info complete, right to the bottom, with all plug-ins showing?


Hi @pascal,

The system info are taken from safe mode, not all plugins are also displayed. But I assume that if the problem occurs in safe mode, it is not related to plugins as they’re not loaded anyway, or am I wrong?

Do you think a fresh new Rhino install could fix these issues?

EDIT: probably not, I just tried on another machine, both normal and safe-mode and I get the exact same issues…

Were you able to figure this out?
Is it still happening?

Hi @John_Brock, Hi @pascal,

I just tried again with this version in safe mode:

Rhino 6 SR28 2020-6-23 (Rhino 6, 6.28.20175.14591, Git hash:master @ 9ddbd1399e001a3eae701470332b5379477fa7d6)
License type: Commercial, build 2020-06-23

The lag still occurring with some fonts:

  • ‘Arial’, ‘Fira Sans’: no lag
  • ‘Fira Sans Condensed’: lag when selecting/deselecting the text object

I also performed a few more test (always in safe mode) and I observed the following:

  • the lag duration is correlated with the quantity of text (I selected each text 3 times):

    • with one line text object: maybe 1 second lag (4, 5, 6)
    • with 10+ lines of text:several seconds of non-responding application (1, 2, 3). I also can hear the fan of my computer starting a few moments after I select the text. The CPU usage clearly shows some peaks as well: some heavy computation is definitely taking place in the back scenes…
  • I tried a bunch of different fonts families:

    • ‘Monserrat’:

      • standard ‘Monserrat’: no lag
      • ‘Monserrat Black’, ‘Monserrat ExtraBold’, ‘Monserrat Medium’, etc… : lag occurs
    • ‘Source Sans Pro’:

      • standard ‘Source Sans Pro’: no lag
      • ‘Source Sans Pro Black’, ‘Source Sans Pro Light’ etc… : lag occurs
    • ‘Zilla Slab’:

      • standard ‘Zilla Slab’: no lag
      • ‘Zilla Slab Medium’, ‘Zilla Slab Light’ etc… : lag occurs

    Conclusion: it appears that the lag only occurs on sub-styles of the fonts.

To be honest, I really would like to get this thing fixed. Please let me know if there is anything I can do to help you to spot that bug. Is there a way for me to profile the application via a plugin debug on my side and send you back the result logs or whatever?

Please stop using Safe Mode.

It is intended only as a troubleshooting tool when display drivers or plug-ins are causing startup crashes.
It is not a “working mode”.

If you can’t run Rhino normally (not Safe Mode), solve that problem first.

I hope you’re kidding…
I use plenty of my ‘free’ time to expose the matter here and help you to reproduce that lag. The condescending response I get in return is to be taken for a moron… Is that a new McNeel policy?

Please tell me where I mentioned that I use SafeMode as a working mode?
Please tell me where I mentioned that I can’t run Rhino normally?

I use SafeMode to demonstrate you that the issue isn’t plug-in related. I have similar lags in standard mode as well. Did you read the posts above?

But OK, I won’t waste my time here any more, I don’t have the feeling that someone’s really listening.

You have completely misunderstood my comment.
They way you worded your message, gave no indication as to why you were running in Safe Mode and what you thought it would show.
I have no way of gauging anyone’s understanding of these tools outside what they post.
I’m sorry that I guessed incorrectly. No slight was intended.

The vast majority of Rhino users have never heard of Safe Mode.
Those that do, generally have no idea what it’s for.
When we give instructions for using it, most will not read the message and jump to the conclusion that it’s some special mode that makes it so they don’t need to fix anything.
A very small number, like yourself it seems, do know what it’s for. That is a very tiny percentage of Rhino users that blast questions at tech support like a fire hose.

In this case, it is still not a good measure of the issue as it blocks the OpenGL graphics which are key to performance.
Instead, if you suspect a specific plug-in might be involved, disable it in Options > Plug-ins and restart without it, not running in Safe mode.

This particular thread was revived as it had been ignored for a couple weeks with no activity. We are trying to slog through a backlog of old messages and yours came up.