Bug - Automatic spell checker in Text properties freeze cpu

Ok, I was suspecting it was something related to windows because the Wip7 has the same problem…
I’ll try to disable this “smart” spell checking somewhere in windows and see what happens.
Ciao!

Do you believe that I disabled all the flags in the Windows options (keyboard input) and the spell check is still there?
I’ve also try re-enabling and disabling, restarting the pc several times but when I write a text in Rhino the spell correction appears again. :joy: Well… tomorrow I’ll start to play with registry so we’ll see who will win! (win, windows, who win? X… uhmm… and there on discourse? no grammar correction? Uh, Win, uh where, cmon… grrrr… hahaha damn… :sweat_smile: )

Hi Lucio- it might be worth a look to run Rhino and Windows in the same language and see if that makes any difference. I’m not sure what to do if it does make things better, but it might point toward the problem.
Our developer also could not turn it off, btw - we may need to add a test command.

-Pascal

1 Like

Hi, I believe I’m experiencing a similar problem on Win 10 using English Rhino & Windows, so it is possible that the issue is not related to a mix of languages.

When creating a text object or leader, there is sometimes a short freeze (maybe 1 to 2 seconds). However, I’ve been working with a larger file (170 MB) and notice that whenever I select a text object or leader, the program freezes for a little over 5 seconds. This ONLY occurs when the Properties panel is open.

Hello - can you please run SystemInfo in Rhino and copy/paste the results here?

-Pascal

Sure, let me know if anything else will help.

Rhino 6 SR28 2020-7-17 (Rhino 6, 6.28.20199.17141, Git hash:master @ b1f15b655bd1f5ae0d3d3257e3efdeb0a45630e4)
License type: Commercial, build 2020-07-17
License details: Cloud Zoo. In use by: Darin Russell ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: ECLIPSE

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon R9 200 Series (AMD) Memory: 4GB, Driver date: 9-10-2019 (M-D-Y). OpenGL Ver: 4.6.13571 Compatibility Profile Context 19.9.2 26.20.13003.1007

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 9-10-2019
Driver Version: 26.20.13003.1007
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Users\Darin Russell\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7030.16466\RealDrawings.rhp “RealDrawings” 1.0.7030.16466
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20199.17141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

It it were me, I’d update the display driver first
See if you can find an updated driver on this site:
https://www.amd.com/en/support
Graphics > AMD Radeon R9 Series > AMD Radeon R9 200 series > [whichever specific card you have]

If that doesn’t work, I’d try disabling the “RealDrawings” plug-in as a test.

Any luck?

Here’s how I solved this issue on Windows 10:

Take ownership of files using Command Prompt (Run as administrator)

takeown /f C:\Windows\System32\MsSpellCheckingHost.exe
cacls C:\Windows\System32\MsSpellCheckingHost.exe /G [username]:F

takeown /f C:\Windows\System32\MsSpellCheckingFacility.dll
cacls C:\Windows\System32\MsSpellCheckingFacility.dll /G [username]:F

Rename, move or delete these two files in C:\Windows\System32

MsSpellCheckingHost.exe
MsSpellCheckingFacility.dll

This disables the spell checker.

1 Like

I highly highy recommend against changing any files in your Windows system directory. You can disable the spell checker in Windows through the control panel.

Thanks Esa, I’ll give a try!

Steve, in control panel is all disabled… but Rhino still highlits “wrong” words when selecting a text… Why?
And if I Click in the object propertie’s text box the spell checker stops working untili I open another session of Rhino…
So, are there other workarounds?
If the answer is no, then I have to follow Esa’s advice and use “brute force”.

no!!! Please don’t do this. I’m inclined to delete this post as this recommendation is not a good thing to do to your system. If you do, don’t contact us about problems with Rhino.

Please see the recommendation at

Steve, again, it’s all disabled! I don’t know how to explain better…


There’s no way that Rhino stops to spell check!
Also Pascal told

I agree that renaming system files is a bad thing but… I’m waiting to know if McNeel is doing something to fix that or not…

@curtisw or @Alain is there any way we can get a test command built into Rhino for disabling the spell checker so users don’t resort to these tactics?

1 Like

Hi, I tried everything before this extreme solution: I turned spellchecking off (even tried to do it in Word to be sure), also disabled spell checking using regedit but nothing worked. Rhino 6 still checked spelling of text objects. I have Windows 10 and Rhino 6 both installed in English, but the content of the text object is in other language. So it looks a like a bug, either in Windows 10 or in Rhino 6. Seems like some other apps such as Edge have similiar problems. I’ve had no issues since moving those two files to a backup location. I had to try everything as Rhino was not usable. There was too much lag every time I selected/edited a text object. The more text it contained, the slower it got. This hack has been recommended in different forms in several forums around the Internet.

1 Like

@lucio_zadra, @esa.ruskeepaa, @d.c.russ,
There’s a test command: TestToggleSpellCheckOnAnnotationText in SR 6.30 RC.
Let us know if that helps.

1 Like

Thanks Alain!
I’ll try asap and tell you if the problem is solved!

AWESOME, PERFECT, WONDERFUL!!!
The Spell Check is disabled!!! YEEEEEEEEEEEEEE!!!
No more delay when selecting a text!!!
I’ll open a prosecco to party!! :champagne:
Thanks!

RH-60691 is fixed in the latest Service Release Candidate

Thanks Brian!
:+1:

Hi All just my little cup of tea to anyone who may need, I think this thread is a kind of mixed up of different concepts but to clarify for anyone having issues with spell check:
System Spell check works in the language the system is configured to use by default.
so if your windows language is Spanish your typed texts in rhino text boxes will be checked in Spanish, you can change it “on the fly” having multiple languages configured in windows with the same keyboard layout (that is made exactly for this, even if some special characters would be tricky to type, but there are also the Alt codes combinations) so if you have to write some text in other language than the current one you could change windows language for a while (bottom right corner of windows bar, beside windows clock) and get spell check work in the language of your choice.

Anyway the test command “TestToggleSpellCheckOnAnnotationText” works to disable spell check in rhino, but I think IMHO it’s a backstep in evolution because spell check is very, very useful!
I think maybe a toggle button in the text boxes would make sense, to avoid unnecessary time / resource consumption if no need of spell-check, this “test command” is really a good workaround, very useful but is not that practical, as it is necessary to restart Rhino to change the spell check status. that’s why its called a test command!
Many thanks for sharing it, as spell check in my in rhino7 was disabled by default.
Alex