Problem with dimension lines after latest update

my Rhino 6 updated on Friday (Feb 01) and today I noticed a change in behaviour with dimension lines. When creating a dimension with text above the dimension line, everything’s fine when the arrows are fitted inside. When they are fitted outside however, the line between the arrows disappears. Position of the text has no effect on it.

This was the standard behaviour in Rhino 5 but it was, of course, wrong and against the ISO standard. So I was more than happy when this was fixed in Rhino 6, until now.

Attached image says it all - first image is from a PDF I created last Tuesday, second image was created today from the same rhino file.


My current rhino version is 6.12.19029.6381, 29.1.2019

@mary - do you know about this?


Hi Simon,
Thanks for the images.
You are correct. RH-45814 was a bug fixed to make Rhino 6 sr12 work like Rhino 5 sr14.
Now it works like Rhino 5 and does not draw the line.

With ISO, ANSI, JIS, DOD, CES and more, there are too many standards to make the decision to draw the line or not when arrows are place on the outside of the extension line. Also there are those that don’t follow a standard and have their own style that we want to support.

I have logged bug RH-50656 to ask for control of the dimension line. I am not sure if it will be addressed in the next version of Rhino or sooner. But the Rhino 6 sr12 behavior is back to match Rhino 5.

Thanks for alerting us to this issue.
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

(BTW AutoCAD has had the DIMODFL variable and control for as long as I can remember. They have it right - do not make the decision, but give control.)

1 Like

Hi Mary,
thanks for the info.

I find it surprising that are standards where it would be demanded the line not being there - I understand that when the text is not above the line but centered with it. But when it’s placed above the (now missing) line, it looks rather weird and confusing. I quickly searched for different standards and couldn’t find one where this would be the case but I’m of course not an expert on this.

If there really is a standard where 1) text is placed above the line and 2) when using arrows on the outside, the line is omitted; then it would be really prefered for there to be an option. This way it’s broken for everyone following the ISO or DIN standards which my guess would be is not a small group of people.

The change being made between “small” updates is rather unfortunate for me, when I need to continue on unfinished work. Is there a way to roll back to the previous version until it’s resolved?



Hi - please check the following folder on your PC to see if SR12 is still available there.
If not, I’ll get you a link.


Yes, there are several folders with random names, the newest one contains 6.12.19029.6381 and 6.11.18348.17061

Should I run the .exe in the 6.11 folder?

Yes. You’ll need to uninstall Rhino 6 first.

Alright, thank you. Managed to downgrade to the previous version without screwing anything up and the dimensions are now behaving as I wanted.

For me, dimension lines are missing for any dimension less than 6’. Can this threshold be set? (To Zero, Ideally…) I’m assuming not, from Mary’s post above.

Hello - As far as I can see this is related to text size to dimension ‘space’ ratio. Smaller text allows the line to show with a smaller dimension. I do not see any way to set it explicitly.


Well, it seems to make sense in that example, Pascal, but it’s not helpful in the below:

(In my decades of experience in Architecture, this has never been desirable, I echo Simon’s surprise.)

I’ll be rolling back also. Does this sort of uninstall and reinstall require porting over my preferences and options and macros and so on? If so, can you please direct me to the instructions for that procedure. It’s not something I can recall each time. I will need a link to 6.12 though ( I just updated from 10 to 13). 12 isn’t in my cache.


1 Like

Rhino 6.11 was the last version that didn’t behave like Rhino 5 - link in PM

Any changes to factory-default toolbars will be lost in an uninstall. These should be saved with a new name. Preferences and options survive an uninstall but it’s always a good idea to keep a backup (using the OptionsExport command). How are your macros defined?

1 Like

Hi Djhg,
Sorry again for the issue. We sided with the Rhino 5 behavior since users that upgraded to v6 were complaining about the line, while orphaning users like you that adopted the newer Rhino 6 (sr0 to sr11) behavior. Obviously, Rhino can not make everyone happy until this control is offered.

Control for the Dimension Line When Arrows Are Placed on Outside in Rhino 7 is on the tracker item RH-50656. I will let you know more when it has implemented, and I hope it will be sooner.

When this is available, you can download and install the WIP of Rhino 7 to have control over the line.

But for now, try and download Rhino 6 sr11 from here.
Let me know if it works for you.
You will probably need to uninstall Rhino if you have sr12 installed.

And if you worried about loosing anything your have customized, reference @wim’s suggestions above.

Mary Ann Fugier

As per the Rhino video tutorial for creating mx and my for mirroring across those axes. Will they survive an install?

This is an important issue. It’s a basic requirement for any dimensioning for it NOT to work only as it has for recent months. No line between hash marks for any dimension less than 6’? How could this possibly be an advantage? No professional in the construction industry, in my long experience, would require that. Until it’s fixed, those of us requiring typical architectural construction technical drawing standards are labouring with an out of date version. Please provide a fix.

The fix is already in Rhino 7 wip. Any user that has Rhino 6, can download and use the Serengetti (work in progress) release of the next version of Rhino.

As I explained earlier in this thread, this was a regression from Rhino 5 and many users were telling us that it was not working for them. These Rhino 5 users were updating to Rhino 6 and were expecting the same behavior as Rhino 5. It took a few releases for this to be addressed, but it was eventually rolled back to work like it did in Rhino 5.

The only sensibly option moving forward was to make Rhino offer the control of the dimension line between the arrow/tick. The user needed the power to decide in the documents, even having one file do the line and another not.

I believe the Rhino 7 SR0 2019-5-28 wip contains the control you are looking for. I just tested the fix on Friday. You can run Rhino 6 and Rhino 7 WIP side-by-side without issue. (if it is not in the public build, it will be there soon.)

You should be able to combine these three setting in the Annotation style under Text and Arrows to get any behavior that you are looking for.

If not, let us know:

  • what you are doing
  • what happens
  • and what you expected to happen.
  • Send a file that we can work with as well.

Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Well the problem is when you upgrade to a different main version, you expect some changes. You do not expect such changes (making things worse for a lot of people and screwing up projects you’re working on) in service updates.

Unfortunately the company I’m working for won’t upgrade to Rhino 7 anytime soon (running the free WIP version is only a temporary solution) so I’m either stuck with an outdated Rhino 6 or having to draw the missing lines myself which is of course not ideal for obvious reasons.

Thankyou Mary, I understood that from earlier in this thread.

Applauding your desire to serve the user base, and with all respect to the challenge of parsing the abundance of input you must receive (I can’t imagine): I’d like to as gently as possible - but assertively and confidently - suggest that your team may need a more broadly experienced set of technical drafting minds determining which input to follow than was involved with implementing that decision. No professional environment I have been in would accept the gap-laden dimensioning in the drawing I posted above, but R6 couldn’t do it any other way.

From what I see in your recent note above, a component of the issue may still be unaddressed: that of autmoating the behaviour of a dimension based on the threshold distance below which the arrows or text switch to the outside of a dimension.

If the text doesn’t fit between the hashmarks, it’s essentail for professional dimensioning that the text place itself automatically a) intially only as far beyond a hashmarks as required to clear it, and that it b) stay where a user places it if the user overrides that by dragging. Neither a) nor b) is the case with Rhino. Please see this post: Dimension Text Placement when outside Dimension Line

I haven’t been able to reproduce b). When a) gets implemented (RH-53019), please report cases where moving dimension text doesn’t stick.

1 Like

All of them. It will stay for a session, but usually: close and open a project and they go back to the default (too far) distance.