Rhino 6 dimensions disappear

unhandled

(Burak) #1

Hi,
I baked the dimensions with the Elefront component. After I select on of the dimensions for editing the properties dialog does not display the dimension properties. And after a few clicks dimension display disappears in the viewport. Please see the screensshot I have uplaoded.


Other curves and text also disappear from the viewport. Seems that Rhino is locked and not responding. It happened several times while working on the same file.


(Wim Dekeyser) #2

We’ve had an issue with disappearing dimensions and curves that was fixed in Release Candidate 5 of SR11.

That sounds like something else. Can you provide more information on this?
Also, please run the Rhino SystemInfo command and paste the result here.


(Burak) #3

I had to use end task, will send more info on this if I can repeat the problem. There were Make2D components automated in the GH definition, maybe the problem is connected to my definition.

Here is the system info:

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Commercial, build 2018-11-07
License details: Cloud Zoo. In use by: bkercan ()

Windows 7 SP1 (Physical RAM: 64Gb)
Machine name: MOBYDICK

Quadro K4200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.33)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-7-2015
Driver Version: 10.18.13.5382
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Burak\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.4.13.574\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Burak\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp “SectionTools”


#4

Looks like your Nvidia driver is over 3 years old. You might want to update that to the latest. The latest is 411.95 (11-15-2018)

https://www.nvidia.com/download/find.aspx


(Burak) #5

Not that much old, 391.33 is from March,27 2018… :slight_smile: Nevertheless I will try the latest.

Thanks. Will update if there will be new info on the problem.


#6

Interesting. The System Info “Quadro K4200…” line reports NVIDIA 391.33 (which I glossed over) and the “Driver Date” line says 8-7-2015.

@nathanletwory, @jeff, why this discrepancy and which is right?


(Jeff Lasor) #7

Which “System Info”? Rhino’s or Windows’ ? What does Rhino’s OpenGL settings page list for the driver date?

Driver dates, their locations, and how to actually get at them seems to be a lesson in futility sometimes…even MS gets it wrong sometimes…so if you’re seeing a bogus driver date somewhere, just know that some developer somewhere is trying his best to get it right :slight_smile:

Driver version on the other hand is actually something that gets returned by the actual drivers…so it will always be accurate… so if you’re seeing 391.33 as your version, then you can be sure that you’re using the March 2018 drivers.

-J


(Jeff Lasor) #8

Oh wait, I see the System Info dump above… Dang… so it’s Rhino getting it wrong (again)… I currently have no idea why the date is wrong atm… All I can suggest is that when you install drivers, that you always perform a “clean install”… NVidia’s installer has such an option if/when you choose the “Custom” install option. Windows keeps all kinds of residual information around for “just in case” scenarios, so I can only assume Rhino is running into older information and just not realizing it.

-J

Note: Uninstalling drivers ahead of time is NOT the same as a clean install… When Windows’ uninstalls drivers, it simply removes them from the “active list”, but they’re still on your system, along with all of the information that goes with them. A clean install completely deletes the current drivers from the system, and then installs the latest ones.


#9

I didn’t know that. Thanks for the very useful bit of info.


(Burak) #10

Thanks for the useful info but after clean install of the latest driver Rhino still shows the old date.

I have an other question regarding the dimensions. Although the dimension style is same for all, few of the dimension are properly drawn with dimension text above dimension line. Some dimension lines are trimmed at the dimension text location. All geometry baked from GH.

Any comments are much appreciated,
And after exporting as a dwg file some vertical dimensions are also turned upside down in AutoCAD.
Besides the dimension style properties are not properly translated to AutoCAD, and I have to manually correct them.


(Wim Dekeyser) #11

Are the dimensions also generated in Grasshopper? If so, can you reproduce the same issue when creating these in Rhino?


(Burak) #12

Everything is generated in Grasshopper. Dimensions, text, hatch, baking and exporting done with Elefront 4.2, Top and side views with Make2D.

The setting for dimension text is “Above” and “Horizontal”. After editing the dimension text “Above” and “Aligned” it displays correctly for all, but I cannot force fit text “Inside” by using the dimension style for the small dimensions. I have to manually select all dimensions and force to fit text “inside” from the properties dialog box.


(Wim Dekeyser) #13

I’m still not completely sure what you are setting where (GH or RH) but if I understood it correctly, you are asking that the Fit Arrow and Fit Text properties of annotations are exposed in the annotation style and not just in the Properties panel. Does that sound right?


(Burak) #14

I am setting the dimension style in Rhino and baking the geometry from GH to see if dimensions are displayed properly. I don’t want to modify manually after baking because there will be thousands of pieces like this.

As far as I can see I cannot set the properties of Fit Arrow and Fit Text within the annotation style. The only way to edit them is by selecting manually after baking and edit from the Properties Toolbar. Am I right or I am missing something?

The disappearing of the dimensions, text and some curves from viewport occurred again when I select and deselect dimensions several times for editing their properties.


(Steve Baer) #15

Did you update to 6.11?


(Burak) #16

Nope, not updated to 6.11 yet. I have to submit some drawings so I will check asap with 6.11 when I have some time.


(Pascal Golay) #17

Steve, this seems not to be gone yet in SR12 even on some machines- I don’t want to muddy the waters on this thread but I think this is the same thing, at least at the top of the thread as @john11 is seeing here

-Pascal


(Jeff Lasor) #18

That’s usually indicative of a clipping problem… It sounds to me like dimensions are getting clipped from the frustum for some reason… and since all clipping is turned off during foreground drawing (i.e. highlighted objects), they show up…

But that’s just my $0.02 observation here…

-J