Dimensions are doing wierd things in Rhino 6... why?

Rhino 5 dimensioning in layout worked nicely. Rhino 6 dimensions in layout do very strange things. If I try to move the detail view that has dimensions on it, I get a strange warning “Dragging broke history on 1 object”! What? And then, when reviewing my drawing, I notice several dimensions are completely off…what should read about 2’ shows around 8’! This is scary because I have to put out drawings quickly and they need to be accurate. Can’t have these mistakes!

Any ideas how to get dimensioning back rhino 5 style to avoid these problems?

1 Like

Hi Peter,
This is a serious issue.
In Rhino 6 History has been associated with the dimensions.
This is why you are seeing with the strange updating.

There have been a number of bugs fixed that relate to this issue. The latest should be available in the daily build by next week.
You can remove the history from the dimensions with this macro:
! '_historypurge 'seldim _enter

I assign it to my Control+F5 key, but any open key would work.

You will need to run this on each layout, and one a layout when you finish a dimension session.

I will ask Dale Fugier @dale to come up with a more sophisticated script that can will purge history on all dimensions on every layout and the model. This script could be run once and address all these dimensions.
And we will post it here soon.

Thank you for being this issue to our attention.
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

1 Like

Thanks Mary. So do I run this macro before I start dimensioning? Looking forward to an update that fixes dimensioning bugs! :slight_smile:

Hi Peter,
It is run the macro after your do your dimension or anytime and to every file that you are concerned about the weird dimension updating. You will need to walk though each layout and the the model in every model that you are concerned about. Putting it on the function key will at least make it easy to run.

So until there is a better option, you will have be diligent about this.
And we hope you will see some improvement in next week’s service release as well.

Thanks again.
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Hi Peter,
One more update…
In May, this year the developer added an this option in the History command called RecordAnnotationHistory. This will help you create new dimensions with out history. Existing dimension will still need to be striped with the previous macro that I shared.

It is not persistent, and will need to be run at the beginning of each editing session.
However, “Options -> General -> Run these commands each time Rhino opens:” will make it easy.
!_history Record=No RecordAnnotationHistory=no _enter

Every time you open Rhino, or a new or existing model, new dimension that are created will not be history enabled. And you also need to make sure and turn history On in the Status bar when you want to use it with other commands.

Let me know if this works for you.
Mary Ann Fugier

1 Like

I wish there was an option called revert to V5 dimensions
Along with the problems inherent in V6 dimensions, if you open a drawing created in V5 and work on it in V6 the dimensions are all screwed up.
It means it’s not possible to work back and forth between V5 & V6 for some of us.

Hi Arail,
Could you send me some example of file that do not save back to Rhino 5?
Of course, when you get drawing in Rhino 6 it is not optimum to go back.

However, please attach files and specific examples that do not save as Rhino 5 and open in Rhino 5 as the look in Rhino 6. I will see if there is anything that can be done to help.

Mary Ann Fugier

I will do that tomorrow.
The problem is that many projects don’t have a clear beginning and ending.
I just got a request to make revisions to a project that I began a year ago.
There are 20 pages of layouts in that project.
If I opened it in V6, I would have to revise every one of the 20 pages.
Not good.

I think the scaling issue has been corrected and should be in next weeks service release candidate, hopefully.



Actually the alternate units feature is still broken. Not sure if this is related or not. I know I can specify alternate units in mm or inches and that works ok but scaling by a number is not. I’m on Version 6 SR8

Abraham That does appear to be broken.


Would it be a feasible feature request for Rhino 6 to have program wide option to remove history from dimensions?

It’s been extremely frustrating to have history on. As mentioned, changes to details can change the value. Also, I often run into cases where I constantly get nagged with pop-ups that changes are breaking history, in most cases I don’t care. Also, when objects are on top of each other, I don’t know I’m dimensionning to which part. So I have had multiple cases where I inadvertently dimension to construction geometry I end up moving and then my dimensions are messed up.

This is probably an anxiety shared by many designers here: dimensions are the last thing I want to be changed for me. Even in very robust parametric CAD programs, I go through drawings with a fine toothed comb after doing model changes.

I have another dimensions quirk to add. In 6 lately arrowheads aren’t showing up properly when inserted as part of a block. The arrowheads will always stay at 0,0 regardless of where the block is moved. If the block is exploded they appear properly on the dimensions.

That arrow display is an unfortunate bug indeed. It’s on the list to fix for @Steve.
You can work around it for now by running TestDimensionCache to toggle off the use of caches in dimension drawing.

1 Like

To disable recording history for annotations when history is otherwise off, you can run the command-line version of history “-History” and set RecordAnnotationHistory = No.
If HistoryRecording is on in general (Record=yes), annotation history will still be recorded.

1 Like

Hi Abraham,

Thanks for reporting. The issue is logged here

Hi Mary, this issue is related to printing pdf’s also now, Please see the latest posting here: Rhino PDF not working! Help!

One more dimension related bug to report: dimensions are not adding up properly. See image below showing the overall dimensions with an incorrect 1/8" … and if this is a tolerance issue, then Rhino should round dimensions so this doesn’t happen (IMO).

Just to be sure, could you upload that file?

I’m pretty sure this is a tolerance issue, though, and this has come up once before but I can’t find the thread at this point.

Hello there all, I am having issues with getting the dimensions to work as I want them to work(like in rhino 5, nice and easy.) It seems I have adjusted every setting but my dimension keeps coming up 0". I have changed the scale , the size of the font, arrow, lines everything?
This has to get easier at some point. It would be great to go back to Rhino 5 dimensions or make them simpler and the sizes would scale automatically. Also the lay out of the dimension preference window is so annoying meaning I hate having to scroll with in a window within a window, what is the point there? It’s a bad design, I think when you select he dimension preference window it should pop up as big as it needs to be so you can see all of the options without scrolling down. It’s one idea anyway. Anyone have any suggestions? Thanks Dave