Dimension in V5 and V6

unhandled

#1

Sorry to raise this again.

It has been suggested to me that when V6 cuts dimension text in half it is something to do with Windows updates and or the Intel graphics driver on my HP laptop.

I updated Rhino 6 yesterday and now all the text in a dimension disappears.

I have Rhino 5 on the same machine. I have tried cutting and pasting between V6 and V5. In V5 the dimension line shows correctly with its text, but in V6 the text disappears.

Notice this effect is the same if the original geometry is created in V5 or V6.

The laptop is the common, The operating system is common. The drivers are common. V5 is OK V6 is not.

It looks as if it is entirely down to a bug in the Rhino code.

Any thoughts?

Bill


#2

Yes, but V6 uses completely different display code than V5… So the same video driver will react completely differently with V5 and V6. Older integrated Intel graphics are difficult to support.

Did you post the results of SystemInfo in Rhino somewhere here on the forum already?


#3

Hi,

There may be difficulties in supporting older drivers but yesterday I had a partial dimension text display and today I don’t have any. The only change has been a rhino 6 update. Clearly some effect occurs within recoding the updates.

I did post the systeminfo file before.

I have 5 HP machines affected by this. These machines are used for Rhino training.

I hope one of the McNeel experts can find a solution to.

Thanks

Bill


#4

Yep, I think @stevebaer has been tweaking the display code for several releases now…

If its from here, your drivers are from May 2016, or more than 2 years old. Definitely need updating, and I might venture to say nobody is going to “fix” anything until that is done and still proves problematic…


(Steve Baer) #5

That isn’t really the problem. You’ll notice that the output reads Microsoft GDI Generic. This means Rhino isn’t able to find a graphics driver at all for this computer. Does V5 also read Microsoft GDI when you go to the OpenGL page?


#6

Ah, right sorry, jumped right over that… :confounded:


#7

The drivers I have are the latest. Old I know but Intel has no plans for further development.

What I don’t understand is why McNeel can clearly produce code that generates V5 dims satisfactorily but V6 has deteriorated in this function on the same laptop.

Would it be possible to select older drivers for use in V6 in the options panel or perhaps disable open GL altogether in order to achieve some function to the dimension notation?

Thanks


(Steve Baer) #8

It’s not that the drivers are old, they don’t exist as far as Rhino6 can tell. It very well may be something we need to change in Rhino, but I can’t tell yet. Can you post a screenshot of what your Rhino 5 OpenGL settings page shows?


#10

Is This what you need? Thanks. Bill


(Steve Baer) #11

@jeff can you take a look at this? It looks like Rhino 5 is picking up the Intel OpenGL drivers, but V6 is not.

You can see the results from systeminfo in V6 at


(Jeff Lasor) #12

Interesting… V5 manually selects pixel formats, whereas V6 just allows the “system” to choose one… And the pixel format is what determines which driver gets loaded the second a context is created. So this tells me that the system isn’t choosing a hardware accelerated pixel format by default…which can’t be right, so I’m probably wrong…just thinking out load atm.


(Jeff Lasor) #13

Yes Bill…and I’d also like a similar screenshot from V6 just to confirm our suspicions.

Thanks,
-Jeff


(Jeff Lasor) #14

If I were to guess… I would say that somehow hardware acceleration has been turned off in the Advanced OpenGL settings.

Go to Options->Rhino Options->Advanced…

Scroll down until you see “Rhino.Options.OpenGL.xxxxx” entries.

Look for the entry “Rhino.Options.OpenGL.UseHardwareDriver”…

Is it set to “False” or “True” ?

Thanks,
-Jeff


(Steve Baer) #15

I thought that too, but noticed the systeminfo results said the opposite


(Jeff Lasor) #16

Ya, just noticed that too… very odd.

-J


(Jeff Lasor) #17

@RhinoCAD

Bill, unzip the attached file and place DeviceID.exe on your desktop…and then run it.

Take a screenshot of if after it starts, and then take another screenshot of it after having CHECKed the option “Driver summary only”… Then please post the screenshots here.

Thanks,
-Jeff
DeviceID.zip (795.0 KB)


#18

Hi Jeff and Steve,

Thanks for looking at this. The screen shots are attached.


(Jeff Lasor) #19

Thanks… Very odd indeed… The DeviceID program is finding the Intel GPU and driver, but Rhino is not… The odd part is that I wrote both of them, and they pretty much do the exact same thing.

This is going to sound strange…but please bear with me…

Rename DeviceID.exe to Rhino.exe and then run it…

Are the results the same as your screenshots?

Also, did you ever go into Rhino options and check/confirm that the “Rhino.Options.OpenGL.UseHardwareDriver” option is set to TRUE?

Thanks,
-Jeff


#20

Hi Jeff,

Here is the screen shot from “rhino.exe”. I dont recall setting ‘use hardware driver’ to true. I confess I can,t even find a place to do that in 5 or 6.


(Wim Dekeyser) #21

In Rhino 6, under Rhino Options > Advanced - write usehardware in the search box:
image