OSnaps do not stay put

Hi @brian, i cannot see this working here yet. Once i have docked eg. my Osnaps panel below the main toolbar on the left and the Layers panel below other panels on the right and reopen Rhino 8, the panel positions of the Osnap panel and the Layers panel are shifted upwards. Below shows what i have:

Below is what i get after closing / reopening Rhino 8:

I’ve tried to save the first state as panel position multiple times. Restoring causes that the Layers panel on the right is not visible at all and the Osnap panel still is shifted upwards.

Also, please note the wrong background colors (i’m running Windows 10 in darkmode but Rhino 8 in original light mode. Once i drag the Layers panel or Object Properties panel out from the docked state, the dark gray background colors turn to white (which seems to be the correct background color for light mode).


1 Like

@clement I don’t have a solution or a clue just yet, but can you try the following:

restore Rhino to the default Window layout, then close Rhino and reopen, will this stick?

if so can you then zip up the xml files from this location:

and then adjust again to your preferred layout, close rhino and zip the xml files from the same location again, then send both zips? I want to see if I can spot a difference with the files my Rhino is generating.

Hi @Gijs, thank you for investigating the issues.

Yes, i’ve restored default positions from this menu item:


then closed Rhino and zipped the two xml files in the %appdata% folder which is this file:

Default_settings.zip (5.2 KB)

After reopening Rhino, it looks the same as when closed, everything at defaults. I’ve then made the following changes to the window layout/panels:

  1. On the left side: dragged the Osnap toolbar down and made the Main toolbar 2 columns wide
  2. On the right side: put the Layers panel below the Properties panel. Then for the upper group of panels, i’ve added Materials, Rendering, Groundplane, Environments and Display panel. For the lower group of panels i’ve added MacroEditor and Notes beside the Layers panel. So it looks like this:

then i’ve closed Rhino and saved the xml files: Changed_settings.zip (5.2 KB)

After reopening Rhino, i can see that the panels i’ve docked and moved down, are shifted up as reported in my recent post, it looks like this:

It seems to remember the 2 column width Main ToolBar and the panels i’ve added on the right side. But the positions are not properly stored for panels docked below the Main Toolbar and the Properties panel…


thanks @clement, I will have a look shortly

@clement, I think I did not ask you the right thing. It looks I probably need the whole settings folder.

One thing I just noticed is that your xml files are about half the size as they are here.

Hi @Gijs, ok i can do that an send it via PM as this includes a toolbar/ workspace for some custom tools.


@clement this issue is listed as https://mcneel.myjetbrains.com/youtrack/issue/RH-70275

I will add this thread and mention all the things we tried so far. Thanks for sending all the info and files.

Hi @Gijs, thanks. At least i am not the only one who experiences this issue. :wink:


Hi Clement,

can you check something. Wim suspects that this issue is related to systems using either comma’s or points. If you make a model in cm, then change the unit system to mm, Which of the 2 dialogs do you get?
1 (showing 0,1)

2 (showing 0.1)

Hi @Gijs, the one with the comma:


Windows 10 - 22H2 (german) in dark mode.

thanks, that confirms it.
I just tested it here (I have the .) and if I change the decimal sign to , I can repeat the issue you have been seeing all the time.

Hi @Gijs, thank you, i owe you a beer for your persistence :beers:


Thanks, I’ll pass it on to @wim for finding the cause!

RH-70275 is fixed in the latest WIP

4 posts were split to a new topic: Fullscreen messes up window layout