Bug? Docked OSNAP toolbar not appearing

I’ve got an odd issue with the OSNAP selection box not staying visible when docked. Every time I start WIP, I have to drag it from the corner so it is floating, then re-dock it so the tick boxes are visible:

Is there a setting that has changed on WIP to fix this - all the other toolbars and panels seem to work fine, just the OSNAP.

Hi Deri -

By the looks of that, the column is simply too narrow for the snaps to be shown. Have you tried running the WindowLayout command and restored the Default Window Layout? In a factory-default setup here, that looks like this:


Hi Wim
Thanks for the reply. The standard windows layout now seems to give 3 columns of buttons on the LH side, rather than the old 2 columns. I’ve got my setup with 2 columns and if I drag the OSNAP out and back, then it fits under the 2 column toolbars fine

, but doesn’t stay like that when closed down. Trying to put the OSNAP underneath the view tabs at the bottom of the screen has the same problem - it looks fine like this:

but close down and re open and the checkboxes disappear.
I’d rather either have the OSNAP toolbar at the bottom (works fine in Rhino 7) or in a 2 column side bar so that I’m not eating up more screen space. Also, having used a 2 col side bar for the standard toolbars for so long, not sure my hand/eye coordination would be able to deal with the locations of buttons moving :wink:
Hope that helps.

Hi Deri - you can of course move the toolbar where ever makes sense but one thing to try if you have not is moving the tabs on the left side to be horizontal - i.e. along the top of the Osnap/Filter panels - this can, as of this past week, be set independtently on the left and right docked containers.




Bingo! Changing it to horizontal worked for the left hand dock with two columns of tools above and that all works nicely thanks.
However, trying to dock it along the bottom still gives issues - it reverts to this when I close and re open Rhino:

You either have to drag the OSNAP tab up and then re-dock it, or use Window layout, revert to the default and then re start your saved window layout, where it will dock properly. Not sure what the issue is, but thanks for getting me sorted on the LH docked OSNAP.

@Deri_Jones is this still an issue for you in the latest WIP? I can’t reproduce it in the build of the day.

Sorry, missed this query - it appears to be working fine in the latest WIP. Thanks for sorting it.

1 Like