WIP 8 Antialiasing issue

Trying out WIP 8 today. Immediately noticed that the antialiasing is not working very well. R7 is much sharper looking with settings at 8x. Changing between 2x, 4x and 8x antialiasing settings in WIP 8 seems to have no effect, but it gets worse when you change it to ‘none’. Anyone else report or experience this? To be honest it looks so bad I am going to switch back to R7 for now

I’m not seeing much of a difference here.


Not sure if this would have anything to do with it, but I would suggest you make sure you have the latest graphics drivers.

Dan

Yeah I am getting much more jagged edges in WIP 8. Edge clarity seems to be very dynamic too…when I am orbiting around my model the edge sharpness changes very drastically depending on viewing angle etc.


WIP 8


R7

Hi Brady,

Do you have your labels mixed up? That top image looks a lot smoother than the bottom, but you have the top labelled as WIP 8. I’m guessing the bottom one is really from the WIP.

Oh my gosh, yes I did mix the labels up sorry.

First of all run the systeminfo tool on both rhino and upload them here.

My first guess is that wip8 is using the embedded Intel video device instead of your dedicated card.

SYSTEM INFO FOR RHINO 7

Rhino 7 SR22 2022-8-29 (Rhino 7, 7.22.22241.07001, Git hash:master @ 752c32917c9a5a67a84684d402757f922e6d7ed9)
License type: Commercial, build 2022-08-29
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 7-21-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.94
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-21-2022
Driver Version: 31.0.15.1694
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.22.22241.7001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\brady\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

SYSTEM INFO FOR WIP 8
Rhino 8 SR0 2022-8-30 (Rhino WIP, 8.0.22242.00305, Git hash:master @ 4db61e882aa09c39e4a74abb93e956c0185012c5)
License type: Commercial, build 2022-08-30
License details: Cloud Zoo
Expires on: 2022-10-14

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 7-21-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.94
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-21-2022
Driver Version: 31.0.15.1694
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\Constraints.rhp “Constraints”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\BlockEdit.rhp “BlockEdit” 8.0.22242.305
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.22242.305

Here is another couple of screenshots


Hi Brady -
If I’m not mistaken, that’s on the list:

-wim

Seems like a similar problem yes. Any comment on why changing the antialiasing settings has no visible effect (ie, x2 looks the same as x8)?

I have this same problem using a 3060ti… So probably related to NVIDIA drivers?
By turning on FXAA in the nvidia control panel I was able to get some AA back, but It’s not as good as Rhino 6 or 7.

Glad I am not alone. I think this would be considered a regression and I would expect to see a fix before R8 launch.

Talked about it also here:

NVIDIA GTX 1060 used there.