WIP 8 Antialiasing issue

Hi, I’m having the same issues. It looks as if there’s some sharpening effect active in the viewports, which creates bright pixels next to the edges. A bit like unsharp mask in photoshop.



See also Rhino 8 - Ghosted display mode - weird outline around surface edge curves

I hope this gets addressed soon. R8 is hurting my eyes and I am quite surprised R8 got released like this.

Compared to other 3D programs that I am running, Rhino8 looks like going back into time 25 years. Happy 25 anniversary by the way :D.

R8 has lots of nice new features, but drawing and displaying lines is the utmost basic of a 3D program and shouldn’t be forgotten.

5 Likes

Absolutely.
We won’t be heard, but that’s also part of what I reported in the past months.
Something should be done.

Yes line quality is a big step backwards in Rhino 8.

Hope to see a fix :slight_smile:

3 Likes

Absolutely true!

Curves were not perfectly aligned to pixels, that came in V6.
In theory the V6 feel should be even better, it’s not, I can’t explain why.

V8 needs some love.

correct . It needs a lot of smoothing and improvement. He looks fragile now

1 Like

I’ve found a possible fix using the nvidia control panel that I posted over here.

These settings do nothing for me unfortunately, still terrible AA

FWIW, I’m on an RTX 3050 with the latest drivers (546.33). Also, I had to exit all open Rhino instances and re-open for the settings to take effect. I’ve noticed over the last few hours it’s been a big improvement on my setup but I think overall Rhino 7 is still looking better. I recall having a similar issue when either 6 or 7 came out, I had used the TestWireThicknessScale setting to get through that one until they got it fixed.

I’m having the same anti-aliasing issue. It looks horrible in Rhino 8.

I made the changes suggested in this thread to my NVIDIA Control Panel. This seemed to help, but it’s still noticibly worse than Rhino 7.

I would really appreciate a fix to this as soon as possible because it’s quite straining on my eyes.

System Info

Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Studentenlizenz, build 2024-02-13
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.2

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2200 (NVidia) Memory: 5GB, Driver date: 5-24-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 535.98
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-16-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-24-2023
Driver Version: 31.0.15.3598
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Here with custom display there is big issue in Rhino 8 anti-aliasing.

Custom display mode Antialias issue - R7.3dm (827.9 KB)
Custom display mode Antialias issue - R8.3dm (820.2 KB)
1. AO-Rendered - R7.ini (13.9 KB)
1. AO-Rendered - R8.ini (15.4 KB)

hi @Teo could you try with these settings and see if things get better for you?

1 Like

Amazing Gijs kudos to you! Thank you very much. :grinning:
This is now working great in combination with this advanced option setup: