Windows 10 Creators Update - REVISED - Fixed with V5 SR14

unhandled

(Scott Davidson) #1

Microsoft continues to march toward a rollout of the new Window 10 Creators update. At this time we recommend DO NOT use this update. At this time the update is a “soft rollout” and the upgrade must be manually started. At this point there only a few that have the update.

Some of the issues we are seeing:

  1. Some customers have had crashing problems. Most of these problems have been fixed by updating video drivers to newest version.
  2. The update also enables previously disabled plugins. The new update seems to reset the registry.
  3. The Creators update has a new way to deal with high DPI settings. This is especially problematic as the Layer panel may not draw any of the layers.

Some other things we have tried:

  1. Rhino 5 using no additional setting will use the Manifest trick. The text and toolbar buttons are the correct size, but the Layer panel does not work.
  2. Rhino 5 using the Application setting will display everything, but the Toolbar buttons and buttons in the layer control are quite small.
  3. Rhino 5 using the System option will make the text and toolbar look correct, but the layer panel does not work.
  4. Rhino 5 using System Enhanced will force the viewports to redraw in the incorrect location.
  5. Rhino 6 using no extra settings works fine.

We are currently trying to determine how to solve these issues. If you are having any issues, please post on this thread.


Layers tab won't let me access Layers- Help
Layer panel does not work
Bug? Unable to select layers
Layer does not show anything
Edge analysis window is blank - Win 10 "Creators update" warning
Rhnio 64bit extremly laggy, but Rhino 32bit fluent...?
Layer window empty
Layers toolbar not working after vray 3.0 install EDIT windows 10 update is the issue not vray
Print command bug
Rhino Layer Issues - Layers disappeared from layer tab
Toolbars and text too small in 64-bit Rhino on high resolution screen
Layer Properties Blank!
No templates or toolbars in Rhino 5 on Windows 10
(John Brock) #2

#3

Thanks for the heads up Scott!


#4

I’m not sure the WIKI Rhino hi-res solution is official one so it’s a bit hard to say, but since the icons were quite small I used the
Rhino.exe.manifest file(placed it under system folder for 64bit rhino,
and added key by using RhinHiRes file.

Just wanted to make the icon a little bigger since using an 15inch/4K display on XPS15 dell laptop.

If using English as the language it seems ok, but in Japanese I can’t properly see the document properties.
Not sure if this was due to creators edition or if happened before.
Just started to use WIN10 and updated to WIN Creators Update so difficult to say.
attached screen capture for both Eng and JP.

Is rolling back from Creators Update to previous WIN a simple task?


(John Brock) #5

Are you using the “Application” setting:


#6

Hello,
I didn’t read this post before updating, Unfortunately I carried on with the update and Rhino has since stopped working entirely! It will open only in safe mode. I’ve tried 32bit and 64.
Please I’m in need of a fix or solution.

Thank you


#7

Hi,
I set to override high DPI to application and seems now the icon is smaller again, though the property panel is now working in both languages.


(John Brock) #9

At the moment, that is the best you can do.
We are working on the problem but do not yet have a good solution.

If Rhino is your primary use for this computer, the only additional work-around I can suggest is to reduce the screen resolution Windows is using. Of course, this will change the resolution for everything.


#10

Hi John,
Thank you for the quick feedback.
Is it possible for Rhino to go into windows display setting and
change the resolution when it’s running?
Sort of like a shortcut?


(John Brock) #11

Sadly, I don’t think that is possible.
I hope our efforts with the Microsoft developers behind this change will yield some results, but I have little confidence that will yield a fix.
The real fix will probably be Rhino V6, but that will not work for users with V5 plug-ins that will not be updated.


#12

Try nircmd:

http://www.nirsoft.net/utils/nircmd.html

You can create a shortcut like this on your desktop:

“C:\Program Files\Nircmd\nircmd.exe” setdisplay 2560 1440 32

May be it’ll even run from within Rhino


#13

The only workaround found so far to be working is to open the display settings panel set the scaling to 100%, start Rhino, wait for load whereby the layers are displayed correctly, then scale back to 250% (my case).


#14

Thank you for the response!


#15

Thanks I’ll look into Nircmd looks like a nice tool for other uses too


#16

Didn’t think about that. Is it stable? Like when going
back from sleep?


(John Brock) #17

These might prove useful to clean up the mess this Windows update is causing:


#18

Hi

I just found out about this problem. However, since I just bough windows 10 days ago, I might be stuck with the creators update? I’m not sure. But I have the layers palette not working, and I’ve put the manifest file there to see the icons.

There is no option to rollback to a previous version in my settings at least.

Is Rhino 6 my only option?

Regards

  • Björn

(Wim Dekeyser) #19

Did you try the scaling trick that was described in this thread? It appears to work for others as well…


#20

hi
Just faced the problem today,its only rhino5 x86 issue.I was surprised by missing layers,the tab is there but nothing inside.the rhino x 64 is fine.tried the suggested override DPI scaling by application and everything now works like it should.Thanks!


#21

Just a warning that the update in my case did NOT have to be started manually. It installed as a regular windows update much to my chagrin.

Dennis