Rhino 5/Windows 10 Display Issue

I just got a new laptop (Acer V15 Nitro) and it has a GTX 960M video card. I’m getting Rhino setup, but having a weird display issue. Lots of stuff is getting “scrunched” vertically - see the attached. The issue with the text on the right of the splash screen seems to show up in a variety of areas.

Any ideas?

-Sky

I should probably also mention the laptop has a 4k monitor, and one thing I can’t seem to do either is find a way to bump up the size of the Rhino icons - for instance the ones on the left side. Also note how the “Grid Snap/Ortho etc” buttons at the bottom are super scrunched together.

Hi, Sky

What’s your display resolution set at? Have you updated your drivers and system?

It’s at 3940X2160, and yes I’ve updated to the latest driver for my display card. I also made sure in the Nvidia control panel that it’s being used for Rhino and not the built in graphics card.

Nevermind, got it figured out! The trick was to bump down the screen resolution, AND REBOOT. Reboot was key.

Been seeing this a lot recently as well on student computers with 4K screens… What needs to be done exactly? I need to be able to tell them what to do.

–Mitch

I think it is the Windows upscale that f***s it up.
So just set it back to 100% and see if that helps.
(Log off log in might be required)

The scaling doesn’t give me any problems - it was the 4k resolution. Really the fix is simple - set it lower - I put mine down to 2048X1152 and rebooted. Reboot is key - closing Rhino, resetting res and reopening Rhino had no effect on the display weirdness.

1 Like

Yes, that is the best you can do for Rhino 5 (adjust the resolution). Unfortunately getting Rhino to be DPI aware un the high res screens is a pretty massive project. We are working on this for Rhino 6.

To be frank you should work on this for V5. 4K screens are here and have been for years allready and V6 is not here. NOT supporting 4K and reccomending people to set the resolution lower just doesn’t cut it IMO.

Supporting 4K is requiring rewrites in many different areas of Rhino and these are not minor fixes here and there. Even if we stopped all development and focused on this for V5, I think we would have a less stable Rhino because the side effects from adjusting for 4K need many months of testing to make sure they are accounted for.

That’s what I figured! Funny enough I tried to get the non 4K version of this laptop and they were sold out everywhere online. I bet in about a year it’s going to be hard to find a NON 4k laptop that is loaded the way us Rhino folks like. I suppose the important thing for people to know is it’s not enough to change the res, you have to reboot too. Spent a good 2-3 hours freaking out before I realized that!

You may also want to try the section on “fixing dumb programs” in this article

I understand that adjusting all UI so it is ergonomic on a small 4k screen is a lot of work, but I am talking about getting rid of the bugs so people don’t have to set a different resolution in the OS, because that is a flaw and a serious bug IMO.

People buy 4k for a reason and pro CAD is one of the things that benefit from high resolutions, I think it is ok if the icons, the text and the UI is small and fiddely, that is the users choise for going 4k, but it should not be buggy, clipping text etc.

There should be technical issues category in the forum for stuff like this. I imagine it would save some people a lot time and frustration. It took far too long for anyone at McNeel to even address this.

With a System Registry key addition and copying a manifest file to the folder where 64-bit Rhino V5 lives, you can fix the small icon problem on high resolution monitors.

The details are in this new FAQ support document:
http://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

This also fixes the same issue for Grasshopper in 64-bit V5

This works fine on the 32bit version of rhino on my xps15, but I can’t get it to work on the 64bit version. I have copied the manifest file into the 64bit version’s system folder and merged the reg file. Any ideas as to why the 64bit version seems to be ignoring the manifest?

J

What John says worked for me on my Surface pro 4 with rhino 64 bit, so check all the passages because it should work…
The only issue is that also the lines in the viewports are scaled so, practically, it’s like having a lower resolution screen but only in Rhino. Far better than lower the resolution for everything, not really THE solution because lines and render preview are like having a lower resolution screen…

But for McNeel it’s a huge mistake not having developed a scalable interface for Rhino 5. Hi-res screens are on the market from years now…