V5 sr14 display issues after - creators update


(Przemysław Doliwa) #1

Hi,

i have very strange issue with rhino viewports after (ms forced update to 1709 win)

First thing is that viewports doesn’t redraw on resize - i need to move camera to get it back to normal
as on screens


when back to normal

Second thing is that i can’t get proper interactive rendering with thea in viewport - i need to switch off hw acceleration then it works if not viewport just freezes and starts again when i’ll stop ir

Quick specs:
Win10 1709
Intel HD 530
Quadro M4000M

So far -> Rhino installer repair -> clean nvidia drivers install -> clean thea 4 rhino install + few reboots

Any thoughts?

Edit: I checked also safe mode but it don’t take nvidia card/drivers under consideration at all as i see.


#2

I’ve had this problem for quite some while, myself.
Sadly McNeel seem to only focus on Rhino 6 at the moment…
I guess the only solution is to wait it out…

At least the major crash issues doesn’t occur that often anymore.


(Przemysław Doliwa) #3

Can you write down your sys specs? So far i think this is something related to OpenGL handling here.


#4

Have a look at this thread:

Rhino 5 64-bit: Maximizing a viewport results in a low-res (pixelated) cached/static view of such viewport

And this one:

Rhino V5 FREEZE: Win 10 1709, nVidia display adapters, & V-Ray 3


(Przemysław Doliwa) #5

@Brag0n Thx for links mate!

I had 1607 all the time and all was running smooth also i didn’t had issue with thea ir.

I made update to 1703 and then to 1709 and issue occures on both updates. I tried to reinstall rhino / no luck || ddu + clean instal of nvidia drivers / no luck || in my case plugins aren’t related to this issue as far as i see now ill try to roll back intel hd 530 display driver but as i see this is the same driver i had earlier (it’s date is 11/11/2016) so this is rather rhinos internal gpu handling stuff

Edit: i tried on dektop xeon / quadro / gtx / 1709 and there’s no issue - viewports are ok no fuzzynes and thea ir is on its place overlaying normal viewport

Edit2: Very intereting finding is that when i pluged in hdmi and turned off hd 530 rhino behaved on different screen as it should.


#6

It only happens with dual GPU systems and started happening after Windows 10 Creators Update. It has to do with the changes introduced in the way accelerated surfaces are transferred from DGPU to IGPU framebuffer. It has nothing to do with Rhino itself.

A possible fix in the Rhino 5 viewport rendering pipeline would be to run a viewport refresh in every viewport each time viewports are maximized/restored.

Rhino 6 is not affected by this maybe due to changes introduced in viewport rendering pipeline.
It is up to McNeel to develop a hotfix for Rhino 5.

It also affects previous versions of Illustrator CC when the viewport is changed from GPU mode to CPU mode.


(Przemysław Doliwa) #7

Oh indeed? It happens not only for dual gpus cause if i turn off hd 530 problem remains… Also there are different issues with gpu discovery for eg. on sys with has gtx and quadro rhino discovers half of first and half of second. Not to mention tripple gpu setup but as i see theres also no issues - cause thers no intel integrated graphics - so mainly systems which will be affected will be those with integrated intels pseudo gpus and compute devices behind them.


#8

Turn off the DGPU and the problem will go away. It is not even a workarround but a way to confirm the bug. When you disable the IGPU you can still render OGL accelerated surfaces and those are also copied to the IGPU in VESA mode. So that is why the problem continues when you disable the IGPU.
You do not actually disable it you just move into VESA mode.


(Przemysław Doliwa) #9

One moment need to dive into BIOS


#10

What setup do you have?

In my case a laptop with Intel (IGPU) + NVIDA (DGPU).
If I disable the NVIDIA GPU via Windows Device Manager the problem goes away.
In my case I cannot completely disable the IGPU because both LVDS and HDMI are hardwired to the IGPU.


(Przemysław Doliwa) #11

I wrote in first post - but anyway hd 530 and quadro m4000m

And you were right i’ve turned off intels shi*** hd and now everything is back to normal.

But this is rather workaround cause when i use 530 crap for viewing sys and rendering on m4000m system remains responsive instead of having slideshow.

Anyway i think this should be somehow solved cause turning off gpus isn’t any solution cause gpu rendering people will loose performance that way.

EDIT: btw. can’t u just turn on in bios gpu discrete mode ?


#12

Sadly, with most Intel laptops you are stuck with their integrated GPUs as both the internal panel (LVDS/eDP) and connectors (HDMI/DP/VGA) are hardwired to it. That means that whatever is rendered by the DGPU is always channelled through the IGPU causing this kind of trouble.

In some laptops the HDMI port is hardwired to DGPU instead of IGPU.
Also, some gaming/professional laptops offer the possibility to bypass the Intel GPU completely.


(Przemysław Doliwa) #13

In my case on hdmi rhino worked as expected (when intel hd was on) and now in bios i just bypassed intel gpu and running only quadro m4000m on laptop screen and works also as it should.

Btw. is there a way to enable/disable hardware accelerated mode via macro ?

_-OptionsPage OpenGL ?? and whats next ?