Fuzzy display in V5 after SR14 update?

(John Brock) #1

A few people have noticed you might end up with a slightly fuzzy display in Rhino V5 after the SR14 update.
This is easily fixed.

Run the “About this PC” command in Windows to determine your Windows version:


  • In Windows 10 “Creator’s Edition” (1703), Rhino 64-bit desktop shortcut right-click > Properties > Compatibility > Uncheck “Override high DPI scaling behavior…”

  • In Windows 10 (1607), Rhino 64-bit desktop shortcut right-click > Properties > Compatibility > Check “Disable display scaling on high DPI settings”

If you still have display problems, you can run the new “SetDpiAwareness” command and disable the SR14 fix, and restart Rhino.

Latest V5 update display difference
Rhino only detects 64mb video ram
Resolution problem after update
Rhino 5 interface suddenly looks blurry on 4K display [FIXED]
Battery Prob with WIN10 using Dell XPS15 9560[Solved]
(John Brock) #3


HELP! I upgraded my Rhino and am having blurry issues as long as small and cut off type in the menus and icons at the bottom of my screen… I am running Widows 8.1 and I upgraded my drivers which are Nvidia geforce gt 750m/pcle/SSe2. my program was running perfect before this new upgrade…very frustrating I am working on a huge deadline…What can I do? Thanks, Jeff

(John Brock) #6
  1. Right-click on your Rhino 6-bit shortcut
  2. Click Properties
  3. Click on the Compatibility tab
  4. Check the option to disable display scaling

Does that get you going?


THANK GOD! it seems to help…THANK YOU!!

(John Brock) #8


Now includes specific details for Win 7, Win 8.1, Win 10 Pro (1607), and Win 10 Creator’s Edition (1703)