Tool palettes bug

I have this macro for the left screen edge: _ToggleActiveToolPalettes (Rhino Preferences → Mouse → Screen Edges) - and in Rhino Preferences → Tool Palette I have “Hide tool palettes when starting commands” checked. When I touch the left screen edge my chosen palettes ‘pop out’ (as they should) and when I start a command they disappear (as they should). However… When I finish the command the palettes pop out again - which they shouldn’t. This happens regardless of what command I’m using.


Any chance this could be fixed before the next WIP?


We recently fixed a major bug with Hide tool palettes when starting commands. Are you still experiencing this bug in the latest RhinoWIP?

Yes, still a problem. That fix didn’t help, unfortunately. The problem is still here in Version 7 WIP (7.0.20042.12036, 2020-02-11).


Here’s a video of the problem (I usually don’t have all these toolbars ‘pop out’, though).


I would expect the tool palettes to reappear. I interpret “Hide tool palettes when starting commands” as “Hide tool palettes when starting commands (and show them again when the command ends).” It sounds like that is not your expectation. Perhaps I’m completely misunderstanding how that feature is used or expected to work.

No Dan, sorry, absolutely not! They should appear only when hitting the screen edge - and disappear when starting a command. Nothing else (this is the way they work in V6 and V5 - you can check if you like)! Otherwise the toolbars would be visible and obstructing the view 90 % of the time when modelling (like they are doing now).

Sorry, but yes, I think you are.
I’d like to have them working the way they do/did in V6 and V5.


Please bear with me a little. For the moment, let’s ignore your screen edges bug completely (we can come back to it later).

Rhinoceros > Preferences > Tool Palettes > Hide tool palettes when starting commands

predates my time here at McNeel, so I have to calibrate my expectations as best as I can.

In this case, unfortunately, the documentation is not helpful.

As far as I can tell, this feature does not work at all in Rhino 5.5.5 and 6.23. If I reset my preferences, then enable Hide tool palettes when starting commands, they do not hide when I start a command. That seems like a bug to me. In fact, if I restart Rhino, having this feature enabled just automatically hides the tool palette right away (it flickers and disappears). That’s essentially this bug:

RH-56725 ToolPalettes: Floating Tool palettes Disappear

which @JohnM recently fixed (back to that in a moment).

When I look at the source code, I can glean a little of the intention however. The developer intent is for this feature, when enabled, to hide the tool palettes and then show them again when the command is finished. That source code lines up with my expectation, but not yours, if I’m understanding correctly.

In Rhino 7 for Mac, in the current RhinoWIP, if I completely reset my preferences to factory-defaults, then I launch Rhino for Mac and navigate to Preferences > Tool Palettes and enable Hide tool palettes when starting commands, it performs how I would expect it. The floating tool palette hides when I start the command and reappears when I finish the command. Ok, good…that works for me.

Ok, back to your screen edges issue…

I wonder if you have adapted to, developed habits, and created workarounds for buggy behavior (until John’s recent fix)? Is that possible? If so, that’s doubly unfortunate and we need to figure out what to do.

I’ve never looked at the documentation for this before, but I agree - not helpful.

They do hide here when I start a command:

That fix didn’t change anything regarding the behaviour I’m complaining about.

This is the thing I’m complaining about (showing the toolbars again), because it doesn’t make any sense at all from a Rhino users point of view. If the toolbars reappear automatically after I finish a command I’ll have toolbars getting in the way and obstructing the view, as I said in my previous post.
In that case I could have them open all the time and wouldn’t need the screen edge toggle at all.

As I said earlier: I want the toolbars appear when I touch the screen edge and disappear when I start a command - and stay out of my way until I hit the screen edge again!
I also get this annoying behavior with the middle-mouse-button pop-up toolbar reappearing after I finish a command (and getting in my way).
I can’t imagine any situation where this ‘automatic reappearing’ of side-toolbars or pop-up toolbar would be useful.

No. To me the present behavior is buggy (from a users point of view) and the way V6 and V5 works is the way it should be - even if it might be something else than the developer originally intended (which I don’t understand).
Also: John’s fix didn’t change this reappearing-thing. The toolbars reappeared after finishing a command both before and after John’s fix.


I hear you, we just disagree about this feature. Your video above shows exactly how I believe the Hide tool palettes when starting commands ought to work. I’ve looked at the code for this feature and the intended behavior of the original author - I presume Marlin (as this predates version control, I can’t be certain) - is to show the tool palettes again when the command completes. I’ve also conducted an informal straw poll of people here at McNeel and they all expect the tool palettes to show again when the command finishes. That said, we are not the users of Rhino, just the authors, so your opinion has more sway.

Really? I’m struggling to understand why you would not want them to show again. You have a bunch of floating tool palettes up, some obstructing your work, some not, you start the _Line command, they disappear so you can see your work, then, when you are done with the _Line command, they appear again. Would you really want a user to have to create some other workaround like you have to show them again, or force the user to navigate to Window > Show floating tool palettes? If they don’t show again, then the feature is effectively a one-time thing until you explicitly tell Rhino to show them again. That seems incorrect to me.

I believe we can figure out a way to have both situations work, but I don’t think unfixing a bug is the right way to do it.

I find this very strange. This ‘showing-toolbars-after-a-command-is-finished’ is something new for MacRhino. It doesn’t happen on Windows either.


Ok, let me explain… Modeling/designing is not just about… well, modeling. I can have long pauses between commands, where I take a look at my design from different directions, zooming, panning, and so on… so I need a clean view. I might be sketching something on my iPad or paper to evaluate some ideas or variations to the design - and then continue modeling.

I also - for most of the commands - use aliases instead of ‘popping out’ the toolbars, so I’m not using the screen edge that much. I really just want them to appear when I ‘tell’ them to.
Imagine the frustration when I finish a command and the toolbars appear for no logical reason…

Same goes for the popup toolbar. It also reappears after finishing a command. This is not ok.

WinRhino also doesn’t behave like this. If I want to fly out a toolbar I press and hold a button to fly out the toolbar (or right click, if the button doesn’t have a right click command). I then select my command from the toolbar - and the toolbar closes - and doesn’t reappear.

Same goes for the popup toolbar in WinRhino. Why would MacRhino work differently?

It’s not a workaround to hit the screen edge. It’s just a way to show the toolbars in MacRhino. In WinRhino you have to click something to fly out a toolbar - MacRhino is more convenient in this regard.


Not to me.

As I said… I really can not imagine why anyone would like to keep the current behavior, but ok…

I can’t give you any advice here - I’m only interested in restoring/retaining the former/correct behavior we had in V6 and V5 - and WinRhino. Please!!!
Thank you!


I’m still considering a solution to this. I can think of one solution - which requires adding an extra checkbox to Preferences - but it’s not ideal.

Which setting in Rhino for Windows do you consider equivalent to Rhino for Mac’s Hide tool palettes when starting commands?


Well, as I said, I can’t imagine why anyone would like the current behavior - and I’m surprised that nobody else has commented. I would like to hear one good reason why this feature is a good thing - from a users point of view. I’m sorry, but I still don’t get it… Please explain.

It’s the default behavior - not a setting.


I don’t understand. In Rhino 6 for Windows, if I float a toolbar over a viewport and start a command, the toolbar does not appear or disappear or change in any way. I must be using it wrong.

Hey @Philip I think I’m doing a poor job of communicating in this topic. I’m sorry. I think I need the help of @wim or @pascal. They are often better at reading-between-the-lines than I am.

I believe he’s describing the behavior of flying out a linked toolbar in Windows…

As Dan pointed out above, Windows does not have anything like this where floating toolbars somehow disappear when a command starts. How Dan describes the mac feature is how I understand it should work, - I’m guessing that if the bug had never been there, Philip would not have created the workflow he has… but now that he has, it may well be a legitimate workflow option for others as well, but it seems like a feature request at this point.
(Having toolbars go away during a command, and come back when done, seems reasonable behavior to me…)


Exactly! Thanks for the video Mitch!


No, I think it’s me doing a poor job of communicating if you have to read between the lines… but English isn’t my first language - or even my second, so it’s probably me.

I’ll try again in my reply to Pascal…


I just meant what Mitch showed in his video - not that it would be directly comparable to the Mac version.

Ok, it seems that I definitely haven’t been able to describe this properly then - even after so many posts and videos. I’ll try again.

This makes me sad to hear. Developing a new feature takes time… To me this feels like a regression (but you already now that by now, I guess).
I have had to develop a different approach to modeling in the WIP - which is much slower (and still doesn’t work 100 % - se below).

I’ll try to explain again why I think this is bad behavior - and point out that WinRhino doesn’t work this way. Lets for a moment forget about the side-toolbars and focus on the pop-up toolbar. In windows (and previous versions of MacRhino) you press the middle mouse button and the popup appears (if you have it set up this way) - select a command and the popup disappears - and doesn’t reappear when ending the command. Why should it reappear and block a part of the view in the Mac version?
It’s of course worse when you have some of the side toolbars also open and obstructing the view.
See video below (WIP version):

You can also see the annoying “viewport-size” bug in the beginning, but that’s not the point here, of course.


Here’s a side effect of this “reappearing-toolbars-feature.” Just drawing some curves here in this video (you can also see this annoying to-strong-center osnap getting in the way), rebuilding one curve - and then start undoing… The toolbars flicker for every undo. Same flickering happens if you undo view change (with the icon or by pressing ‘home’).