ToggleActiveToolpalettes in Rhino 7 compared to Rhino 6 & 5

The ToggleActiveToolpalettes in Rhino7 has become completely useless. Have read other topics on this and I have to agree that in Rhino Version 5 and 6 this command worked perfectly together with the ScreenEdges setting for your mouse pointer. In this way you could re-show an “active” tool palette on your screen by just moving your mouse pointer to the edge of the screen.( specific mouse setting option in rhino preferences)
There are many professional users who use this type of setting. It is also promoted that way on the MCNeel Rhino site. So the software engineer who thought that this behaviour was a bug and had to repair this as it is in version R7 did not so good job.

To be clear: the function does not work (anymore)!!!
It doesn’t TOGGLE, which is easy to test.
Activate a Toolpalette and type the command “toggleactivetoolpalettes” the tool palette should go away. When typing some time later again the command should recall that toolpallete on the screen. This is how it works in R5 and R6.
If you use Toggleactivetoolpalettes in R7 it doesn’t toggle, it just flickers on your screen but it stays visible, it never toggles to hidden.

can you please review and correct this “toggleactivetoolpalette” command in R7 because it seams that in the programming there is something wrong because it looks that it repeats itself; E.G. like an extra enter after a command to repeat.

1 Like

I agree!

That’s right - it doesn’t!

It also affects how the popup toolbar (dis)functions - and strangely it seems like nobody cares… There have been a number of threads on this topic during the last 18 months. Why can’t we have this fixed ones and for all. It’s a lost feature, a regression, that occurs many times during every modelling session! How can it not be important to fix this (as nothing has happened for over a year) - it ought to be top priority! It’s really frustrating about how this has been handled…

@dan @BrianJ


indeed, therefore I am stil working in R6 because this mis-function in R7 slows down tremendously and is frustrating .
I had the feeling reading through your topic list (@Philip) that the people at mcneel who commented had no clue about this rhino feature and how it (should) work, and definitely had not the intension to agree that the way it is now is completely useless (even the software engineer should after reviewing finally agree that it became a useless command).

1 Like

From your perspective, is this the basically the same issue reported here?

I’m going to need some help reproducing this here. Here is Rhino 7.7 on my computer…

I’m pressing space to toggle them on and off (rerunning the command). I tried with screen edges as well and I get the same behavior.

I simply cannot reproduce the issue you are seeing.

My presumption - based on the other topic above - is that what I’m seeing is the buggy behavior and something else is desired entirely (and I’m just failing to understand what that is.)

I’d appreciate some help here getting me deconfused.

Here is what I see with Screen Edges…

Does this above video show the desired/expected behavior? (I would consider this the expected behavior).

PS: I see exactly the same behavior in Rhino 6.34.

Yes, that’s one of the threads… There’s another one also (with a link to a bug report on youtrack filed by @BrianJ).


By the way… Your videos don’t show the behaviour that’s different from V6: the reappearing of tool palettes and popup toolbar after finishing a command. The reappearing is the undesired behaviour! Please take a look at the original thread again.


Hi Dan, I try to explain better. What Philip and I are referring to is the behaviour of a combination of solitair commands. E.G. a certain order that you select the commands in or in combination with specific preference settings.

  • You are looking into the behaviour of solitaire commands only.
    E.G.: the behaviour that you show here in the video with the screen-edges is correct, it toggles ON and OFF when hitting the screen edges. (this is the solitair behaviour)
    But if you then would select a function from this shown tool palette (“combination of different commands”) then the tool palette stays visible and is “blocking” the screen. You can only remove the “blocking” tool palette by hitting the screen edge again or by using its closing button.
    If you want to hide it by the screen edge you have to do so directly after selecting the command that you want to use from the tool palette, but it re-appears immediately after the selected command is finished.
    If I just hide the tool palette by hitting the screen edge without selecting a command from it and use a randomly command from whatever other menu then after that specific command is finished the hidden tool palette from before re-appears again although there is no relation with the former activated command.
    If you close the shown tool palette by the “closing” button you can not recall the toolbar by hitting the screen edges.
  • Next stage of the problem:
    Rhino has a Tool Palette Preference setting: “Hiding tool palettes when starting commands” that you could activate
    Screenshot 2021-07-28 at 11.47.03
    (note: this was switched off in your screen edge demo)
    If you activate this setting in the preferences then the ToggleActiveToolpalettes doesn’t work anymore. (commands in combination with specific preference settings.)
    The active tool palette keeps appearing on the screen, it does HIDE when starting a command but it reappear immediately after finishing, “blocking” the screen. Hitting the “screen edge” function with your mouse pointer to toggle the tool palette ON & OFF only blinks the screen and the tool palette stays! You can not hide but only close the tool palette by the closing button
    So the behaviour of the Toggle function is influenced by the “hide tool palette” setting.

And both Philip and I (and probably many more) are using these described functions in combination, as was promoted by McNeel in R5 and R6 and were explained in typical videos on the internet.

You could maybe explain to the software development department that there is absolutely no use-case were a designer wants to have constantly floating tool palettes visible on the screen blocking the workspace. If I need constant visible commands then I would use a stationary location at one of the screenedge menu’s.
I would need the (personalised) floating tool palette(s) to appear and hide on my request, I want to have full visibility on my model so I can decide / position quickly for the next command and only then I want to have the choice for the floating tool palettes to appear or select an other command input.

This is how it worked in R5 & R6 and really made the difference in design/modeling speed.
So please test and compare in R6 & R7 these settings, commands, combinations and behaviour.
And although the intend of the software designer was probably to improve on functionality in this case it failed and it would be highly appreciated if it would be corrected.

1 Like



Please have patience with me. Let me try asking this again…

With regard to ToggleActiveToolPalettes, does this video :point_down: show the expected/desired behavior?

Logged RH-65131 Preferences > Tool Palettes > Hide tool palettes when starting commands: should exclude some commands.

Hi Dan, this video is almost complete the only thing that you need to do now is this:
Hit the screen edge (ToggleActiveToolPalettes) so that your “circle” tool palette reappears on the screen as in your above video.
Then select a command from the from the “circle” tool palette on your screen.
The desired behaviour should be that the “circle” tool palette hides and you can continue with / finish the selected command.
When the “circle” command is finished the “circle” tool palette should stay hidden.
You should then be able to select different commands e.g. the “line” command from the left menu bar (static) and draw some lines etc. or any other command input action.
If I now again hit the screen edge (ToggleActiveToolPalettes) then the hidden “circle” (or whatever active) tool palette should reappear. and a sequence as described above could be repeated.

This is what we are looking for in behaviour

1 Like



…and same thing for the popup toolbar: no reappearing after finishing a command!


Thank you. I think we have finally gotten to the crux of this issue. I’ve made a comment here in RH-57945, as I understand it.

Hi @Philip and @Eckhardt

Can you please do a little testing for us?

Try this

  1. Download this Rhino “build-of-the-day”.
  2. After opening the dmg, when you see the screen with the Rhino and the Applications icon, drag it to your Desktop instead. (Since this is not an official release of Rhino, I’d discourage you from installing and using this as your “stable” version of Rhino).
  3. Launch Rhino 7.10.21217.05002 on your Desktop.
  4. Navigate to Preferences > Tool Palette and verify that Hide tool palettes when starting commands is enabled (checked).
  5. Navigate to Preferences > Mouse > Screen Edges and set the left and/or right edges to ToggleActiveToolPalettes.
  6. Navigate to Preferences > Advanced and make sure that Rhino.Options.Advanced.LeaveFloatingPanelsHiddenOnMac is set to true (enabled/checked).
  7. Start a new modeling window.
  8. Navigate to Window > Active Tool Palettes and show any you desire (I tested with Circle and Popup here).
  9. Start and finish a command.

Does Rhino 7.10.21217.05002 behave as expected?

  1. (optional, but recommended) Quit Rhino and drag the Rhino from your Desktop to the Trash.

Hi Dan,
Wow !! great work and this is almost what we had.
The main ( sequence ) behaviour as we described before is exactly what you build in this trial version, with one exception were the active tool palette still pops-up unwanted.
I try to describe below how to recall this unwanted behaviour.

  1. Activate a floating tool palette e.g. circle
  2. Start and finish a command from the tool palette.
  3. Navigate to the screen side and activate ToggleActiveToolPalettes and show any active tool palette (I tested with Circle here).
  4. Start and finish a command from the tool palette.
  5. Now select an other command e.g Line from main menu
  6. Start and finish the command.
  7. Hit the “space-bar” on your keyboard to repeat the Line command
  8. Finish the command

Now the hidden “Active tool palette” (in this case Circle) appears suddenly.
This reappearing of the (hidden) active tool palettes happens after any other command that you repeat by the space-bar.
The active tool palettes should however always stay hidden until requested to reappear by the ToggleActiveToolPalette command.

If you can implement this also then I think we have covered the issue.

Do you see any other issues in the behaviour that I might have missed.

Best regards,

1 Like

I haven’t had time to test yet - will try it today or tomorrow. However… I don’t see any mention of the popup command’s ‘misbehaviour’ (which was mentioned in those other threads). That’s the one that causes the most grief for me personally.


Ok, sorry @dan - you did mention the popup toolbar. However… I tested Rhino.Options.Advanced.LeaveFloatingPanelsHiddenOnMac (set to true) with a number of toolbars (also popup) - and the result isn’t yet quite what we would expect as @Eckhardt already mentioned above. These problems have been discussed a long time ago in this old thread (as I already mentioned). The new option Rhino.Options.Advanced.LeaveFloatingPanelsHiddenOnMac is working much better than the previous version mention in that thread, but it’s not perfect yet (doesn’t work like in V6 and WinRhino). Please take a look at the whole thread once more. Every problem related to floating panels is described there.

This is the problem with this new version. Also… If you follow the steps described by @Eckhardt above, but invoking the line command (in 5.) with an alias (I have: l = ! _Line) I get the reappearing of the circle tool palette already after 6.

As mentioned: The active tool palettes should always stay hidden until requested to reappear by the ToggleActiveToolPalette command.