Popuptoolbar command bug in Rhino8

Hi McNeel team,
There is a bug in the PopupToolbar command in Rhino8. The PopupToolbar command stops functioning after a few different commands have been run. After it breaks the only way to restore the functionality is to restart Rhino.

Here are the few ways I have found that cause PopupToolbar to stop working.

  • Trim command with any cutting objects preselected (Note: you don’t have to complete the trim, just starting the trim command with something preselected disables PopupToolbar)
  • _Section command - after first input selection
  • _Project command - after 2nd input selection of surfaces to project curve onto

I have also had problems with PopupToolbar in Rhino7, but it seems to be far less frequent, but more dangerous. In Rhino7, when PopupToolbar stops working it will prevent even the SaveAs dialog box from popping up (so I just hit Ctrl+s to save and then restart Rhino). If I continue working while PopupToolbar is malfunctioning it will eventually make Rhino crash. I have not found ways in Rhino7 to intentionally make PopupToolbar malfunction, but what I have noticed is that it seems if the PopupToolbar command is invoked during an Autosave that is when it seems to become unstable. But I have not spent anytime trying to confirm that is what happened.

I hope this will be fixed soon, because I use PopupToolbar very frequently. I have the majority of the tools I use linked to 2 custom toolbars that are assigned to F4 & F5 keyboard, which I have assigned to my gaming mouse buttons.

One other thing that I have noticed is that the middle mouse button popupmenu is unaffected and seems to work without any problems.

I am using Rhino Version 8 SR1 (8.1.23304.10001, 2023-10-31) - full system info attached.
Rhino System Info.txt (2.6 KB)


1 Like

what happen if you create a container that hosts the popup toolbar and assign it to the popup settings? will the issue persists?

Hi John - so just to be sure, the issue you are seeing is with tyhe PopUpToolbar command only, correct? And if I set up a PopUpToolbar “Curve Tools” fpor example, if I follow your trim scenario above, this should stop working at some point - do I have that right?


Yes, that’s correct

putting in a container makes no difference. unless there is a separate command - PopupContainer?

sorry I misunderstood you issue, I thought you are talking about the popuptoolbar in the mouse middle click action.

Hi @pascal,
Does the popuptoolbar command malfunction as I describe on your end?

Anybody else having the same issue?


Hi John - so far it is ok, here - can you tell me exactly how you are invoking PopUpToolbar? If it is an alias, please give me the exact macro you are using and the alias.
(my guess of the moment it that there is some confict between an alias and a command line option)

Hi @pascal,
Thanks for checking into this.
I have tried everyway I can think of to invoke Popuptoolbar, always with the same result. The primary way I use it is by assigning popuptoolbar with toolbar name to the F4 key and then mapping the F4 button to an extra button on my mouse.

That said I think I found the conflict - I had my command prompt undocked. With the command prompt undocked there are numerous commands that make PopupToolbar stop functioning. The only way that I have found to recover the functionality is to dock the Command Prompt and restart Rhino. With the command prompt docked PopupToolbar functions as expected.

So I guess I won’t undock my command prompt :slight_smile:
Are you able to recreate the same issue with the command prompt undocked?

Having the command prompt undocked in V7 does not cause this issue for me.

Thanks for the awesome support! and congratulations to the McNeel team for another successful release.
Can’t wait to start playing with the Rhino 9 WIP.

Hi John - thanks, I’ll try un-docking.
@john.ohran - I see this - the popup flashes for a moment but disappears immediately, is that what you see?


@pascal - yes.

Also, it has since happened again with the command prompt docked. I haven’t been able to figure out yet what triggered it.

1 Like

Hi John - thanks, here, once it happened with the undocked command prompt, it persisted even if I docked the thing. Anyway, a bug, I’ll get it on the list, thanks.
RH-78224 PopUpToolbar: erratic behavior


thanks @pascal

Popuptoolbar also occasionally malfunctions in Rhino7 (I haven’t be able to figure out what triggers it in v7), but it would usually cause Rhino to crash after a few minutes if I kept working.
One of the times that it crashed within the last couple months, I got the crash report that sometimes pops up when Rhino crashes unexpectedly and I sent it in. Not sure if you can look that up, but that might contain some clues.

So far in Rhino8 I have not had it crash if I keep working after popuptoolbar malfunctions.

Hi @pascal -

I found a way to lock up Rhino completely with the PopupToolbar command. The end result is that Rhino behaves like there is a dialog box open that is hidden, so you can’t dismiss it and return to main Rhino program window.

Here are the steps to reproduce the error:
-create a new container
-place the Layers panel in the new container
-close the container window
-run popuptoolbar container
-click on the layer color swatch to open the ‘Select Color’ dialogue box
-color selection dialog box does not appear and Rhino is pushed to the background of Windows

From this point on any clicks made in the Rhino window will be met with the annoying windows chime sound that indicates there is an active dialogue box open that needs to be closed before you can go back to the main program window. I have not found any way to get out of this situation. There is no dialogue box visible.

At this point the only path forward I know of is to use Windows Taskbar to EndTask, killing Rhino and any unsaved work.


Hi John - got that, thanks.
RH-78366 PopupToolbar glitch with Layers


Hi @john.ohran,

I can repeat the bug.

Just curious, any reason you don’t just click on the status bar layer pane?

– Dale

Hi @dale,
I guess maybe I’m lazy? or maybe I’m just really efficient?

I like to have my tools popup under my mouse and then disappear after I’ve selected one.
In V7 I would just toggle on and off the Layers dialog box in the sidebar. But now with the new Containers in v8 it is possible for Layers to popup at my mouse location via the PopupToolbar command.

I have my user interface setup so that all of my tools that I use most frequently are on a couple of custom toolbars that I access with the PopupToolbar command assigned to my extra buttons on my mouse. So I try to keep my screen clear of all toolbars and windows, except the command line.



Hi @pascal, @dale,
Not trying to beat a dead horse, but I found another glitch with popuptoolbar. I’m guessing these are all interrelated. Hopefully knowing the triggers will help you find the solution.

The glitch happens after PopupToolbar has opened a toolbar and then Rhino is unexpectedly pushed to the background of Windows and the last previously active Windows application is activated and brought to the foreground.

To repeat the behavior:

  • Open a web browser or other application, leave it up on the screen or maximize
  • Open Rhino and maximize application window
  • Run _Popuptoolbar main
  • hold shift and right-click on any button to open the Button Editor dialog box
  • Close the Button Editor dialog box
  • Rhino is pushed to the back and the web browser is brought to the front

This also happens (on a “popped up” toolbar) if you:

  • click on any cascade menu triangle in the bottom right corner of a button
  • click on the same or any other cascade menu triangle


Hi John - thanks, I’ll check.
I see this, thanks.
RH-78425 Edit popped up toolbar button glitch


RH-78366 is fixed in Rhino 8 Service Release 2 Release Candidate