Middle mouse button custom toolbar not working after upgrading to Rhino 7

I just upgraded from Rhino 6 to 7 on Mac. I have it setup where I click my middle mouse button and a custom toolbar palette appears with all of the commands I use the most. Here’s the macro that I found ages ago on another post and has worked well up until now.

_ShowToolPalette _ToolPalette=Popup _UnderCursor=YES _Enter

Back on Rhino 6, after I clicked a command, the toolbar palette would disappear but that’s no longer the case when using Rhino 7. In 7, the toolbar will appear but after clicking a command it just stays there until I click the middle mouse button again or close the toolbar palette.

I like having all of my most used commands easily accessible, is there a way to fix this or is there another work around that people are using to help speed up their workflow? Thanks!

In Preferences > Mouse > Middle mouse button, can you try setting it to Popup this toolbar > Popup. Any luck? This should be the default setting too.

That works but I have way too many commands in the toolbar so it ends up being a ridiculously long list. I like that the toolbar shows everything in a grid of icons.

This has been discussed before. I don’t get the impression it’s high on the fix list.

1 Like

It appears “Hide tool palettes when starting commands” was unchecked. Checking this box appears to have fixed the issue.

That’s ALMOST fixed it. Once you complete the command, the Popup returns. At least that’s my experience when testing for, say, ten seconds.

1 Like

Take a look at the thread Mark was referring to. It sure looks like this V7 problem is being ignored. We are now forced to use the unergonomic, unreadable pop-up list instead of the pop-up toolbar with icons. Everything was fine in V6, but having this problem in V7 is so frustrating as the pop-up is being used so often in every modelling session. This is to me easily the most annoying regression I’ve seen in Rhino - well, ever…

Could we at least have some comments from the developers about when we will have a fix for this behaviour. Please give us an ETA.
@dan, @pascal, @BrianJ

Philip

Ah you’re right. The popup returns again after completing the command. Why on earth would someone make it work this way?

1 Like

Hi all,

Sorry this has been a pain, I just experimented a bit with the macro option for the MMB in Rhino 7 for Mac’s Mouse preferences and find
“!_ShowToolPalette T Popup Enter V Toggle”
works to get an Icon only Popup tool palette. MMB again to hide it after using a command. Maybe that will help.

Well, thanks for trying, but nope, sorry - that’s an unnecessary extra step. The pop-up needs to go away (and not reappear) after finishing a command. It needs to work like in MacRhino V6 - and WinRhino. Nothing else is good enough in my opinion (as it is a regression compared to V6). It has to be fixed in a V7 service release.

Philip

Good question…

Philip

Hi Philip,

I filed https://mcneel.myjetbrains.com/youtrack/issue/RH-63774 to see if we can make the macro work as it did in v6 or add an advanced option to control tooltip text display in the default popup toolbar.

Thank you! However, I think you misunderstood the problem.

You wrote in your bug report: “In Rhino 7 for Mac, this same macro brings up the popup toolbar as expected but it does not auto hide after clicking an icon as it did in Rhino 6 for Mac. This is what appears to be a regression.”
That’s not the problem. The pop-up toolbar does auto hide - like in V6 - you only have to have “Hide tool palettes when starting commands” checked.

The problem we are talking about is that the pop-up toolbar reappears after finishing a command. This is different compared to V6 and WinRhino, where the pop-up doesn’t automatically reappear (and that’s the correct behaviour).

Regarding the second suggestion for an advanced option… “If we could add an advanced option to not show the tooltip text in the popup toolbar this would also serve to alleviate the pain here. Then the default Popup toolbar option for the MMB would I think work for the users of this macro.”
Perhaps I misunderstood you, but if this would mean just getting rid of the the text and leave only the icons as a (long) vertical ‘list’ then I don’t think this would solve anything - it would make it even worse. The pop-up toolbar should be configurable like the pop-up in V6 and WinRhino, to be able to have something like this, for instance…

By the way… Dan already made a different advanced option almost a year ago: LeaveFloatingPanelsHidden
This is discussed in the original thread. Unfortunately it didn’t seem to have any effect for the pop-up (doesn’t matter if it’s set to true or false - the pop-up reappears).

Philip

I’m with Philip. Please get this tuned up.

1 Like

Thanks for explaining more. I did not have that custom setting to hide tool palettes when running commands checked so I didn’t see the hiding of the popup toolbar and therefore couldn’t judge that it reappeared. I see what you mean now and I edited the bug report to reflect this.

I was thinking a grid of icons would result just minus the text tooltips. I also added that expectation more explicitly to the bug report.

Thanks, Brian. Just to be 100% clear, this is what the default Popup toolbar looks like, invoked with the middle mouse button:


Via this setting here:

This is what Philip and I want:
Screen Shot 2021-04-12 at 1.53.47 PM
That is, no text, just buttons, and disappears (and does not re-appear) after a button is clicked.

1 Like

I understand, I think I’ve got this documented correctly now on the bug report. Now the developers will need to take a look.

1 Like

Hi!
I shared the exact same issue with the Mcneel team when I upgraded back in March, no answer on that specific problem, it’s pretty frustrating to have the popup re-appearing exactly where you need to see things. I’ve been using Rhino for the last 15 years and this is really one of the most annoying regression (this and having to right click twice for some commands going from PC to mac).

1 Like

Exactly!!!

It sure is! I hope they really fix it ASAP.

Philip

I agree with everyone else’s comments in this thread. I’m sticking with Rhino 6 until this bug and the extremely slow undo command is fixed. This makes Rhino 7 more or less unusable at the moment.

2 Likes