Tool palettes bug

Since you bring this up here (should be a different topic though…) - I can’t see what you are snapping to. It looks like your Near snap is off.

Well, to be honest, in Windows Rhino, if you have floating toolbars like you show in the video, they don’t even disappear when you start a command. So if you’re drawing a curve in a window, you need to draw around the toolbars. Makes your curves pretty funny… :stuck_out_tongue_winking_eye:

I have posted it in different topics as well - in fact many times (just couldn’t keep quiet here either).
I was using the line command and picking the tangent option in the sidebar. I always have near off.


I know - but only if you ‘tear them off.’ If you’re just opening a toolbar it will close nicely when starting a command (like in your video).

Yep :upside_down_face:


…and in Windows you don’t get this nice flickering :sunglasses:


Yep - but only one toolbar can be flown out at a time… Mac the same, no?

ISTR that there is a setting in preferences to have the toolbars on Mac fly out as icon pallets and not the default menu style - which I hate and used to annoy me greatly before I saw this option.

No, not quite. You can have all toolbars fly out at the same time, if you like, but that would be a bit too much :grinning: I have it set up to fly out those shown in the video - when I touch the left screen edge. It might seem odd, but it’s really easy to find the button you need based on where they “geographically” are. For all my normal commands I have aliases, so I don’t use the buttons all the time.

It’s just frustrating as it is now when the toolbars reappear after finishing a command - doesn’t matter if it’s started from buttons or aliases…

Yes, that’s what I use (icon pallets). Now I have to use the menu style, which I also hate and makes working a PITA.


Sorry @Philip it took me awhile, but I added:

RH-57945 Tool palettes: Add advanced setting to suppress tool palettes reappearing after command completes

to allow you - and probably just you :wink: - to override our bug fix. Once we get it in a build, we’ll let you know how to test it.

1 Like

Thanks! I don’t understand why I’m alone on this… It seems like nobody else is using the popup toolbar on MacRhino (I can understand that not that many use those ‘side toolbars’ like I am)…

I’m quite sure, however, that you would get people protesting a lot if you would implement the same ‘feature’ on WinRhino (the popup reappearing after the command).

Perhaps you should try that if you think it’s a good idea :wink:


Well, we do get a lot of complaints about the Hide tool palettes when starting commands preference NOT working as expected in Rhino 5 and Rhino 6, so I’m glad we fixed the bug in 7. In fact, we just got another one today, which is what reminded me to come back and revisit this topic.

I don’t quite understand this… So you mean that Mac users are complaining about a (popup)toolbar not reappearing? I wonder why Windows users aren’t complaining about the same thing. I must be missing something.

Anyway… no point in discussing this any further. I’ve tried to explain why I think the reappearing of toolbars is a bad idea, but I seem to be alone on this one, so I’m grateful if you are making this addition to advanced settings - even if it’s probably just for me :wink: Any estimates on when “the bug fix override” will be ready (so I can start testing V7)?


I think it’s probably just for you :wink: and I can understand from your descriptions above why you want to have this “feature” back. I struggled to come up with a workaround that would provide you with the workflow you had built around the old behavior and, frankly, I want you to continue to use Rhino.

Sorry, I don’t have a good estimate for when this will be done.

1 Like

This will be in next week’s RhinoWIP.

@Philip but why wait until the next RhinoWIP when you can test this now? Here is a link to a “dujour” build of the RhinoWIP. Install it, then navigate to Preferences > Advanced and then filter on LeaveFloatingPanelsHiddenOnMac. It will default to false (the normal, fixed, behavior). Set it to true and you have your old behavior back.

Thank you! Great!


Ok, I’ve been very busy lately and have not had the time to test the new advanced feature “LeaveFloatingPanelsHidden” until now - and I’m sorry to say that it’s not working the way we have discussed here. I assumed that setting this to “true” would bring back the behavior we have in V6 (active tool palettes would not reappear).

As you probably remember I have set the left screen edge to run the macro “_ToggleActiveToolPalettes” (Rhino preferences -> mouse -> screen edges) having a collection of tool palettes appear when touching the screen edge. That works. So far so good. After selecting a command and finishing it the tool palettes don’t reappear. So far so good. However, touching the screen edge again doesn’t do anything anymore. No palettes appear (as in V6). The screen edge macro seems to have been deactivated altogether.

An even bigger concern is the popup toolbar which reappears exactly as before after finishing a command. No change here at all. My popup macro (Rhino preferences -> mouse -> mouse): “_ShowToolPalette _ToolPalette=Popup _UnderCursor=YES _Enter”
I would at least like to have the popup working the same way it does in WinRhino (not reappearing).


Did you see this @dan?


Sorry, I’ve not yet had time to look at this, but it’s not off my radar.

Ok, thanks!


Could you at least fix this… There’s absolutely no reason why the pop-up should behave differently on MacOS (compared to windows). Please fix the reappearing.


I’m really disappointed that I haven’t got even a comment about at least the popup problem for a long time. As Jarek just said in a different thread: do we have to be rude (insert name here) - or rude and funny (insert name), to get some attention? I can understand that you are busy, but please at least give some answer to a user that have been with Rhino since 1997!

The popup on MacOS doesn’t work like a proper popup toolbar as it reappears in the focus of your work and gets in the way! To be able to work efficiently I could as well make it a normal floating toolbar… but then it, of course, doesn’t appear conveniently under your mouse. In other words: the popup on MacOS is useless! Once again: why does it have to behave differently than on Windows?

About he side-toolbars: just forget it, as it seems to be conflicting with other users comments on this matter, if I understood you correctly. I have learned to manage without them by now. It’s not as convenient as before, but whatever…

To not get an answer doesn’t exactly encourage me to try to discuss problems here at all.
I’m sorry about the tone in this message and shouldn’t have written this being so frustrated, but well, I did…