Shaking lines after scaling

Hi guys,

I have such a big issue. After two weeks of working on my model, I realized that my model unit was in meter and that I was drawing as in milimeter.
So I tried to fix it by first changing the model unit and then scale my model. But at the end all my polysurface are shakings and not straight anymore. The problem is that I saved it as it’s (shaking) and can’t undo anymore.

If someone knows a trick to fix it.

Hello - the model is almost certainly very far from the origin - try selecting everything and moving to the world origin and see if that cleans things up.

-Pascal

This should be fixed in SR12

It don’t change anything, the model is pretty big like 300m*300m but i didn’t had the issue before

I’m using rhino 6 do I have to update ?
How I can know on which SR am i ?

I think you can work around this issue for now by saving the “shaky” model to a NEW file name; shutting down Rhino and the restarting/loading the new file.


You are probably not using SR12 since we just released our first release candidate for it this week. I just checked and the fix that I made won’t be available until next Tuesday, sorry.

You can check to see what version you are using by looking at the help->about screen or by running the SystemInfo command.

Here is information on getting the SR12 release candidate. Again, this specific fix will probably not show up until next week.

the resaving/restarting trick didn’t worked but it’s not just de display problem because on all the other views it’s also shaking.

Can you send me your model so I can try and repeat this?

Uploading: Building 1_program.3dm…

Can you download it ?

It doesn’t look like the 3dm ever completed uploading to discourse. You can directly email me the file too (steve@mcneel.com)

Ok I’ll, thanks a lot

Did you receive my email ?
Otherwise, here is a link to the file : https://drive.google.com/file/d/1gw39DcYWssBlIaf01-czjQbhbHK7OUtf/view?usp=drivesdk

Let me know if you can’t download the file

Yes, I received your email. Thanks

Did you manage to fix it ?

I got the model, but am still seeing some display issues. I’m still investigating

Edit: the bounding boxes for individual surfaces in the model are massive. Was this model created in Rhino?

Yes it was created on rhino but it was like a site model really big and then I scoped it on the area of my project.

I think this issue will be fixed if you take the following actions:

  • Install the SR12 release candidate (Rhino 6 SR12 Release Candidate Available)
  • Load your 3dm file and run SaveSmall to save the model without render meshes. The meshes render meshes somehow were the massive meshes that must have been in place before you scaled the model.
  • Restart Rhino and load the model.

ClearAllMeshes might do it as well.

-Pascal

Just that alone will probably not remedy the issue. The model needs to be reloaded.