Shading visualization issue

Hi everyone,

I’ve been having some problems with the way all shaded views act in perspective mode. It happens from time to time when my model gets too heavy, that the edges and surfaces of my geometry start to jitter whenever I orbit/pan. I attached a GIF showing the problem.

However, when I change to parallel view the jittering disappears. Does anyone have experienced the same issue? I’m not sure if it has something to do with my graphics card (Quadro K4000), or if the files gets corrupted.

I tried already playing with the mesh settings, refreshing the shades, testzbiasfactor and a few more things related to the graphics, but nothings seems to work. In previous models I was able to fix it just by copying everything into a new file, but this time it’s not working.

Any suggestions?

rhino vis issue

Edit: I just discovered that the problem disappears whenever I open any script in Grasshopper with preview geometry drawn… which is confusing me even more.

Hi, this happens to me when two or more surfaces have identical areas (two-dimensional intersections). These areas jitter.

This often happens when geometry is far from origin.

Edit: can you please send the geometry, i have here M4000 and some other nVidia cards and could check this.

Hi!

Thanks for your help.

Yes, I’m aware this may happen because of the origin which is far away but not extremely far, but what seems odd to me is that I’ve been working on this file for over a year and it just happened today.

The full model is quite big, but I extracted this part and tested it if the same issue occurs, and it does.
So if it happens to you, might be the file that is corrupted?

Hi, yes i think that is normal when two single surfaces intersect on the same plane, but in this case these are solid polysurfaces, and also the edges jitter.

Thank you - opened the model in Rhino 7 SR10 (2021-09-13) and then focusing on similar part as your screenshot.
On first computer with GTX1080 and 4K monitor all is fine, no artefacts (driver is 471.68 from Aug 2021). On second computer with Quadro M4000 and FullHD monitor there is similar jittering like you have (driver is 471.41 from Jul 2021). Analysis show no bad objects and the origin is indeed not far away. Remeshing didnt help so i will look for possible solution.

Thanks for your help. I still don’t know why happens, and why whenever I open any script in grasshopper the problem seems to dissapear. But as you tried it in a Quadro, might be the problem.