RHINO6- Unit change/surface crack

rhino6
unhandled

(Chris Chen) #1

Hi, I have an issue when I tried to merge two models into one. So the first model is made in meters while the second one is millimeter. And the meter one became a bad object after merged. Is there any solutions to solve that? And it seems like rhino5 doesn’t have the same problem.


(Pascal Golay) #2

Hello - can you please upload both files, either here (public) or to www.rhino3d.com/upload (confidential) and I’ll take a look.

-Pascal


(Willem Derks) #3

Hi,

Could it be your geometry is far from the world origin?
If you move it closer to the world 0,0,0 point does it render better?

-Willem


(Chris Chen) #4

Hi thanks for the reply. I am aware of this issue and I already moved it to the 0,0,0. But it’s still the same.


(Chris Chen) #5

Hi! sorry the model is confidential so I cannot upload it. But it happened several times in rhino6 before. All complicated model got pixelated after changing the unit.


(Wim Dekeyser) #6

Hi - I have tried to reproduce this but am not seeing the issue here.
If you were able to reproduce this with just one or a few of the surfaces from each file, please upload those with a detailed description of your workflow. Also note that models that are uploaded to the link that Pascal posted will not be visible to the public in any way.


(Steve Baer) #7

Please make sure to try the latest SR12 release candidate. There have been a few recent fixes made that could have an effect on this. You may also need to clear your render meshes and let Rhino recreate them.


(Chris Chen) #8

Great! I’ll definitely try that. Does purge help to clear the render meshes?


(Chris Chen) #9

Got it. Will upload it soon. Thanks a ton!


(Chris Chen) #10

I just checked and it seems like the latest release is SR11?


(Wim Dekeyser) #11

That’s correct but you can subscribe to Release Candidates for Service Releases. If you do that, you will be able to install the latest RC for SR12. In Rhino, go to Rhino Options > Updates and Statistics > Update fequency and change that setting to Service Release Candidate.


(Chris Chen) #12

Hi, so I just uploaded the two models to the link you sent. Thank you so much for your help.


(Chris Chen) #13

test model.zip (11.1 MB)

well it seems like the link doesn’t work…please find the attachment here.


(Pascal Golay) #14

Hi Chris - thanks, I’ll see what I can figure out.
@schen.risd - for now, you can Explode and then RebuildEdges on the result to restore the display.

-Pascal