Rhino WIP 8-Nov-2016 Display

Hello to everyone,

I was wondering if anyone out there is experiencing the same problems I am having with Rhino 6 WIP for Windows.

The graphic response from my system, a Macbook Pro 17" with Windows 7 Pro 64bit, i7-2720QM quadcore CPU, 12GB Ram, AMD Radeon HD 6750M 1GB Ram Graphic Card, is very slow and unpredictable.

I experienced two times big crashes when running it along with Rhino 5. The system literally freezed and blocked itself and I had to reboot it.

Rhino 5 has worked beautifully for years and the graphic performance is still fast and responsive. The current graphic performance of Rhino 6 instead is literally keeping me away from it for the moment. With all my best will, if I run it along with Rhino 5 and I see that my system crashes, I don’t know what I should be doing. I am not thinking about replacing my system, which, despite being relatively out of date, is not a dinosaur yet. What should I do then?

Thanks for your help
Regards,

Luca

Help us figure out where the bugs exist in Rhino on your computer; that is one of the reasons we have a WIP process :slight_smile: Are you still experiencing crashes with the latest WIP? If so, are you getting a McNeel crash reporting dialog?

Hi Steve
Is there any movement on this…?
In the fullness of time I will just “solve” this by buying a newer computer, but I’m reluctant to do so at present when it still works very well for everything else - photoshop, sketchup, V5…just not v6.

Cheers
rabbit

Not in the last couple weeks, but that should change soon. I’ve been spending my time getting a bunch of older V5 annotation SDK “stuff” replaced with the new V6 annotation SDK “stuff” (that’s my technical term). The big chunk of my personal work on that project was just finished today.

I wouldn’t go running off and buying a new computer for this unless you feel the urgency to get a new computer. We aren’t going to ship a V6 where a significant % of the users will experience a completely unusable interface because the screen is just black. Obviously there is a bug in the system and we are still trying to flush it out. We’ve been working around different GPU driver issues for years and are just up against another one now that we will find and fix.

I just chatted with a recycled computer/laptop store down the street from our office last week and am hoping to start a program this week where we borrow computers from them for a short time to see if we can reproduce any of these display bugs that people are seeing. If we can reproduce it, then it is usually fixable. We’ve also been figuring out how to remote debug onto users computers for cases where we just can’t reproduce the bug no matter how hard we try. In that case it is a bit more painful for both us and the end user, but at least we can get a chance to dig in and see exactly what is happening.

Thanks Steve

Obviously you cant support a whole bunch of older hardware past a certain cut off point - I’m just hoping I can squeeze in under the roller door as it comes down…!
By all means contact me if you want to have a crack at this computer by remote…

cheers
rabbit

I actually think we can support older hardware as long as it can run Windows 7 or greater. We have code in place that will let us degrade to older functionality when the hardware doesn’t support newer versions of OpenGL so you should be able to at least work in wireframe / shaded types modes.

Thanks, we very well may take you up on that offer.

Hi Tony,
Could you try the latest WIP and let us know if anything has changed? It would also help to test by setting AA to None and restarting Rhino.
Thanks

Hello Steve

Whats changed is that i get a dialog saying i need a license; i log on as it tells me to, and get a message saying all my licenses are in use on other devices, and rhino will now close…

There are no other devices…

what now?

cheers
tony

1 Like

@brian, can you help?

Just to update here…

No-one replied re the above; just now, thinking there might have been some developments, I tried starting the V6 i last downloaded ages ago, thinking it would initiate the update process.

1: immediately says rhino needs a license.
2: tries to do something with the cloud zoo,(whatever that is…) reports server error, says I don’t have any licenses in the cloud to run the product…returns to the screen in 1 above on ok
3: try “use the zoo” option, since i don’t obviously have a license to enter. Reports it cant detect the Zoo server automatically. I have no idea re the other option about entering a hostname or IP address so that me done!

Why don’t you guys just be honest about it and come right out and just say you don’t want me to use rhino anymore, rather than this litany of evasions and poor excuses?
Its ok, I can take it…

cheers
rabbit

@rabbit Did you click on “Login” or similar after downloading V6? I did when reinstalled V6 on my second computer. I then got notification about needing a license for the zoo. My solution was to back out and try an alternative (not clicking on “Login”) which asked for a registration key or similar. It was in an email from Brian Gillespie titled “Your Rhino WIP license key”. I don’t remember if it also appeared on the screen during the download process.

The Zoo is a system for license sharing among multiple users in an office, school, etc. So if an office has twenty potential users but only a maximum of six users will be using Rhino simultaneously they can buy six licenses and install the Zoo to share the licences. Not needed for individual users.

Ok - i got all that sorted by downloading the latest wip (thanks david)…

However, when it does start it throws up an error over a messed up display (screen grab in zip file).
the ortho viewports are black, the perspective viewport looks like its shaded, and i can rotate it etc, but it wont maximise, and very soon the whole thing crashes…

crash dump in zip file

cheers
rabbit

20417.ZIP (14.7 MB)

We think we’ve finally identified the issue that you are having with your computer just fixed it over this weekend. Fingers crossed, you’ll have a working V6 with the next update.

Thank you Steve - I’ll let you know how I get on

Cheers
rabbit

So WIP 4/4/2017 fires up fine, and everything appears to work in wireframe, shaded, ghosted, x-ray and technical display modes.
Switching to render or any of the others locks not only rhino but the whole computer; the only way out is to actually turn it off with the power switch…

So it’s definitely progress, but not an actual functional result.

Cheers
rabbit

—Sent from mobile device & email—

Hmmmm…just loaded a small (1meg) file into it, and it’s just locked the whole computer right up immediately- I’ve taken a photo of the screen on my phone - it appears to be a maxed viewport of the right view, but you can see a viewport trying to exist bottom right…

Sigh…
rabbit

—Sent from mobile device & email—

Thanks for testing; sounds like we are making some progress here. If you run “TestGlWarnings”, do you get an error dialog when you attempt to load the file that locks up Rhino?

This testglwarnings is a toggle right? It was already enabled.
Anyway, with it on (after restarting) I chose to open the file from the splash screen:
The command line reads “successfully read file” blah blah and then on the 2nd line it reads "name of file to open (updatepromptupdate blocks=yes Browse):

And the whole computer locks with the 4view all black…

cheers
rabbit

—Sent from mobile device & email—

Hi @rabbit,

How long did you wait for Windows/Rhino to respond after the computer froze? I noticed you have a 9 years old GPU, so I could expect some complications when doing some once-per-session preprocessing on the GPU when switching to rendered mode.

I know it sounds boring, but could you try waiting around 5 minutes to see if your system then unfreezes? I’d like to know whether this is just very slow or a bug.

-David