Display Modes Not Working

unhandled
v6_display

#1

Display Modes error, most options of the display modes aren’t working, Pen, Technical, Arctic, Artistic, Raytraced, Render. The wireframe, ghosted, and xray seem ok ??? I have checked the same models in V5 and everything is fine. In v6 this has just happened and I can’t seem to get them to work, this is a big issue for me as I use Pen & Technical display lots, can someone please advise ?? cheers :slight_smile:


(Brian James) #2

My guess is you have an old graphics card driver installed. Choose System Info from the Help menu in Rhino 6 and paste that in reply here. v6 may require an update to the driver.


#3

It was fine up until yesterday, system info -
Rhino 6 SR4 2018-4-10 (Rhino 6, 6.4.18100.1591, Git hash:master @ b6485d60ae29d5ee76751120dc9232f8b172e934)
Licence type: Evaluation, build 2018-04-10
License details: Cloud Zoo. In use by: Miles Dexter ()
Expires on: 2018-05-09

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-DRIAS5A

Intel® HD Graphics 630 (OpenGL ver:4.4.0 - Build 21.20.16.4627)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build 21.20.16.4627
Driver Date: 3-9-2017
Driver Version: 21.20.16.4627
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\mdexter\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


(Brian James) #4

Here’s a link to Intel’s driver downloads for your GPU.


I’d try installing the latest one at the bottom of the page with Rhino 6 closed. You might have to restart Windows 10 as well. I’m not sure what changed on your system between when technical modes were working in v6 till now. It may have been a Windows update or the Rhino 6.4 update that is now requiring that the GPU driver be updated.

Any luck?


#8

no, seems to have done nothing, the only display modes that work are shaded, ghosted, wireframe and xray, the rest just default to wireframe, :frowning:

Rhino 6 SR4 2018-4-10 (Rhino 6, 6.4.18100.1591, Git hash:master @ b6485d60ae29d5ee76751120dc9232f8b172e934)
Licence type: Evaluation, build 2018-04-10
License details: Cloud Zoo. In use by: Miles Dexter ()
Expires on: 2018-05-09

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-DRIAS5A

Intel® HD Graphics 630 (OpenGL ver:4.5.0 - Build 22.20.16.4836)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 22.20.16.4836
Driver Date: 10-17-2017
Driver Version: 22.20.16.4836
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\mdexter\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


(Brian James) #9

Which installer did you use on that link, the one from 2017 or 2018? Did you also restart Windows? Also, do you have any Windows updates waiting to be installed and have you checked your Windows update history to make sure nothing failed recently?

@jeff any other ideas?


(Steve Baer) #10

Do these display modes work when you are NOT in a detail viewport? I’m asking because that looks like the problem based on your screenshot. If they do work, then your display driver is not the problem and we need to look somewhere else.


#11

the display modes do not work in either model space or a layout detail


(Jeff Lasor) #12

Hi @milezee,

I’d like to step back a bit and start from a very simple test case…

  1. Close down any and all rhinos you may have running.
  2. Start Rhino
  3. Go into Options->View->Display Modes, and confirm that all your modes are at their defaults (i.e. you don’t see any blue entries). Note: If any are blue, click the “Restore Defaults” button to reset them…then exit the Options dialog.
  4. Draw a sphere… I want a sphere because the screenshots that you post will tell me a lot more.
  5. In the Perspective view, set the display mode to Shaded. What do you get? (screenshot would be good).
  6. Set the display mode to Rendered. What do you get? (again, a screenshot will be helpful).
  7. Once in Rendered mode, go to the Display Panel and UNCHECK the “Shadows” setting. Any different?
  8. Next, set the display mode to Technical…what do you see?
  9. Lastly, go into Options->View->OpenGL and get a screenshot of what it shows. I realize you’ve already posted system info…but I want to see what Rhino’s OpenGL mechanism reports.

Thanks,
-Jeff


(Nathan 'jesterKing' Letwory) #13

FWIW I use Rhino with the exact same Intel GPU. As far as I can tell, with defaults, it draws all modes correctly.


#14

Jeff, when I’m back at my PC tomorrow I’ll run the checks and get back to you, cheers


(Jeff Lasor) #15

Also, I’d like you to do this…

Go to the Render Tab and UNCHECK the “Skylight” setting… (see image)
image

…and then try the different display modes and see what you get.

Thanks,
-Jeff


(Jeff Lasor) #16

Thanks @nathanletwory, that is good info. What driver are you on? Milezee seems to be running 10-17-2017 x 22.20.16.4836.

And does Rhino’s OpenGL page report the same caps as Milezee’s?

Thanks,
-J


(Nathan 'jesterKing' Letwory) #17

I have to check tomorrow. Just before leaving the office today I temporarily plugged my monitor into the Nvidia card, and forgot to move it back to the Intel GPU.


#18

Jeff, when I looked at the display modes in Options, all display types were in blue, as if they had been custom set, I’m pretty sure the only display modes I customise are Pen and Technical. I’ve had numerous crashes too this morning, when working between model & layout space, using different display modes in detail windows. The Skylight option was unchecked. Below is a series of screenshots you requested. I have also noticed my L/H sidebar is displaying wrong too. It does right itself after clicking different toolbars.


(Nathan 'jesterKing' Letwory) #19

I have a newer driver version:

image


#20

hi Nathan, have you experienced any issues ? If not do you have a link to the driver you have installed ? cheers


(Nathan 'jesterKing' Letwory) #21

Well, I still get the occasional crash in the driver. I know where it happens, not why - so we haven’t been able to fix it really. But otherwise the viewport modes draw correctly AFAICT.

I noticed there is an even newer driver: https://downloadcenter.intel.com/download/27650/Graphics-Intel-Graphics-Driver-for-Windows-15-65-?v=t


(Thomasmax7892) #22

Thanks for sharing us its really useful link friend. :slightly_smiling_face:


#23

@jeff @nathanletwory my Rhino has progressively got worse, pretty much unusable now, will have to revert back to Rhino5 to get work done :frowning: