WIP Display issue on Intel GPU


#1

(Was going to add to this thread, but I this is a different problem, don’t want to interrupt that)…
So, I’m running a 5 yo intel GPU, and since the first version of the WIP, the letters on the axis icon, and the information on fillets, chanfers and etc it’s blurry…
Tried again today whith TestGLCoreProfile Enabled and Disabled, still nothing…
I guess my chip is probably not supported, but I was wondering if there’s anything I and others running more humble machines do about it…
I mean, Rhino was always AWESOME in running on old hardware with poor specs…
Thanks


(Steve Baer) #2

There are two things you can try in this case

Update the driver and see if that improves things. The specs for the version of OpenGL that driver is reporting is for an older version of OpenGL than what drivers are typically supporting nowadays. Intel has made pretty good improvements in their drivers in the last few years.

If that doesn’t work or you don’t want to update your drivers, then you can use an alternate algorithm we have in Rhino for drawing text. Run the command “TestGlyphy” to turn off our advanced glyph rendering shader. I have actually been thinking of turning our glyphy shader off completely for drivers that don’t support at least OpenGL 3.3


#3

Thanks Steve!
“TestGlyphy” just changed the look on the text made with the “Text” tool, that works with no problems.
The world axis text and the text values on fillets and etc. remain are not affected and remain blurred…
My CPU/GPU drivers are as updated as they can be :sweat: (the last one is from 01/2012, I can understand why it may not work…)