Rhino Licence Firewall

Just stumbled upon this beauty. All ports open outbound on Router

Any Urgent help would be appreciated.

Bit more info - Cannot also log into my Licence Account

Does Anyone know how to make a R6 3dm into R5 without Rhino 6 as I can use 5 as a fallback.
Failing that is there a way to convert a 3dm to Fusion ?

Logging into my Rhino account works for me here, so the server seems to be up… maybe a local problem? What kind of error message do you get when trying to log into your Rhino account?

No, this is not possible.

It think I know what has happened. After a repair install all worked OK. I think my malware software saw the licensing service as a threat and killed it. Just posting in case anyone else has the issue,

1 Like

This licencing problem has cropped up again and the repair install did not work this time. This is really impacting on my ability to work. All outbound ports on my firewall are open. Does anyone have a wild guess of what is wrong ?

Hi Des,

I don’t have an answer, but I can suggest some diagnostics thoughts. Apologies if you have already been through all this.

You don’t say whether this happens every time you start Rhino or intermittently. If every time then you need to check firewall logs on both router and pc. My antivirus replaces the Microsoft firewall with its own so don’t forget to check for logs there if yours does the same. If intermittent it is more likely to be a connectivity issue.

Does the same thing happen if starting Rhino in safe mode? I get one less remote connection occurring in safe mode suggesting that a plugin might be contacting base. (In safe mode Rhino connects to servers at Amazon, Automattic and Microsoft; in normal mode it also connects to one at Google). Good idea to eliminate plugins as a cause.

What changed on your PC around the time the problem cropped up again? Windows update? Rhino update? AV update?

Thanks for the tip Jeremy

I tried safe mode, no luck
It happened in November but a reinstall fixed it, I tried a reinstall this time no luck. I’m guessing it has to call back to base every x amount of days and now it wont communicate. I’m running the bog standard windows defender and their is no port blocking on outbound connections.

From my reading (yet the documentation is sparse) it uses port 80 and there is no restrictions on that outbound.

It is now a constant issue. I get the error when starting and then it is a constant loop.

I have had to dust off old knowledge and go back to Fusion 360 as I simply cannot work. I would prefer Rhino but… what else can I do ?

Thanks for your help


The connections I see all use port 443 apart from the one to the Google server.

But I reckon you’d be better off emailing Rhino Tech Support directly on this one - it probably needs them to remote onto your machine to understand and resolve.

Thanks Jeremy

I have sent an email previously but am still awaiting a reply


Looks like I’m not the only one, brace for a storm folks

This has been confirmed by IT, Rhino is not send a request to the licensing servers.

I don’t understand this comment. I can interpret it as:

“IT has confirmed that our firewall is blocking all licensing request from Rhino.”
“IT has confirmed that by inspecting our network logs, no requests have been sent to the licensing servers from Rhino.”

Can you please provide more details?

When things are truly wrong on our end, we get a storm. It’s calm and sunny here today, figuratively.

Wireshark logs show the request is not being sent but it adds an error in the windows log (See Thread Mentioned Above) IT= Information Technology (Department)

Star date 210519. Error still occurring, have managed to almost do a slight bit of my job by finding my old key and working offline. No response from support but will still offer what I can to resolve the problem. Here is the windows logs.

I’m glad it is sunny and calm where you are Brian but I can tell you it is far from that from where I am sitting at the moment.


It could be that because of your network security settings, you may not get to use the Cloud Zoo tools.
There are a few larger companies like Hewlett Packard that are in this situation.
Perhaps a LAN Zoo would serve your needs better.

Maybe @brian has some other ideas.

Thanks John for the reply but other users are having the same issue. From what I know from the IT guys I paid to look at this to try and get me working, the logs indicate that a windows 10 update has beaten the Rhino licensing server. I work from home and have bog standard router which has been working for years. The IT company disabled every firewall and NAT rule and still no luck.
On a side note I’m not that impressed that support has even tried to contact me.

Going down the tubes Des

I can’t help you.
This is a thing for @brian and @aj1

Hi @des,

Have you tried restarting your computer and only running Rhino 6 once without any other programs (ideally any unnecessary background processes as well)? I have had an experience with another customer where other programs were somehow blocking Rhino from contacting our servers.


Another thought: do you have IPV6 enabled on your network adapter as well as IPV4? If you have and don’t need it, try disabling it, restart your PC and run Rhino.