Unable to connect to Rhino Account - Rhino won't start

I’m unable to get Rhino 6 running on my home PC. I’ve tried repairing R6 SR12, uninstalling it, downloading SR14, installing it. Nothing works to get the License to my Rhino Account to work.

The Windows log shows the following exceptions when I try to connect to my Rhino Account:

  • Unable to bind to the underlying transport for [::]:1719. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine. The data field contains the error number.
  • Unable to bind to the underlying transport for [::]:1718. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine. The data field contains the error number.

It appears to just keep cycling between tcp ports 1717, 1718, and 1719. But is unable to connect to the Rhino License server. My Rhino Account login works here fine.

I also do NOT have the Windows Firewall enabled.

Running Windows v1809 (build 17763.503)

Any ideas?

My guess is a Windows reboot will sort the problem.

Any luck?

Still not working after a reboot.



I did have IPv6 enabled, but disabling it, did not help.

This all worked a month or so ago, I don’t normally run Rhino on my home PC, but I need to for testing purposes, our software releases next week.

Any help is greatly appreciated.

P.S. If you need any logs or other info please let me know.


Hi @jstevenson,

Here’s a possible workaround you might try. I don’t know if it will help as I don’t have the problem myself…

Right click the windows icon and open ‘Windows PowerShell (Admin)’.
At the PS prompt type (or paste)

netsh http show iplisten

and hit return. This will almost certainly return an empty list. If it should show a double colon


stop now and exit powershell, you already have the setting I am suggesting.

Otherwise at the PS prompt type

netsh http add iplisten ipaddress=::

and hit return. Then see if you can start Rhino successfully. If not then the workaround hasn’t helped and you should remove it by typing at the prompt

netsh http delete iplisten ipaddress=::

and hitting Return.
Finally exit from Powershell.

Let us know if this works.


n.b. The double colon is definitely an IPV6 pattern (meaning any IPV6 address).

Did you get a resolution to this problem as I have the same thing occuring

Thank you for the information, it did not however solve my problem. The :: entry was not there, I added it per your instructions. Rebooted. And it still failed to work.


Can you have a look at this one please?

I did just solve the problem. However I’m not certain which change actually solved the issue, I suspect it was the Hyper-V Virtual Ethernet Adapter causing the problem.

I have 3 Network Interfaces, a TAP-Windows Adapter V9, a Realtek PCIe GBE Family Controller, and a Hyper-V Virtual Ethernet Adapter. All 3 interfaces were enabled, however the TAP interface showed Network Cable Unplugged so I don’t believe that was the issue.

Either way I disabled both the TAP and the Hyper-V Adapter and then tried launching Rhino. This time Rhino opened up my Web Browser as expected and allowed me to use my Rhino License.

Hyper-V Virtual Ethernet Adapter appears to be the culprit. I suspect somehow your code is looking for a specific network adapter, and is choosing the wrong device. Then fails to get access to the network.

I don’t see any way to Logout or Disconnect my license so I cannot give you a definite answer on which change fixed the issue.

Hi @jstevenson,

Sorry it didn’t help in your case, but glad to see you’ve subsequently found a solution.

FYI, the issue isn’t going to be the Hyper-V virtual Ethernet Adapter per se - I have one on each of my PCs and don’t have the problem - although it may of course be related to its configuration.

I think Rhino tries to connect to the Licence Server each time it is started, so you should be able to re-enable both adaptors and see Rhino fail again, then disable each one in turn to find out which solved the problem. (Though I quite understand if you prefer not to jeopardise your now-working setup by making changes…)


1 Like

Nope. Re-enabling them, and it stays authenticated. But the disable definitely fixed the issue.

I fixed mine but not sure which step was effective.
As suggested by jstevenson,
I disabled all network interfaces other than the physical one, but nothing happened.
I run ‘netsh winsock reset’, but nothing happened.
Then I restarted my computer, and it worked.

Also I did not find any log in Event Viewer.

Restarting your computer should be fairly high on your general troubleshooting list, along with making sure your operating system is up to date (Check for Updates).

For Rhino accounts licensing to work, Rhino.exe needs access to these 3 URLs. These not not normally be blocked unless you are behind a really locked down firewall:

I’m having the same problem. When I start Rhino 6, a dialog tells me that I need to log into my account in order to get a license. When I do, nothing happens and the dialog persists in telling me to login.

My license is an NFR. It’s listed on the Licenses page (Rhino Accounts)

I have R6 installed on a laptop upstairs and it’s working, so I’m not sure, but I suspect I’m running afoul of the “new” (to me) licensing model.

Any help would help.

hi @cestes001 can you first check if you have the latest Rhino 6 installed?

Gija is right. First make sure you’re running the final Service Release 35 for V6.
If the problem persists, report back and I give you the details to delete the local LIC file so you can update it.

When you login, does your account tell you there is a license available, you click on it, and are directed to go back to Rhino.
Then Rhino tells you there is no license and you need to login again.

Are you being directed back and forth in this never ending loop?

That worked for me. Thx, you two.