Rhino encountered a problem and needs to close

Hey there,

I was working with Rhino 6 for the past year now with no major problems.
During the last few days however, I am constantly running into the same problem.

While opening Rhino 6, it suddenly crashes and tells me that there is a problem and therefore have to get closed.

I digged through the topics and found ideas from @John_Brock here .
I updated both the Nvidia and Intel Drivers but the problem is still there. I also can’t run a SystemInfo in rhino safe mode as the program crashes as well.

The AOC Monitors does not have any specific firmware and can’t be get updated.

Thank you in advance for your help!

Hi Dominique -

Do you know what changed on your system? An update of the Windows OS? New hardware? A new program that was installed?

Do you start Rhino with the Rhino shortcut on the desktop or by opening an existing file, or…?

Does that mean that Rhino starts correctly in safe mode but that it crashes when you run the SystemInfo command?

Can you describe your hardware configuration? Are you running a desktop or a laptop? Do you have one or several monitors attached, and, if so, to which ports on your PC?
-wim

Hey

I didn’t change anything on my PC. Software and Hardware are the same.
I initially recognized this error when starting an existing file but now, I also tried to start the application from the desktop symbol and from the windows drop down menu - nothing changed.

It starts correctly in safe mode - but after initializing the system info, the program crashes down.

I am running a MSI GS 85 with an RTX 2080 and an Inten UHD 630 + working with two displays (AOC U2777PQU).
The Hardware is all connected through an i-tech docking station.

Dominique

Hi -

I take it that’s a laptop.
What happens when you disconnect all external monitors and only run Rhino on the laptop screen?
-wim

Yeah you are right - sorry for the confusion.

I disconnected everything and rhino started with no problems.
So therefore, it has something to do with the external devices.

Do you need further information in order to specifically know the problematic device?

Dominique

Hi Dominique -

Please run the Rhino SystemInfo command now and copy-paste that information here. I understand that that won’t give the exact same information as when you have devices connected but it’s a start.
Also, please specify what type of cable goes from which port on the PC to what device.
@jeff has been looking into connected hardware a lot lately and perhaps your detailed information rings a bell.
-wim

Hey Wim -

In the following, you can find the SystemInfo:


Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Educational, build 2020-08-25
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: MSI

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2080 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version: 27.21.14.5671
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Dominique Lehmon\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\PanelingTools\2018.12.17+906\PanelingTools.rhp “PanelingTools”


My two monitors are connected to the docking station with a display port.
From there, the display port is connected to my lapotp with a USB-C cable.

Hope this helps.

Dominique

Thanks.
Could you please connect the monitors again and make Rhino crash?
When you see the dialog box for the crash reporter, don’t send it in just yet. Minimize all your programs and go to the desktop. There should be a crash dump file there. Please copy that and send it here.
When you close that dialog box, the crash dump file will be deleted from your desktop.
-wim

@Dominique_Lehmon
I suspect one of two possible “bad” third-party utilities are causing this because you are using a docking station.

This has shown up recently on ASUS laptops:

We have seen this very similar issue for a while now too:

These performance settings are important too:

See if you have either one of these problematic tools running, and if removing them solves your problem.

Any luck?

Hi @Dominique_Lehmon,

How are you connecting the external monitors? Through some docking station or some kind of USB port device? Please provide the make and model of all your devices.

Thanks,
-Jeff

Hi @Dominique_Lehmon,

Could you please do the same thing when running Rhino in SafeMode and then run the SystemInfo command? I want to make sure the two different crashes are the same thing…

Also note: We’re looking for the RhinoCrashDump.DMP file (note the extension .DMP), and not the .3dm file… It should be somewhere on your desktop if you haven’t closed the Rhino Crash Report dialog.

Thanks,
-Jeff

Hey @wim, @John_Brock and @jeff

Thank you for your help! :slight_smile:
I will be back at the office tomorrow and immediately recreate the crash.
In addition to this, I will follow the instructions and give you feedback if one of the provided approaches fixes the problem.

Hey,

attached you find both Crash Files:
Dump Files.zip (14.7 MB)

I will also try the steps from @John_Brock next.

Dominique

Hey John,

I deactivated the Nahimic Service and restarted the PC but rhino still doesn’t work…
Couldn’t simply delete it.

Best,
Dominique

You have to uninstall the Realtec High Definition Audio Device so you can stop the Nahimic Service. Otherwise it will restart when you restart.
This is detailed in the forum post:


image

Hey John,

i deleted the Realtek Audio but after restart, it appeared again in the device manager.

Do you have any clue on how to make sure that it will be deleted permanently?

Dominique

The OS is always going to try to install drivers for a discovered piece of hardware…unless it is explicitly “Disabled”…However, I’m not sure you want to disable his audio device. It’s not RealTek that’s the problem, is the crappy software by Volute… You need to remove or disable that software, but it can be difficult to locate… It might be running as a service.
See this post:

Any luck?

Hi @Dominique_Lehmon,

Thanks for the dump files… Unfortunately all they show is that the Intel drivers are crashing immediately. So whatever Rhino is doing during its device collection process is causing the drivers to puke.

At this point I would try completely removing the Intel GPU and its drivers from your system using the DeviceManager… and then let Windows reinstall drivers for it automatically. If you’re not sure how to do that, let me know and I’ll post the steps.

Thanks,
-Jeff

Hey @John_Brock, i disabled the Nahimic but nothing changed. I also located the .exe but wasn’t able to delete it since it is used although no major programm is running. Probably some backround processes…

@jeff, it would be great if you could provide some information about removing the drivers. Thanks :slight_smile:


BTW: I am currently working at home with just a second monitor and rhino is running perfectly fine.

Then most likely it’s not really disabled… You really need to figure out how to get that software removed. Since you’ve obviously located the .exe, what folder is it in? That might indicate what else to look for.

Perhaps some screenshots of Windows “Uninstall” dialog, showing the installed programs would help us identify what really needs to be uninstalled. It’s hard to know since ASUS (and Volute software) keep changing the name of the program and DLL files.

Thanks,
-Jeff