Rhino crashing on startup

When I launch Rhino I get a window saying “Rhino encountered a problem and needs to close”. Today I’ve downloaded grasshopper patterns but I don’t believe that’s the issue. When Rhino crashed, I was downloading Bifocals on food4rhino. I have tried uninstalling and reinstalling Rhino and I’m still facing issues. I need Rhino ASAP as I have an assignment due Thursday, please help!

Hello -

Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

Does Rhino start? If so please run SystemInfo and post the results. Also please be sure that your video drivers are up to date, from the Intel/nVidia/AMD websites as appropriate.

-Pascal

Hey,

I am able to run Rhino in Safe mode. Question for this, am I able to do everything as normal through safe mode?

Also, here’s my SystemInfo

different systeminfo… please open rhino and run the systeminfo command- then past the result here.

systeminfo.txt (1.3 KB)

Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03001, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Evaluation, build 2020-11-09
License details: Cloud Zoo
Expires on: 2021-02-14

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y). OpenGL Ver: 1.1.0

Secondary graphics devices.
NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 11-6-2020 (M-D-Y).

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 10-28-2020
Driver Version: 27.20.100.8935
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20314.3001

Hi -

No, you won’t. In Safe Mode, plug-ins are not loaded. This includes certain plug-ins that ship with Rhino by default. Among other things, this means that you won’t be able to work in any shaded display mode.

At any rate, we’re seeing a lot of these issues in the past week or so and have now found that it is caused by a combination of an update to the latest Windows 10 version and drivers for the on-board Intel UHD Graphics 630 chip.

We are working on finding a way around this Microsoft bug and should be having a new build out within the next week if all goes fine. Until then, you can either roll back your Microsoft Windows update from 10.0.19042 to, e.g., 10.0.18363 or disable your Intel GPU in the Windows device manager. If you have an external monitor (i.e. not a laptop’s own display), make sure that is not connected to the HDMI port of your machine but directly to the NVIDIA card in your machine.
-wim

1 Like

Awesome, thank you! I disabled the Intel GPU and it’s back to working.

2 Likes

Hi again -

I’m happy that got you on the road again.
Would you mind describing your system a bit more? Is it a desktop or a laptop machine? Are you connected to external screens? If so, did you also connect the screen (or one of the screens) to a different port on your machine when you disabled the Intel GPU?
Thanks!
-wim

It is a desktop, connected to a monitor. I didn’t connect the screen to a different port when disabling intel GPU. I just disabled it and was able to access rhino.