Crashing Upon Start Up


#1

Hi,

My laptop seems to have an issue with Rhino 5, I run a windows 10 software on a MSI GS40 Phantom Laptop. It’s strange because when I first downloaded and installed Rhino there were absolutely no issues for the first time. Today, I’ve just received a report saying

“Rhino has encountered a problem and needs to close” along with a send error report

Tried updating my drivers, tried to run it on safe mode, 32-bit, 64-bit, none of it works

computer is definitely a high performance one with 16gb ram with an intel 530 HD driver as well as a NVIDEA GEFORCE GT970M one.

Processor is an i7 skylake 6700-hq 2.70 GHZ

I’m quite nervous because I need Rhino to help with an assignment for my university and it’s due pretty soon! It’s never happened on a previous laptop I had (also updated to windows 10 before I switched), only this one…

Tried re-installing it as well, no dice

seeing if it could be anything to do with virus and double checking the outdated softwares to see if theres anything else I can do

Any help would be great, thanks!


(Wim Dekeyser) #2

It’s not clear to me if it also crashed in safe mode.
Also, which of the GPUs does Rhino report on the OpenGL page?


#3

Hi wim,

its also crashed on safe mode

I’m not sure how to check which of the GPUs the rhino report lists on the openGL page

Sorry, new to this

Thanks

timothy


(Wim Dekeyser) #4

If it crashes in safe mode you won’t be able to check which GPU is used. I’m not on a PC at the moment but I think you need to dive into the driver settings for the NVIDIA card. If you search here on discourse, I’m sure you will find some information about this.


#5

Hi wim,

Thanks for the advice, i’ve tried out some of the stuff about driver settings on discourse and i dont think im getting anywhere with it yet…


(Pascal Golay) #6

@Timothy_Huang - I responded to you via your note to tech@mcneel.com - not very usefully, yet, I’m afraid, but we have not forgotten you.

-Pascal


#7

Hi Pascal,

Thanks! Sorry for the sense of urgency on my end,

I’m in the middle of my university term and having rhino up and running would be of great help!


(Kelvin Cheng) #8

@Timothy_Huang found Nahimic audio software coming on the MSI laptop caused Rhino to crash. Disabling its application makes Rhino stop crashing. Thanks for sharing the information with us.


(Biagiomoro85) #9

Hi Kelvin

I seem to be having the exact same issue, tried reinstalling and everything with no luck…

I am running the latest version of rhino 6 for windows, and my setup is

laptop hp omen 15-ce0xx
windows 10 home 64bit
16gb ram
intel core i7-7700HQ
GeForce GTX 1050

everything updated with the latest driver

The only thing that I can point out is that I’ve had audio problems as well, which I tried to solve by reinstalling the intel graphics driver since it contained audio drivers as well, although my driver is realtek high definition audio, and for some reason it wasn’t showing up at all in the list.

Reinstalling the video driver didn’t solve the missing audio, but realtek somehow reappeared on its own after a few days, now the audio works but rhino doesn’t anymore…

Thanks, any help is appreciated!


(Pascal Golay) #10

Hello - if you are running V6, please run the SystemInfo command and post the output here. Does Rhino start in Safe Mode (Windows Start menu, type ‘Rhino 6 in Safe Mode’)?

-Pascal


(Biagiomoro85) #11

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Evaluation, build 2018-09-28
License details: Stand-Alone
Expires on: 2018-12-31

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-H3KEH3ST

GeForce GTX 1050/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.36)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-24-2018
Driver Version: 24.21.13.9836
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Biagiomoro85) #12

Hi Pascal, thank you! trying to run safe mode, I’ll let you know if it still crashes…


(Biagiomoro85) #13

It seems to be running without issues in safe mode, even when I say yes to loading this plugin: RhinoRender.rhp


(John Brock) #14

Please run Windows’ Device Manager and expand the Display Adapters section.
I suspect there will be two; your nVidia GeForce and also an Intel somethingorother.
Right-click on the Intel, choose Properties and click on the Driver tab.
Please send a screenshot of that dialog.


(Biagiomoro85) #15

Thanks! I hope it’s the right one…


(John Brock) #16

Yup, and that’s an old driver for it.
See if this new update sorts your problems:


(Rob McPherson) #17

@John_Brock

John,

Quick question for you.

I’ve just disabled my Intel graphics on my laptop because the switching between Nvidia and Intel was causing issues with my ICEM Surf - but now Rhino will only start in safe mode. Does Rhino need the Intel graphics to be working in order to start normally?

Regards,

Rob.


(John Brock) #18

I think so, but I’m not a display developer.
As part of how Windows works, I think Windows control some of the interface display and uses both the Intel and nVidia adapters.

It may be possible using a nvidia tool to specify which display adapter an specific application uses.
You might see if you can find the tool and configure it to use the nVidia adapter for Rhino instead of letting Windows do the switching automatically as is usually the case.


(Rob McPherson) #19

Ok, thanks, will see what I can find.


(Biagiomoro85) #20

You were absolutely right, that was an old driver! And now everything seems to be working perfectly, so thanks a lot! I would never have guessed it since I had just installed it and it seemed to be the latest…
Thank you very much, have a great day!